Server 2008 Local Policy: Log on as batch job "Add user or group" button inactive

Discussion in 'Windows Server' started by Jim in Arizona, Mar 13, 2009.

  1. In setting up a scheduled task on my Windows Server 2008 Standard machine, I
    have to give an account the local police of 'Long on as a batch job'. To do
    so, I go to Administrative Tools -> Local Security Policy, right click on
    that and chose Run as Administrator. The Local Seucirty Policy window comes
    up. Then, under Security Settings --> Local Policies --> User Rights
    Assignment, I double click on the policy called 'Log on as a batch job'. The
    window opens showing what users have that right. However, the button called
    'Add User or Group...' is grayed out.

    How do I fix this issue?

    TIA,
    Jim

    --
     
    Jim in Arizona, Mar 13, 2009
    #1
    1. Advertisements

  2. Hello Jim,

    Is the machine domain member? Then configure the policy with GPMC in the
    domain.

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], Mar 13, 2009
    #2
    1. Advertisements

  3. Yes, that's what I had to do was configure the Domain Controller Policy
    using GPMC then force an update for the Local Policy to show the change. My
    backup worked at that point.

    Thanks.
     
    Jim in Arizona, Mar 13, 2009
    #3
  4. Hello Jim,

    Nice to hear that you solved it.

    For additional settings i suggest that you do not ouch the Default policies,
    either DC or domain. Create a new one and link it also the OU, so in case
    of failures or problems you can just delete the new created ones and have
    only the default policies in place which are error free.

    Best regards

    Meinolf Weber
     
    Meinolf Weber [MVP-DS], Mar 14, 2009
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.