Server Error 403-Forbidden: Access Denied

Discussion in 'Windows Update' started by E. (Izzy) Schultz, Dec 11, 2009.

  1. Not sure if this is the right place or not.
    Went to microsoft update and got the following message

    Server Error 403-Forbidden: Access Denied
    You do not have permission to view this directory or page using the
    credentials you supplied.

    OS is WinXP pro/SP3.
     
    E. (Izzy) Schultz, Dec 11, 2009
    #1
    1. Advertisements

  2. Is Automatic Updates enabled? If not, can you enable it, reboot & find it
    still enabled?

    What anti-virus application or security suite is installed and is your
    subscription current? What anti-spyware applications (other than Defender)?
    What third-party firewall (if any)?

    Has a(another) Norton or McAfee application ever been installed on this
    machine (e.g., a free-trial version that came preinstalled when you bought
    it)?
     
    PA Bear [MS MVP], Dec 11, 2009
    #2
    1. Advertisements

  3. E. (Izzy) Schultz

    aragorn Guest

    Today I got the same error 403 all of a sudden...I did not install anything
    new and yesterday I could still update...hm?
     
    aragorn, Dec 11, 2009
    #3
  4. E. (Izzy) Schultz

    aragorn Guest

    OK
    I fixed it!
    I checked the windows update log file [%windir%\Windowsupdate.log] and found
    that I had a wrong wuweb.dll file...
    I downloaded the latest windows update agent file and now I am back running..
     
    aragorn, Dec 11, 2009
    #4
  5. E. (Izzy) Schultz

    dipswitch Guest

    Hi aragorn,
    Because here is the same issue: how did you know you had a wrong wuweb.dll
    file and where did you download the latest windows update agent file?

     
    dipswitch, Dec 11, 2009
    #5
  6. E. (Izzy) Schultz

    gmoss Guest

    Yeah, man, I was JUST getting the same message. I've never in my life
    received that before. I don't have any antivirus running and I have not made
    any insstallations of any kind in the past few days. I don't have automatic
    updates enabled because I always check manually.
     
    gmoss, Dec 11, 2009
    #6
  7. E. (Izzy) Schultz

    Neil Guest

     
    Neil, Dec 11, 2009
    #7
  8. E. (Izzy) Schultz

    Neil Guest

    Neil, Dec 11, 2009
    #8
  9. E. (Izzy) Schultz

    dipswitch Guest

    I found the answers myself and it fixed this problem here too!
    In the log file it says:
    FATAL: Update required for C:\WINDOWS\system32\wuweb.dll: target version =
    7.2.6001.788, required version = 7.4.7600.226
    And a new wuweb.dll I found at
    http://msdn.microsoft.com/en-us/library/aa387285(VS.85).aspx. Direct URL's:
    WSUS here is distributing 7.4.7600.226 since the last few days
    x86
    http://download.windowsupdate.com/w...one/7.4.7600.226/windowsupdateagent30-x86.exe
    x64
    http://download.windowsupdate.com/w...one/7.4.7600.226/windowsupdateagent30-x64.exe
    Itanium
    http://download.windowsupdate.com/w...ne/7.4.7600.226/windowsupdateagent30-ia64.exe

     
    dipswitch, Dec 11, 2009
    #9
  10. Any respons from MS yet when they will fix their Update Site not to kill our
    clients?

    I've blocked the MS Update Site until further notice in my firewall nit to
    break any more clients.
     
    Dennis Lindqvist MCT, Dec 11, 2009
    #10
  11. That is exactly what we did here. It is absolutely right. The problem went
    away once si updated the DLL.

     
    Ivaylo Krumov - MCSA, Dec 11, 2009
    #11
  12. I am having the same issue (Windows XP SP3) and it started sometime after
    3:00 PM CST on the 10th. I updated 20 PCs before then with no problem. I
    tried to update more later on and that is when I started having problems.

    Updating the Windows Update agent fixed the problem, but for me the install
    package would actually update the files, I ahd to manually copy them from a
    PC with the right versions.

    What a pain in the !@#.

     
    Thomas Heikkila, Dec 11, 2009
    #12
  13. E. (Izzy) Schultz

    adminwendy Guest

    this is happening to hundreds of computers at multiple businesses here.
    Server 2003 and XP are affected. obviously no one is going to update several
    hundred computers. microsoft needs to fix this.
    perhaps updating the dll or agent would fix it, but this is 100%
    unacceptable as this is affecting large scale numbers of pc's. techs like
    myself are unable to manually update that many computers, not enough
    resources.
     
    adminwendy, Dec 11, 2009
    #13
  14. E. (Izzy) Schultz

    ToddH Guest

    I already had wuweb.dd version 7.4.7600.226 but still received the error. I
    simply turned on the Automatic Updates option (was previously off) and
    rebooted. Microsoft Updates is now working.


     
    ToddH, Dec 11, 2009
    #14
  15. E. (Izzy) Schultz

    James Guest

    Many thanks, and yest they need to fix this!!

    Funny thing is, I was trying to check for Updates for my server that runs
    WSUS when I encountered this...
     
    James, Dec 11, 2009
    #15
  16. E. (Izzy) Schultz

    txgrl1977 Guest

    Wow, dipswitch....thanks a million!!!

    This worked for me as well.

     
    txgrl1977, Dec 11, 2009
    #16
  17. Actually. Just running Auto Update instead (or after) fixes the problem.
    If you like to force Auto Update to run imedeatly use

    wuauclt.exe /detectnow

    If you are using a proxy hoowever, it van't use the user settings.
    Configure it with proxycfg

    proxycfg -u

    Copies the current user settings to the system.
     
    Dennis Lindqvist MCT, Dec 11, 2009
    #17
  18. E. (Izzy) Schultz

    G Guest

    FYI: I just tried Microsoft Update and it's down for me (12-11-2009 10:00am
    California Time).
     
    G, Dec 11, 2009
    #18
  19. E. (Izzy) Schultz

    Frost Guest

    Repro, from Spain.
     
    Frost, Dec 11, 2009
    #19
  20. E. (Izzy) Schultz

    Viola Guest

    I got the download and it worked.
    Thank you Dipswitch

     
    Viola, Dec 11, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.