Setting process priority so it runs when screen is locked

Discussion in 'Windows Vista Performance' started by P Adhia, Apr 13, 2009.

  1. P Adhia

    P Adhia Guest

    Hello Experts,

    I run some CPU intensive processes (video encoding using X264) in a
    command shell. Since I don't want it to affect my normal foreground
    applications, I set it to IDLE/BELOW_NORMAL priority using Process
    Explorer. However, when I lock my screen (manually or automatically
    after some idle time), the encoding virtually stops. When I unlock my
    screen, I can see from recent history that CPU was idle instead of
    being utilized to run the encoding process. What can I do to ensure
    that my background encoding process continues to run even when I am
    away from the computer (the screen is locked), but at the same time
    not affect any foreground applications if I happen to be using the
    computer?

    Thanks

    P Adhia
     
    P Adhia, Apr 13, 2009
    #1
    1. Advertisements

  2. It is not a good idea to reduce the priority to below normal or idle. It
    would tell the CPU to execute the application with this priority only when
    there is no other process running at a higher priortiy than idle or below
    normal, hence your application will never get a chance to execute since there
    will be atleast one process running at a priority higher than below normal.


    Check
    http://technet.microsoft.com/en-us/library/cc958314.aspx
    http://technet.microsoft.com/en-us/library/cc938611.aspx
    http://blogs.technet.com/markrussinovich/archive/2008/09/24/3126858.aspx
     
    Gurpreet Singh, Apr 14, 2009
    #2
    1. Advertisements

  3. Get a more powerful CPU and more RAM (8 gig). Use Vista 64 bit operating
    system.
     
    Richard Urban, Apr 14, 2009
    #3
  4. P Adhia

    P Adhia Guest

    Probably I wasn't clear in my previous email. I have adequate CPU and
    memory. It's just that the encoding comes to crawl WHEN I "Lock
    Computer". It seems Windows gives minimum CPU time when screen is
    either locked or screen-saver is active, even though no other high
    priority processes are running.

    Thanks
     
    P Adhia, Apr 14, 2009
    #4
  5. P Adhia

    SC Tom Guest

    Have you checked your power options in Control Panel?
     
    SC Tom, Apr 14, 2009
    #5
  6. P Adhia

    P Adhia Guest

    Have you checked your power options in Control Panel?

    Right on target! I set my power profile to "Maximum Performance" and
    encoding chugs along nicely.

    Thanks
     
    P Adhia, Apr 15, 2009
    #6
  7. P Adhia

    SC Tom Guest

    Your welcome.
     
    SC Tom, Apr 16, 2009
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.