Setting up ISS-IUSERS when using a folder other than inetpub/wwwro

Discussion in 'Windows Vista Installation' started by Larry S., Mar 8, 2007.

  1. Larry S.

    Larry S. Guest

    When setting up IIS in Vista (Home Premium) on my new laptop, I moved the
    folder I use for my web pages to a subfolder of My Documents, instead of
    under inetpub/wwwroot. I did this to make it easier to include any web pages
    I have been working on when I do document backups. I use this server for
    development purposes only, so don't need to have it available to users on the
    Internet. I'm using Macromedia Homesite to develop and modify web pages.

    I have been using this kind of folder (i.e. under My Documents) for my web
    development pages for some time on my main desktop, which is still running
    Windows 2000, however on the Vista machine, it has resulted in an "Error 500"
    when I try to browse to localhost. Apparently, when setting up ISS, an
    ISS_IUSERS net user is set up for wwwroot only. How can I set this user up
    for the actual folder I use? ISS_IUSERS doesn't show up in the control panel
    user account menu at all, but it does appear when I check the properties in
    the wwwroot folder.
     
    Larry S., Mar 8, 2007
    #1
    1. Advertisements

  2. Larry S.

    Joe Guidera Guest

    Do you mean grant the IIS_USERS account access to your newly created folder?
    Try right clicking on the folder and choosing properties.

    Joe
     
    Joe Guidera, Mar 8, 2007
    #2
    1. Advertisements

  3. Larry S.

    Larry S. Guest

    The only place the IIS_IUSERS account appears is in the inetpub/wwwroot
    folder, where it is apparently created automatically by IIS installation. It
    doesn't show up anywhere else, including in the control panel/user account.
    I assume that if I could find out how to create an ISS-USERS account for the
    folder I want to use I could then set the properties for it, but I don't know
    if it would be enough to simply create an account by that name manually, or
    if it has to have some special properties that only can be created by the
    system that let localhost access it. Right clicking on it in the
    inetpub/wwwroot folder doesn't seem to do anything for the folder I want to
    use, and right clicking on that folder, doesn't allow seem to allow for any
    connection to IIS_IUSERS.
     
    Larry S., Mar 9, 2007
    #3
  4. Larry S.

    Joe Guidera Guest

    You don't create it as a user. It's a special account. RIGHT click on the
    folder you want to grant access to IIS and choose properties. Select
    Security. You can then select ADD and browse and you will see the IIS_IUSR
    account.

    J

     
    Joe Guidera, Mar 10, 2007
    #4
  5. Larry S.

    Larry S. Guest

    Eureka! It works. Joe, thanks for your help. There is one more question I
    would like to ask. I want to make sure that by doing this, I'm not leaving
    myself vulnerable to outside penetration of my website directory, especially
    since I have directory browsing enabled.

    Since this site if for local development only, and the pages will then be
    FTP'd up to the hosting site, I don't want to allow ANY outside access over
    the Internet. Sharing is turned off in the new root web directory I'm using.
    Is this enough, or is there anything else I need to do (or make sure I don't
    do!!!) so that access is confined to my local machine only? Thanks.
     
    Larry S., Mar 10, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.