Sharepoint 2424 errors yet again

Discussion in 'Windows Small Business Server' started by Martin, Sep 14, 2009.

  1. Martin

    Martin Guest

    I apologize for bringing up this subject again. Unfortunately I am not
    getting anywhere trying to follow the various fixes I found online. This
    probably a reflection of my limited experience with SP (and SBS 2008 for that
    matter).

    My Sharepoint installation is part of the Small Business Server 2008
    package. Everything is installed on a single server in the default
    configuration. We are running WSS 3.0 SP2 and .net 3.5.

    I get the 2424 Event every five minutes. From what I read, I should switch
    the Content Access and Service Accounts to read only domain accounts that are
    not part of the administrator group in order to resolve this issue.

    To do so, I created two new accounts, SPContent and SPSearch, in AD. I can
    switch the Content Access account over to SPContent without problems, but
    that does not eliminate the 2424 error.

    If I try to switch Service Account to any domain account, I get the
    following error: "Could not access Search service configuration database."

    Something clearly isn't right with the permissions. Any ideas what I am
    doing wrong?

    Thank you!

    Martin
     
    Martin, Sep 14, 2009
    #1
    1. Advertisements

  2. Martin

    Martin Guest

    I think I found a solution to this problem. All the components are well
    documented, but it took me a long time to put it all together. Below is a
    list of steps I took to get it to work. Perhaps they will save someone a bit
    of time.

    We have a SBS 2008 Standard installation on a single box. Apparently there
    are more issues if all components are installed on a single box.

    In the default configuration the Sharepoint Search doesn't work. The indexer
    produces 2424 errors in the event log (The update cannot be started because
    the content sources cannot be accessed. Fix the errors and try the update
    again.) whenever it attempts to crawl the database. The event log shows that
    the search account cannot log into the database.

    Steps to fix this:

    1. Create two new accounts using 'Active Directory Users and Computers.' I
    called one SPsearch and the other SPcontent. As far as I could determine,
    SPSearch needs to be part of the Domain Admins group in order for the next
    steps to work. The account can be added to this group through its Properties
    context menu. The other account doesn't need any special permissions. I set
    up both accounts so their passwords don't expire.

    2. Open Sharepoint 3.0 Central Administration. Under Operations/Services on
    server click on Windows Sharepoint Services Search. Change the service
    account to SPsearch and the Content Access account to SPcontent.

    3. Go to Site Settings, then People and Groups. Add SPsearch to the Farm
    Administrators group. (A lower permission level may work. I didn't try.)

    4. Restart IIS. You should still get 2424 errors, but if you look in the
    sharepoint logfile you should see that the search account is now able to log
    into the database.You should now see something like 'Server
    remote.contoso.com:987 security initialization failed' in the error log.

    5. The remaining problem is caused by the a safety feature in SBS 2008 that
    is intended to prevent denial of service attacks. You can disable this
    feature for you URL by following these steps:

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3. Right-click MSV1_0, point to New, and then click Multi-String Value.
    4. Type BackConnectionHostNames, and then press ENTER.
    5. Right-click BackConnectionHostNames, and then click Modify.
    6. In the Value data box, type the URL (something like
    remote.contoso.com), and then click OK.
    7. Quit Registry Editor, and then restart the IIS service.

    For me this fixed the problem.

    Martin
     
    Martin, Oct 8, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.