show desktop doesn't show gadgets

Discussion in 'Windows Vista General Discussion' started by kerry, Aug 14, 2007.

  1. kerry

    kerry Guest

    Hey, the show desktop icon is pretty neat... I have brand new laptop and want
    to use the show desktop icon to quickly access my sidebar/gadgets. But only
    the left hand icons appear. So I moved the gadgets off the sidebar, closed
    it and still the gadgets don't show. Why would microsoft tease me like
    that?.. what is the point of gadgets if I can't get to them easily and
    quickly? But if I minimise everything, then the gadgets on desktop show.. but
    then what's the point of the quick access icon...
    kerry, Aug 14, 2007
    1. Advertisements

  2. kerry

    Robert Firth Guest

    Well, the gadgets aren't technically on the desktop - they aren't part of
    explorer.exe. The sidebar program is separate. I know that doesn't help you,
    but I thought it might help you to know that it is normal and why. I agree
    with you though, when I first tried it I expected the same.

    Robert Firth
    Robert Firth, Aug 14, 2007
    1. Advertisements

  3. kerry

    oscar Guest

    I've noticed the same thing: if I click on Show Desktop on taskbar, the
    screen will show the desktop but not the sidebar and gadgets. I have to go
    back to another window, minimize it to get gadgets back on desktop. I see no
    reason why Vista should be doing this. This seems to be poor software
    development which is another example of why a recent survey revealed that
    almost 47 % of current Windows users will not upgrade to Vista. 47 %! Is
    Miscrosoft paying attention?

    Besides a couple other quirks, my Vista machine works like a charm.

    oscar, Nov 25, 2007
  4. kerry

    Rick Rogers Guest


    "Show Desktop" does just that, it clears the desktop, whether you use the
    icon or WindowsKey+d. If you want to just minimize the open Windows without
    removing the Sidebar, use the WindowsKey+m to minimize. It's done this way
    by design.
    Rick Rogers, Nov 25, 2007
  5. I too kinda find this annoying, it seems the Sidebar is just a regular old
    window which contains these separate applications, so as long as you run the
    show desktop command, you will get this effect.
    Andre Da Costa[ActiveWin], Nov 25, 2007
  6. kerry

    brink Guest

    Hi Oscar,

    You can make the Sidebar not disappear by right clicking the Sidebar
    tray icon and click Properties. Then, check "Sidebar is always on top
    of other windows" and click OK. This will allow the Sidebar to stay
    when you click "Show Desktop", but it will also always be on top to.



    *There are no dumb questions, just the people that do not ask them.*
    *Please post feedback to help others.*
    brink, Nov 25, 2007
  7. kerry

    lforbes Guest

    In another post it said that the Windows key + Spacebar brings up the
    Sidebar. This is how I now get it back after Minimizing.

    Personally I think the sidebar needs to be like Desktop Icons and not an
    application. I use the "Minimize" or "switch" ALL the time. However ALL my
    icons are on a Gadget Bar launcher so I have to use the shortcut to get it
    lforbes, Dec 26, 2007
  8. kerry

    booglypoo Guest

    You can create a VBScript to open the sidebar back up automaticall
    after it closes due to the show desktop procedure. Just follow thes

    You need to create three files
    Shortcut to ShowDesktopSidebar.vb

    1) Open up notepad and create ShowDesktop.scf

    2) Open up notepad and create ShowDesktopSidebar.vbs
    Dim WshShel
    Set WshShell = WScript.CreateObject("WScript.Shell"
    WshShell.Run "ShowDesktop.scf",
    WshShell.Run """C:\Program Files\Windows Sidebar\sidebar.exe""",

    3) Create a shortcut to ShowDesktopSidebar.vb
    Right click on file and choose 'Create Shortcut'

    4) Change icon of shortcut to the "show desktop" icon
    Right click on shortcut, Properties, Change Icon..., scroll to th
    right just a bit and you'll see the "show desktop" icon, choose it an
    click OK

    5) Move shortcut to Quick Launch area on Taskbar
    Right click on shortcut and drag it to the Quick Launch area, releas
    click and choose 'Move Here'

    That's it! Done

    It has the same functionality of clicking on the "show desktop" icon
    and then clicking on the sidebar icon in the tray, as was a suggeste
    solution. The limitations of this solution, just like the manua
    version, is that if you click on the desktop afterwards, the sideba
    disappears. But if say you open a minimized window (and don't click o
    the desktop), then the sidebar will stay up

    Make sure you keep the .scf and .vbs files in the same directory, jus
    hide them somewhere not on the desktop

    The real solution is for Microsoft to fix this problem by adding a
    option for the sidebar to always be on top of the desktop, but not o
    top of other windows. This is not hard to do at all (for the OS), i
    just needs to be done (by them). So Microsoft, just do it already
    booglypoo, Apr 14, 2008
  9. kerry

    lforbes Guest

    Thanks. I am familiar with vbscript so I will definitely try this out.

    lforbes, Apr 15, 2008
  10. kerry

    Wikijonhenry Guest

    How about clicking on the sidebar icon on the taskbar and having the
    gadgets appear on the page your working as both attached and unattached
    will appear or should come up for your use as was designed? You
    shouldn't need to show desktop for the
    use of sidebar.
    Wikijonhenry, Dec 8, 2008
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.