Sid Meier's Civ 4 and 2K

Discussion in 'Windows Vista Games' started by Zagnoc, Apr 11, 2009.

  1. Zagnoc

    Zagnoc Guest

    I've had several months of back and forth with 2k about Civ 4 with no
    results about 2 error messages I received while using my Home Premium
    Vista. The 1st error message came when I tried to start using Civ 4
    again after several weeks of not playing, the message said:
    "Cannot locate the CD-Rom"
    "Please insert the correct CD-Rom, select ok and restart application."

    To myself I said no biggie I will just uninstall and reinstall that
    should solve the problem and run my registry cleaner and file search
    programs to clear out the corruption as well as defrag but upon
    attempting to uninstall I received this message:
    Error Code: -5004 : 0x80041f42
    Error Information:
    *C:\Program Files\Common
    Files\InstallShield\Professional\RunTime\12\00\Intel32\iKernel.dll
    PAPP:Sid Meier's Civilization 4
    PVENDOR:Firaxis Games (##IDS_PRODUCT_URL##)
    PGUID:CFBCE791-2D53-4FCE-B3FB-D6E01F4112E8
    $11.0.0.28844
    So I contacted 2K and they gave all kinds of excuses as to the problem
    and how to fix it. None of which worked. I've also reinstalled DX9.
    The problem redirects me to InstallShield where I find no help cause
    they refer me back to 2K with the message that 2K has formatted a
    corrupted InstallShield file into there disc.
    Needless to say 2K has not answered back on this nor will they
    acknowledge that is the problem yet admantly say their game is Windows
    compatible (bah humbug) definitely not with Vista.

    So any help would be appreciated.

    I've also found I've a problem with compatibility with my Civ 3
    Complete but at least I can play it whereas Civ4 is unplayable now.
     
    Zagnoc, Apr 11, 2009
    #1
    1. Advertisements

  2. Just FYI,
    For Vista and upcoming Win7, the OS keeps different
    locations for files and saved games for different
    profiles and permissions when installing and running.
    Run game same account as you installed it for
    best performance.
    ie: Install under Admin account and set game
    link icon under 'compatibility' section to 'run
    as administrator'..should keep all files together.

    'Seek and ye shall find'
    NT Canuck
     
    remove_ntcanuck, Apr 14, 2009
    #2
    1. Advertisements

  3. Zagnoc

    Zagnoc Guest

    I've done that and much more but still unable to uninstall the game or
    play it because the Cannot locate disk. What I have found out is that
    Microsoft has posted on their site that all of Civ3 and Civ4 except for
    BTS are incompatible with Vista. Due to some failure in the software
    files DX9 and InstallShield used by 2K. So needless to say since all my
    favorite games are listed as incompatible with Vista. I've proceeded to
    reformat all my computers back to Windows Xp. Vista is like ME to me a
    total waste of money and time to deal with. The only thing I found
    workable was the picture show and video part all the rest was a major
    foul up and not made to be compatible with gaming.
     
    Zagnoc, Apr 14, 2009
    #3
  4. Zagnoc

    Paul Smith Guest

    Civilization IV works fine on Windows Vista.

    The error you mention is typical of the copy protection being tripped up,
    sometimes as a result of installing a Virtual CD/DVD drive software.

    Running a registry cleaner is a bad idea, and defragmenting will have no
    effect at all on this.
     
    Paul Smith, Apr 14, 2009
    #4
  5. Zagnoc

    Zagnoc Guest

    Well no matter because I went to Microsoft and found they've listed Sid
    Meier's Civ 4 as not compatible with Vista.
    Also, I've not installed anything such as Virtual, it just stopped
    working when I went back to play.
    But, again no matter. I've put Vista in the box with all the other bad
    software I've bought over the years. I've tried to load my Windows XP
    on to that computer but Vista shut it down literally, so now I'm in the
    process of letting a pc tech remove Vista from my machine.
    'Windows Vista Compatibility Center'
    (http://www.microsoft.com/windows/compatibility/Default.aspx?type=Software)
     
    Zagnoc, Apr 14, 2009
    #5
  6. Zagnoc

    Paul Smith Guest

    Microsoft's job isn't listing compatibility with all the millions of bits of
    Windows software out there.

    They're simply repeating what the publisher lists as supported, and
    supported doesn't mean compatible or not, just if its supported or not. But
    I can tell you now I've been playing Civ 4, original version with and
    without all expansion packs on Windows Vista with no issues since 2006.
     
    Paul Smith, Apr 15, 2009
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.