Sidewinder Strategic Commander problems

Discussion in 'Windows Vista Hardware' started by Racquel, Feb 14, 2007.

  1. Racquel

    Racquel Guest

    My list of problems just keeps growing and growing. I am trying to install
    the controller onto my Vista system & have encountered several problems. The
    latest problem is while attempting to install the software, the
    "installshield" application stops working almost instantly when it appears to
    be completeing installation ... then there are 2 choices I am given, one is
    to close the program & the other is to check online for a solution. Needless
    to say, the button for checking online yields no results . To address other
    problems, previously I was able to install the CD up to the point where it
    would check the connection of the device to the USB but didnt recognize it
    (USB port is active the working & computer itself recognizes the device &
    that it was 'installed' properly) & also at another time I received an error
    message that 'critical system files are missing or corrupted' (to try to fix
    this based on microsofts suggestion of installing it as an administrator
    doesnt work either) . I am at my wits end w/this thing... Can anyone help?
     
    Racquel, Feb 14, 2007
    #1
    1. Advertisements

  2. There has been no official support for this device for some while.. you may
    have to call time on it.. there are other gaming devices out there that may
    or may not get continued support..
     
    Mike Hall - MS MVP Windows Shell/User, Feb 14, 2007
    #2
    1. Advertisements

  3. Racquel

    turbotoes Guest

    Don't panic, just follow the instructions this post I made a couple of weeks
    ago and all will work beautifully I promise. Since then I've also used it in
    gothic3 and splinter cell double agent.

    turbotoes


    Well having spent most of the afternoon moping about it I actually got the
    sidewinder to work, it’s quite simple.
    Install the sidewinder software, at a certain point you will be asked if “
    you really want to quit the setup program?†say yes.
    Tootle off to the folder in which you installed the software and drag
    “DEAMON14†into startup and you might as well get yourself a shortcut to the
    program itself on the desktop while you are at it.
    Now get yourself off to Device manager by your favourite route. Under the
    heading “Human Interface Devices†you will see two ( maybe more) items. The
    ones we are interested in are
    Usb Human Interface Device, this equals your strategic commander
    And
    HID compliant device, this little fellow will become ms sw strat com hid
    drivers
    Two other devices will appear as we get the drivers installed, these are ms
    virtual keyboard and ms virtual mouse, hoorah.
    So to get the little devils working like you want, right click on the “Usb
    Human Interface Device†choose “update driver software†then click “browse
    my computer for the driver softwareâ€
    Then click “ let me pick from a list of device drivers on my computer†then
    you will be given a list in that list will be “ Microsoft strategic
    commander†click on that, followed by “next†around this point you will get
    the usual warning that the driver is unsigned click on “install anyway†or
    the equivalent there of!!
    Rince and repeat for the HID compliant device and when you have done that
    you will find that the virtual kb and mouse will have appeared, you should
    not have to change their drivers. Windows will tell you that you need to
    restart your computer (that has not changed) and when you reboot your strat
    comm should work!!!
    You will need to repeat this process if you change usb ports, I’ve tested
    it in guild wars and nwn2 and all was fine.

    turbotoes
     
    turbotoes, Feb 15, 2007
    #3
  4. Racquel

    Racquel Guest

    Thank you so much.. I was finally able to get the program to install (that
    was one of my biggest problems) and when it did, I followed your instructions
    & now it works perfectly! :) Thanks again ... Racquel
     
    Racquel, Feb 21, 2007
    #4
  5. Racquel

    Jones Guest


    Wait... just a second!

    Are you telling us that you managed to install and run the drivers and
    profile software for the sidewinder strategic commander on Vista X64??
    I mean, not Vists 32, it really runs on the X64 version this way?
    REALLY????!!! :eek: Completely running, like it did on win2k, with
    buttons and the three movement axes?

    Please please please confirm that you were talking about the X64!
    Please!!
     
    Jones, Mar 14, 2007
    #5
  6. Racquel

    ~USM~Tomza Guest

    I have tried to install the strategic commander on the 64 vista versio
    with no workable results, a call to microsoft produced no results, the
    were suprised it could be installed on the 32bit vista OS. I suspect i
    has to do with signed drivers. If any one figures it out Please post ho
    it can be done, Thanks
     
    ~USM~Tomza, Apr 6, 2007
    #6
  7. Racquel

    Oaken Guest

    Unfortunately I'm not having nearly as much success. I've done the
    install up until the point indicated, dropped a shortcut to Daemon14
    into my Shortcut folder, and managed to force the HID and USB device
    drivers for my device to the Strategic Commander versions. So far so
    good although I did not get a request to reboot. But I reboot anyway and
    it all looks good (the buttons don't automatically light up on the
    controller like they used to on XP though). But when I try to run the SC
    application itself to make sure the right profiles are set up I get an
    error:

    "Critical system files are missing or corrupted.
    Please UNPLUG THE DEVICE and reinstall Strategic Commander software
    from the compact disc."

    Of course if I unplug it I lose the SC drivers and end up having to
    reassign those. And of course it works no better the second (or third or
    fourth) time around unfortunately.

    Any ideas?
     
    Oaken, May 6, 2007
    #7
  8. Racquel

    Babalou Guest

    Please please please .... do you really want to see a grown man cry:(

    I have the exact error when doing everything that has been suggested (I
    have to admit I was a bit hesitant about doing the changes stated as I
    had no real idea what I was doing, but the instructions were precise and
    very good) and the blasted error of corrupted thingy-ma-bobs comes up
    AAAAAAAHHHHHHH:eek:

    So if any very kind soul can take pity on a noob like myself and
    instruct us how to get my wonderful gadget to work again I would be very
    grateful

    Baba
     
    Babalou, May 11, 2007
    #8
  9. Racquel

    wido Guest

    Hi there
    be glad, you are not alone in this matter. I can't get it work either
    But the instructions say: virual kb and mouse, i do not see the virtua
    mouse. I do have the list with
    - ms S
    - ms S C HID driver
    - ms sidewinder Virtual Keyboar

    So do i mis something :confused:

    Wid
     
    wido, May 13, 2007
    #9
  10. Racquel

    turbotoes Guest

    Sorry I've been away. I have recently discovered that if you do not TURN OFF
    user account control, you will not get the device listing for the virtual
    mouse. I have no idea why only the v mouse if affected, but it is. tuun off
    UAC and all should be well. I hope I am not to late to help!!!!!
     
    turbotoes, Aug 7, 2007
    #10
  11. Racquel

    Rotorhead Guest

    PLEASE HELP TURBO.....

    I did the above before turning off the User Account Control, so I went back
    turned that off but nothing happened so I started uninstalling the HID
    compliant game controllers and devices and now I'm stuck with it displaying
    the Microsoft Strategic Commander under "Other Devices" with no HID options.
    I have tried reinstalling the drivers, but still get an error and it comes
    back the same way if I unplug and plug the controller back in, PLEASE HELP!!!!

    Thanks.
     
    Rotorhead, Sep 11, 2007
    #11
  12. Racquel

    turbotoes Guest

    Rotorhead: uninstall the strat comm from “programs and featuresâ€, reboot and
    start from scratch, following these instructions to the letter. If you then
    get an error message, let me know what it is and I will try to help. I now
    have four vista machines all a bit different and all have strat comms
    attached and working. So i can’t see why yours should not work.

    Okay, let’s start from the beginning.
    Turn off user account control, and make sure your account has admin
    privileges.
    Stick disk in cd drive, find and run setup.exe
    Follow instruction through, select region and all that stuff, accept the
    agreement, and to keep it simple the default location. You will then see the
    progress bar zip through installing the program files and then the profiles,
    at this point the setup will rudely ask “if you are sure you want to exit
    install ?†click yes.
    Now for the plugging in. Before you do, open up device manager (control
    panel, system, device manager) then click on the plus sign by â€human
    interface devices†- just to see what is there-
    Now plug in, you may or may not get a message about drivers being installed
    at this point, but you should get two new devices under the HID heading,
    1. HID-compliant device and
    2. Usb human interface device.
    Right click on HID-compliant device and choose “ update driverâ€
    Then click “ browse my computer for driver software,
    Then “let me pick from a list of device drivers on my computerâ€
    In the next window you will have a choice of - HID-compliant device
    Or - Microsoft SideWinder Strategic Commander HID drivers,
    Click the MS SW drivers, then next. You should then get a message telling
    you that “windows has successfully updated driver software†hoorah.
    You should now have two new devices under HID
    Microsoft SideWinder Strategic Commander HID drivers and
    Microsoft SideWinder virtual keyboard (you may also have Microsoft
    SideWinder virtual mouse, but not always?!)
    Now repeat the driver update for the “Usb human interface device.â€
    Once this is complete you may or -not- have to restart your pc. And then
    your strat comm should work fine.
     
    turbotoes, Sep 11, 2007
    #12
  13. Racquel

    Rotorhead Guest

    Turbo....

    YOU ARE THE MAN!!!!

    I thought I was going to have to throw my Strat Comm out the window, it
    would have been a sad day as I love this thing!!!! You should get paid for
    all the help you've provided in this forumn.

    THANKS AGAIN!!!
    Bryan
     
    Rotorhead, Sep 12, 2007
    #13
  14. Racquel

    turbotoes Guest

    ERR. actually I'm a girly, but glad to help!!!!
     
    turbotoes, Sep 12, 2007
    #14
  15. Racquel

    Rotorhead Guest

    Correction.....YOU ARE THE WOMAN!!!!

    Thanks again.
     
    Rotorhead, Sep 13, 2007
    #15
  16. Racquel

    Latharion Guest

    I just wanted to say how glad I was to find out there were others out there
    who still used the Strategic Commander and had gotten it to work in Vista! I
    followed the instructions and it worked like a charm! I really like my SC
    for more than just gaming (I use it in CAD drawing as well as Photoshop).
    Contrary to what the MVP stated, there really is no viable substitute out
    there at this time. The other solutions just don't have nearly the
    functionality. Thanks again, Turbotoes!
     
    Latharion, Sep 25, 2007
    #16
  17. Racquel

    Lucas Guest

    Help me... =\ I tried to do all the steps, but it didn't work here.
    Windows Ultimate X64, I disabled the UAC, did al the steps, but in the
    Device Manager, I couldn't find the driver for Strategic Commander, only for
    other stuff.
    "Select the device driver that you wish to install for this hardware:"
    "USB Human Interface Device" and if I uncheck the box: "Show compatible
    driver"
    A lot of another drivers will appear, but not Strategic Commander.
    In my Device Manager, I found
    +Humand Interface Device
    |_4: Humand Interface Device USB
    |_3: HID-compliant consumer control device
    |_2: HID-compliant device
    Any help ??
     
    Lucas, Oct 1, 2007
    #17
  18. I have the same result, even under the microsoft category there is no
    Sidewinder Strategic Commander device driver.
    I did the procedure several times now but I just cannot get to see the right
    device driver.
     
    GroeneGrasmat, Oct 4, 2007
    #18
  19. Racquel

    Lucas Guest

    I have the same result, even under the microsoft category there is no
    Yep... I did it several times too... no good results...
    And I tried a lot of other procedures, like other USBs, or forcing to use
    some microsoft driver, but no success...
     
    Lucas, Oct 4, 2007
    #19
  20. Racquel

    LastSon Guest

    Where all the people who got the SC to work on their Vista running the
    32bit version? If so, I'm either going to downgrade to Vista 32bit, or
    upgrade to Windows XP. The small advantages that Vista provides are
    SIGNIFICANTLY outweighed by the SC advatages.
     
    LastSon, Nov 1, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.