Sidewinder Strategic Commander problems

Discussion in 'Windows Vista Hardware' started by Racquel, Feb 14, 2007.

  1. Racquel

    Bone_Daddy Guest

    BODYPRINT

    Simply amazing. Well done. Please let me know if we can donate to th
    cause (via paypal or something). It is greatly appreciated
     
    Bone_Daddy, May 22, 2008
    #41
    1. Advertisements

  2. Racquel

    BODYPRINT Guest

    Hi guys.

    Sorry about the delay in updates. Time is my worst enemy !!

    I didn't get as much done as I had hoped I would, but still made alo
    of progress.

    So without further ado here is the list of updates...

    File Save and Load now completed. (Stored in My Documents\Strategi
    Commander\)
    Each Button now has a description which can be edited in the ke
    assignment section.
    New Function button setup. Can be mouse clicked or button clicked t
    open each section. (You'll see what i mean when you run it :p)

    I think this update makes it a fully useful tool. Still not where
    would like to be at though.
    As always, any bugs/suggestions would be very much appreciated.

    @Bone-Daddy, I'll test it in C&C 3 in the coming days and see if i
    works. And yes any donations would be much appreciated. Thanks :)
    wasn't really expecting anything, but I did have to outlay a little cas
    for the USB reading library.

    If anybody wants to donate just PM me and I'll give you my PayPa
    details

    +-------------------------------------------------------------------
    |Filename: StrategicSetupv0.4.zip
    |Download: http://vista64.net/forums/attachment.php?attachmentid=4025
    +-------------------------------------------------------------------
     
    BODYPRINT, May 22, 2008
    #42
    1. Advertisements

  3. Racquel

    Bone_Daddy Guest

    Update with testing Setupv0.4: I assigned the "H" key for button 2 an
    it did respond in C&C 3. I assigned the "END" key for button 5 and i
    did not respond in C&C 3. I reassigned the move buttons replacing th
    w,s,a,d keys with the arrow/direction keys (located below the "END" ke
    - not the number pad keys with arrow/direction keys on 8, 2, 4, 6). N
    dice. The move function emulated the number keys: 8, 2, 4, 6. It wa
    limited testing today. In the next few days, I'll try to load up a
    least 6-8 buttons and see what happens. Hope this helps in any regard
     
    Bone_Daddy, May 23, 2008
    #43
  4. Racquel

    BODYPRINT Guest

    Heres another quick update

    This should fix the problem Bone Daddy reported with certain specia
    keys not working. I needed to add an extension value for these keys

    If you come across any more please let me know. I think I've got all o
    the important ones

    Also let me know if it stuffs up any other keys

    NOTE: You will need to disable the Walk function for this to wor
    properly in C&C and any similar map type programs

    There will be another update soon. I'm not 100% certain the sav
    function is working properly. I'll also set the Walk function t
    disabled by default, considering the type of games this controller i
    mainly used for. I might also add a calibration option. Someone sai
    there's wasn't centered. I don't see how, but I'll add the featur
    anyway :

    See Ya !

    +-------------------------------------------------------------------
    |Filename: StrategicSetupv0.41.zip
    |Download: http://vista64.net/forums/attachment.php?attachmentid=4174
    +-------------------------------------------------------------------
     
    BODYPRINT, May 28, 2008
    #44
  5. Racquel

    BODYPRINT Guest

    Here's another update !! :party::party::party:

    IMPORTANT !! PREVIOUS PROFILE SAVES WILL NOT WORK !!

    In this update...

    Added Calibration (Tools menu)
    Profiles now save ALL settings. That includes Dead Zones,
    Enabled/Disabled Options and Calibrations.
    Default profile is now loaded at startup.
    Walk feature is now Disabled by default.

    I think that's all :)

    Next feature to pretty much bring this to what I feel is deserving of
    Version 1.0 is Key Combinations, of course. I've been avoiding this one,
    but it's time to nut it out I think.

    Once again, please report back to me how it's working for you all.
    Thanks.
    And a BIG thanks to the kind donators. You have been very generous :D

    Have Fun !!


    +-------------------------------------------------------------------+
    |Filename: StrategicSetupv0.5.zip |
    |Download: http://vista64.net/forums/attachment.php?attachmentid=4203|
    +-------------------------------------------------------------------+
     
    BODYPRINT, May 28, 2008
    #45
  6. Racquel

    Bone_Daddy Guest

    @ Body - Great release with .041. Can't wait to try this one! Tested the
    special keys and they are working. w00t! This is going to be huge.

    I have been reading so much from fans of the Strategic Commander that
    they won't upgrade to Vista because of the lack of support. Now they
    will have that option again with a great engine provided by BODYPRINT.
    Well done! I'll promote the hell out of this engine and hopefully get
    you some more donators.

    I'll be testing Counter Strike Source, Age of Empires: The Age of
    Kings: The Conquerors, and possibly Cod4.
     
    Bone_Daddy, May 28, 2008
    #46
  7. @Bodyprint

    thank you a lot for this great program. I thougt i have to sell my
    strategic comander. Then I read this forum. There I read that the
    comander is not able to be used in vista64.

    Now I found your program and it seems working fine. Now I will test
    with some games. By now, a big Thank You.

    Jaques-Ludwig
     
    Jaques-Ludwig, Jun 4, 2008
    #47
  8. Racquel

    Ravynmagi Guest

    I just tried version 1.0.

    I am able to set a sequential key macro successfully once. But if I
    open it again, I'll get this error.

    StrategicEngine

    Run-time error '340':

    Control array element '0' doesn't exist

    And the program closes.
     
    Ravynmagi, Jun 4, 2008
    #48
  9. Racquel

    Ravynmagi Guest

    Also would it be possible to disable the move up, down, right, and lef
    function of the device? I never liked that particular feature since th
    entire thing would slide around the desk anyway

    For now I've just set the dead zone as large as possible
     
    Ravynmagi, Jun 5, 2008
    #49
  10. Racquel

    Ravynmagi Guest

    First I launch the Strategic Engine 1.0
    Then I click on button 1 under the F1 section (same thing happens wit
    other buttons too, so this is just an example)

    '[image: http://www.dragonbytes.org/images/strategic/Image1.jpg]
    (http://www.dragonbytes.org/images/strategic/Image1.jpg

    Then I give it a name, select Key Combination, then choose Shift and 1
    Then click OK

    '[image: http://www.dragonbytes.org/images/strategic/Image4.jpg]
    (http://www.dragonbytes.org/images/strategic/Image4.jpg

    Now back at the Strategic Engine I say, "Oops, I wanted something els
    for that key", so I click on the "Test" button (previously named "1
    under F1)

    '[image: http://www.dragonbytes.org/images/strategic/Image5.jpg]
    (http://www.dragonbytes.org/images/strategic/Image5.jpg

    And then boom. The error

    '[image: http://www.dragonbytes.org/images/strategic/Image6.jpg]
    (http://www.dragonbytes.org/images/strategic/Image6.jpg
     
    Ravynmagi, Jun 5, 2008
    #50
  11. Racquel

    Ravynmagi Guest

    PS. That is also with a new profile
     
    Ravynmagi, Jun 5, 2008
    #51
  12. Racquel

    Bone_Daddy Guest

    I'm actually exited to see what you learn from the course. ^^ Should be
    interesting.
     
    Bone_Daddy, Jun 8, 2008
    #52
  13. Racquel

    shinyhalo Guest

    Please include a way to insert a "pause" of varying miliseconds between
    key combinations so that we can program "combos" for games like Age of
    Conan.
    Thanks!
     
    shinyhalo, Jun 9, 2008
    #53
  14. Racquel

    shinyhalo Guest

    Age of Conan uses some pretty long macros and the timing of button
    presses differs as well.
    I can accomplish some things by using two different methods.

    Method 1 Sequence Mode example: F2
    1111111111111111111111111111111111111111111111111111111111111112
    Method 1 explanation: Basically you need to delay the pressing of "1"
    and "2" for awhile after pressing "F2" so the numerous "1"s succeed in
    that goal.
    Pros: very stable. never ceases functioning
    Cons: doesn't allow for anything more complex than three button combos,
    if a combo gets interrupted sometimes the game character stands there
    executing each "1" press and you can't do anything else

    Method 2 Sequence Mode example: F2 [Delay 1 second] O [Delay 250ms] 2 1
    Pros: can create complex macros like the above and maybe even more
    complex that still actually work in-game
    Cons: often ceases functioning altogether with game not registering ANY
    sidewinder button presses. Exiting Strategic Engine and restarting it
    fixes this. This strange event never ever happens unless the [Delay]
    commands are used.
     
    shinyhalo, Jun 20, 2008
    #54
  15. Racquel

    shinyhalo Guest

    I wish I could duplicate it that precisely, but it's unpredictable. I'
    say the sidewinder+Strategic Engine stops sending commands to the Age o
    Conan software about once every 45 minutes. Alt-Tab, exit Strategi
    Engine, restart Strategic Engine usually fixes this

    One profile that freezes up is here
    http://members.cox.net/shinyhalo/Conqueror2H.se
     
    shinyhalo, Jun 22, 2008
    #55
  16. Racquel

    shinyhalo Guest

    lol, I guess I don't know for sure! Will test right now. I was wrong
    Method 1 can be used to make more complex macros.

    For example, I just pulled this 4-button-press one off
    F3QQQQQQQQQQQQQQQQQQQQQQQQQQQQQQQ222222222222222222222

    This will help some though there is still the Con/ of interrupt
    potentially causing the character to execute each of separate commands

    Basically, you watch the animation and add letters until you see th
    movement being performed then move to the next command and add repeat
    until that movement is performed. The repeats allow for the built-i
    delay requirements of Age of Conan to be met
     
    shinyhalo, Jun 22, 2008
    #56
  17. Racquel

    shinyhalo Guest

    It occured to me that maybe the problem is I am using XP Pro 32 bit an
    this is a Vista forum lol
     
    shinyhalo, Jun 23, 2008
    #57
  18. Racquel

    shinyhalo Guest

    1. M$ software setup is tricky. I have to "force" install drivers fro
    the Device Manage
    2. The M$ software lacks an option for Mouse Wheel Up/Down and thi
    game is so complex that I need every possible input option. lo
     
    shinyhalo, Jun 23, 2008
    #58
  19. Racquel

    shinyhalo Guest

    Could you please add a single delay button duration 1.5 seconds?
    I've been experimenting and the freeze ups don't occur when there is
    only one delay command in the macro. However, the Age of Conan combos
    require a 1.25-1.5 second delay.

    Thanks.
     
    shinyhalo, Jul 2, 2008
    #59
  20. Racquel

    Cyberjudas Guest

    I have been searching for your files but cant find the download anywhere
    please post or pm so i can try this awesome software. All the links give me a
    404 error. Thanks
     
    Cyberjudas, Jul 5, 2008
    #60
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.