Sims 1 and Vista Home Premium

Discussion in 'Windows Vista Games' started by cstotler1, May 15, 2007.

  1. cstotler1

    cstotler1 Guest

    I have all the expansion packs and the Sims Deluxe Edition and I wanted to
    put them on my new computer, which came with Vista Home Premium, and NOTHING
    is working correctly. I found that my other games I can run them as an
    adminstrator and they work fine, but not in this case. If anyone has ANY
    suggestions please let me know. It would be greatly appreciated!
     
    cstotler1, May 15, 2007
    #1
    1. Advertisements

  2. cstotler1

    Andy Guest

    Might try plopping down $19.99 for The Sims 1 Complete Collection. It's the
    Sims 1 with all expansions and updates. I haven't tried it on Vista, but
    it's been updated to new paths that're more WinXP friendly.
     
    Andy, May 23, 2007
    #2
    1. Advertisements

  3. cstotler1

    leighpea Guest

    I bought Sims I Complete Collection, it played fine for a few times, and now
    it shuts itself down while loading. There is no error message. I've
    uninstalled and reinstalled and it still does not work. Help?
     
    leighpea, Feb 16, 2008
    #3
  4. cstotler1

    That Guy Guest

    try right clicking icon, properties, compatibility mode, xp.
     
    That Guy, Feb 18, 2008
    #4
  5. cstotler1

    Andy [YaYa] Guest

    Compatibility mode as ThatGuy suggested is good.

    Update your video/audio card drivers. Did you install any software since the
    last time you played? Sometimes new programs cause other programs to fail.
    Windows has been getting a lot of updates recently. That could be it.

    -A.
     
    Andy [YaYa], Feb 19, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.