Sims not working

Discussion in 'Windows Vista Games' started by rockonzombie, Mar 28, 2007.

  1. rockonzombie

    rockonzombie Guest

    I just bought a new computer with windows vista and I'm unable to play any of
    my sim games. I tried switching to windows xp compatibility mode but that
    didn't help! I bought this computer so I could play my sim games and I was
    told by Best Buy that they would work fine. Well they were wrong and I'm
    going to let them know that but if anyone could help me I would appreciate it!
    Thanks,
    rockonzombie
     
    rockonzombie, Mar 28, 2007
    #1
    1. Advertisements

  2. rockonzombie

    Dale White Guest

    well, Sims 2 works fine for the Girlfriend.

    I guess we need a little more info. Like what's in your sysem Graphics card
    wise.

    Also, when you say you can't play. Does that mean you were able to install,
    but can't play or can't install ?

    If it installed, but won't play Did you try right clicking on your desktop
    shortcut and choose Run as Administrator ?

    A little more detail about what exactly is going on would help
     
    Dale White, Mar 28, 2007
    #2
    1. Advertisements

  3. rockonzombie

    LadyRoot Guest

    If you're asking if Sims2 work, the answer is yes.
    The only thing you should do is to install the latest software update (the
    file thesims2_update.exe can be downloaded from the official web service
    thesims.com).
     
    LadyRoot, Mar 28, 2007
    #3
  4. rockonzombie

    Betty Guest

    I bought a new computer from Best Buy in February with Vista Ultimate on it
    and they told me the Sims would play okay. I haven't tried installing The
    Sims 1 games but I have The Sims 2 plus all expansion packs working just
    fine. At first, I did have problems but when I updated my video card driver,
    that solved the biggest problem.

    Tell us exactly the problem you're having and your computer information and
    maybe we can help you further.

    Betty
     
    Betty, Mar 28, 2007
    #4
  5. rockonzombie

    cdkscully Guest

    I too cannot play the sims.

    It worked fine for 5-7 days and then it crashed.

    These are the specs of my system:

    ------------------
    System Information
    ------------------
    Time of this report: 4/14/2007, 00:50:46
    Machine name: CDKSCULLY
    Operating System: Windows Vistaâ„¢ Home Premium (6.0, Build 6000)
    (6000.vista_rtm.061101-2205)
    Language: English (Regional Setting: English)
    System Manufacturer: alienware
    System Model: alienware
    BIOS: Phoenix - AwardBIOS v6.00PG
    Processor: Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz (2
    CPUs), ~2.1GHz
    Memory: 2046MB RAM
    Page File: 1131MB used, 3176MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 10
    DX Setup Parameters: Not found
    DxDiag Version: 6.00.6000.16386 32bit Unicode

    ------------
    DxDiag Notes
    ------------
    Display Tab 1: No problems found.
    Sound Tab 1: No problems found.
    Sound Tab 2: No problems found.
    Input Tab: No problems found.

    --------------------
    DirectX Debug Levels
    --------------------
    Direct3D: 0/4 (retail)
    DirectDraw: 0/4 (retail)
    DirectInput: 0/5 (retail)
    DirectMusic: 0/5 (retail)
    DirectPlay: 0/9 (retail)
    DirectSound: 0/5 (retail)
    DirectShow: 0/6 (retail)

    ---------------
    Display Devices
    ---------------
    Card name: NVIDIA GeForce 7900 GS
    Manufacturer: NVIDIA
    Chip type: GeForce 7900 GS
    DAC type: Integrated RAMDAC
    Device Key: Enum\PCI\VEN_10DE&DEV_0292&SUBSYS_C6233842&REV_A1
    Display Memory: 744 MB
    Dedicated Memory: 248 MB
    Shared Memory: 495 MB
    Current Mode: 1024 x 768 (32 bit) (60Hz)
    Monitor: Generic PnP Monitor
    Driver Name: nvd3dum.dll,nvwgf2um.dll
    Driver Version: 7.15.0011.0065 (English)
    DDI Version: 9Ex
    Driver Attributes: Final Retail
    Driver Date/Size: 2/10/2007 11:48:00, 4644864 bytes
    WHQL Logo'd: Yes
    WHQL Date Stamp:
    Device Identifier: {D7B71E3E-41D2-11CF-B35B-28E601C2CA35}
    Vendor ID: 0x10DE
    Device ID: 0x0292
    SubSys ID: 0xC6233842
    Revision ID: 0x00A1
    Revision ID: 0x00A1
    Video Accel: ModeMPEG2_A ModeMPEG2_C ModeVC1_B ModeWMV9_B ModeVC1_A
    ModeWMV9_A

    -------------
    Sound Devices
    -------------
    Description: Speakers (Realtek High Definition Audio)
    Default Sound Playback: Yes
    Default Voice Playback: Yes
    Hardware ID:
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0885&SUBSYS_10ECE601&REV_1001
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: RTKVHDA.sys
    Driver Version: 6.00.0001.5350 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 1/2/2007 17:41:00, 1668456 bytes
    Other Files:
    Driver Provider: Realtek Semiconductor Corp.
    HW Accel Level: Basic
    Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No

    Description: Realtek Digital Output (Realtek High Definition
    Audio)
    Default Sound Playback: No
    Default Voice Playback: No
    Hardware ID:
    HDAUDIO\FUNC_01&VEN_10EC&DEV_0885&SUBSYS_10ECE601&REV_1001
    Manufacturer ID: 1
    Product ID: 100
    Type: WDM
    Driver Name: RTKVHDA.sys
    Driver Version: 6.00.0001.5350 (English)
    Driver Attributes: Final Retail
    WHQL Logo'd: Yes
    Date and Size: 1/2/2007 17:41:00, 1668456 bytes
    Other Files:
    Driver Provider: Realtek Semiconductor Corp.
    HW Accel Level: Basic
    Cap Flags: 0xF1F
    Min/Max Sample Rate: 100, 200000
    Static/Strm HW Mix Bufs: 1, 0
    Static/Strm HW 3D Bufs: 0, 0
    HW Memory: 0
    Voice Management: No
    EAX(tm) 2.0 Listen/Src: No, No
    I3DL2(tm) Listen/Src: No, No
    Sensaura(tm) ZoomFX(tm): No

    ---------------------
    Sound Capture Devices
    ---------------------
    Description: Realtek Digital Input (Realtek High Definition Audio)
    Default Sound Capture: Yes
    Default Voice Capture: Yes
    Driver Name: RTKVHDA.sys
    Driver Version: 6.00.0001.5350 (English)
    Driver Attributes: Final Retail
    Date and Size: 1/2/2007 17:41:00, 1668456 bytes
    Cap Flags: 0x1
    Format Flags: 0xFFFFF

    +++++++++++++++++++
    These are the errors

    I was fine installing it the first time.

    Then When it crashed it gave me this error:

    Problem signature
    Problem Event Name: APPCRASH
    Application Name: Sims2.exe
    Application Version: 1.0.0.1022
    Application Timestamp: 433a2c18
    Fault Module Name: StackHash_0ad4
    Fault Module Version: 0.0.0.0
    Fault Module Timestamp: 00000000
    Exception Code: c0000005
    Exception Offset: 00000010
    OS Version: 6.0.6000.2.0.0.768.3
    Locale ID: 1033
    Additional Information 1: 0ad4
    Additional Information 2: a4f914ca25db0f7a78e5c08a9a96b2bf
    Additional Information 3: 2522
    Additional Information 4: e36a2b9657d31058566433ccf88c3771

    Extra information about the problem
    Bucket ID: 321069932

    This is the screen:
    http://i15.tinypic.com/3yo45q9.jpg

    So then I uninstalled it and reinstalled it. When I insert the CD I get this
    screen:
    http://i11.tinypic.com/3zjwxm8.jpg

    I hit retry, same screen.

    Then I hit cancel and I get "do you want to cancel installation?" I click
    Yes and then the installation starts.

    At the end of what appears to be a successful install I get this screen again:
    http://i15.tinypic.com/3yo45q9.jpg

    And then another error sent to Microsoft.

    What is happening with my game and why could I play it for five days and now
    this error?

    I installed University thinking it would override if there was a problem on
    teh first CD, still get the error it cannot copy a file.

    I'm so frustrated. :(

    Chris.
     
    cdkscully, Apr 19, 2007
    #5
  6. rockonzombie

    RoccoIV Guest

    Lynne,
    I currently own Sim City 4 and Sim City 4 Rush Hour and can run them on
    Vista Ultimate 64-bit. But I am having a problem where the game force quits
    after about an hour of game play. I am still tracking down the source of the
    problem ( I think it's Norton Antivirus). Anyway Sim City 4 works with my
    machine. You may be having other problems.
     
    RoccoIV, May 3, 2007
    #6
  7. rockonzombie

    junior76 Guest

    Did you install anything recently? A lot of times it's a conflict with other
    software.
     
    junior76, May 20, 2007
    #7
  8. rockonzombie

    Polly Guest

    I have Sim City 4 and Norton and I can't play at all, restart my coputer all
    time, I tried play as xp version but still the same. What you mean by the
    norton could be the problem??? any suggestion??
     
    Polly, Aug 17, 2007
    #8
  9. rockonzombie

    Polly Guest

    I have Sim City 4 and Norton and I can't play at all, restart my coputer all
    time, I tried play as xp version but still the same. What you mean by the
    norton could be the problem??? any suggestion??
     
    Polly, Aug 17, 2007
    #9
  10. Try disabling Norton then play the game
    --
    VRG Scotty©

    www.vistareadygames.com
    Register (it's free) and Use the Search for solution button to find the
    answer.
     
    VRG Scotty©, Aug 17, 2007
    #10
  11. rockonzombie

    Andy [YaYa] Guest

    Problem is to disable Norton you basically have to uninstall it, at least as
    I recall from my 360 trial I could not disable the program. I'm sure it's
    for "my own good" or something.

    Yeah, disable norton and try the game again. Make sure you get any
    updates/patches for the game from the http://support.ea.com.

    If you still can't get it running after killing all your background tasks,
    running as admin in XP compatibility mode (Disable Desktop Composition, and
    visual themes too) then go over to http://simcity.ea.com/screenshots.php and
    soak up some of the screens from the new SimCity: Societies.

    here's the SimCity 4: Rush Hour/Delux Pack patch, this came out LONG before
    Vista so it may not fix your problem, but you never know...

    http://simcity.ea.com/update/exe/EP1/UPDATE_SKU1_TO_P1_B638.EXE
     
    Andy [YaYa], Aug 17, 2007
    #11
  12. Aye it's a real pain, they do it on badness
    --
    VRG Scotty©

    www.vistareadygames.com
    Register (it's free) and Use the Search for solution button to find the
    answer.
     
    VRG Scotty©, Aug 17, 2007
    #12
  13. rockonzombie

    Andy [YaYa] Guest

    Since were both going this way I might as well bring up the links for
    "Better" and "Free" Anti-Virus scanners.

    http://free.grissoft.com - Follow links to AVG Anti-Virus "Free" Version.
    It's 100% FREE for personal use, works good, it's free, and you can disable
    it when you want too.
    http://www.avast.com/eng/download-avast-home.html - Avast! Free version.
    I've seen lots of recommendations for this one, and hey, it's free!
    http://www.eset.com/download/index.php - NOD32 - NOT FREE, $39/year, but
    I've seen recommendations all over the place for this one so it can't be
    that bad. Remember the "less" popular the scanner, the MORE likely virus
    makers won't try to circumvent it's scanning ability (it'll catch more
    "newer" viruses). They also have a great set of Virus removers (free) if you
    know what virus you have, as well as uninstallers for trend, norton, mcafee.

    Don't let retail scare ya people, Norton, Trend, McAfee aren't the best,
    they are just the best known.
     
    Andy [YaYa], Aug 17, 2007
    #13
  14. I use NOD32 best I've ever used, nice small install and does not sit
    pestering you all the time like Norton etc, it's not memory hungry either,
    highly recommended and works brilliantly with Vista
    --
    VRG Scotty©

    www.vistareadygames.com
    Register (it's free) and Use the Search for solution button to find the
    answer.
     
    VRG Scotty©, Aug 17, 2007
    #14
  15. rockonzombie

    PowerUser Guest

    Kaspersky is the best.

     
    PowerUser, Aug 19, 2007
    #15
  16. rockonzombie

    VRG Scotty© Guest

    Bit too intrusive for me, it's always upto something, my mate has it on his
    machine and it's always flagging up something instead of just sitting there
    nice and quiet and working in the background. That is why I like NOD32, it
    doesn't bother with antispam or internet security it's just antivirus as I
    have decent firewall/antispam software. mind you, my mate has the full
    Kaspersky internet security suite 7.0 so I don't know about Kaspersky
    antivirus on its own.
     
    VRG Scotty©, Aug 19, 2007
    #16
  17. rockonzombie

    PowerUser Guest

    Even so those things can easily be disabled if you dislike them so much, and
    leave just the AV on.

    Kaspersky's engine is legendary and has the best track record of ANY AV in
    the history of AVs. It's what I recommend anyway.

    And it's the only AV that could remove a virus that was stuck on my
    brother's system for like 2 weeks. He went through 4 brands and stand alone
    tools before I recommended it to him.

    Personally though I don't use AV, just a firewall.
     
    PowerUser, Aug 20, 2007
    #17
  18. rockonzombie

    VRG Scotty© Guest

    I agree, it is legendary and the AV prog worked great for me under the
    earlier M$ OS, it's just gone the wrong way with all this 'internet security
    suite' thing, it's just too norton for my liking
    --
    VRG Scotty©

    www.vistareadygames.com
    Register (it's free) and Use the Search for solution button to find the
    answer.
     
    VRG Scotty©, Aug 20, 2007
    #18
  19. SimCity 4 plays great on my Vista 64, but you have to add it to the DEP
    list.

    right click computer, click properties
    click Advanced system setting on the left
    under Perfomance tab, click Settings
    click the DEP tab [the right tab]
    make sure it is ON for ALL programs
    click ADD, & add SimCity 4.exe to it

    If you want the Loteditor to work also add it to the list
    ------
    The ones I have added to the DEP list are
    SC4Tool.exe
    Sim City Plugin Manager.exe
    Simcity 4.exe
    Simcity 4 Lot Editor.exe

    Also run game in Windows XP mode & Administrator
     
    Gary Colligan, Aug 21, 2007
    #19
  20. SimCity 4 plays great on my Vista 64, but you have to add it to the DEP
    list.

    right click computer, click properties
    click Advanced system setting on the left
    under Perfomance tab, click Settings
    click the DEP tab [the right tab]
    make sure it is ON for ALL programs
    click ADD, & add SimCity 4.exe to it

    If you want the Loteditor to work also add it to the list
    ------
    The ones I have added to the DEP list are
    SC4Tool.exe
    Sim City Plugin Manager.exe
    Simcity 4.exe
    Simcity 4 Lot Editor.exe

    Also run game in Windows XP mode & Administrator
     
    Gary Colligan, Aug 21, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.