Sleep Problems/Blue Screens - I'm SO frustrated! Please help!

Discussion in 'Windows Vista Performance' started by Kcpirana, May 9, 2007.

  1. Kcpirana

    Kcpirana Guest

    I'm posting this in a few places, so hopefully someone far smarter than I
    will run across it. I'm at my wits' end and I can't get any assistance from
    Microsoft or Toshiba on a two-week-old notebook! Here goes:

    1) Two or three times, I've gotten a blue screen. The stop error message is
    pfn_list_corrupt. Vista shuts down and pretty much restarts itself
    normally. When the boot option menu comes up, it has normal start-up
    highlighted. In Control Panel>Problem Reports, this appears to be a device
    driver, but I can't find anything wrong! My printer works (Lexmark 7100
    network printer, not directly connected), which is my first suspect.

    2) Sleep mode now appears to not even go into effect now. My little power
    light won't flash amber (which is how you tell your notebook is sleeping on
    this Toshiba), it just stays active, although the screen goes to black. So,
    I can't tell if I still have the problem of it not waking up still, because
    now it won't go to sleep!

    3) This is a stupid thing, but I can't read "sign in" to rate or respond to
    these newsgroups in Windows Mail. I press the Sign In button, but it does
    nothing! So, I read the post (or create one as I'm doing now), I reply or
    hit send, and Windows Mail freezes! I have to use Task Manager to restart
    the program and then sometimes I'm all signed in. Once (only once) I had
    the pop-up box to sign into Microsoft communities come up, I logged in, the
    notebook thought a minute and then decided to give me yet another blue
    screen with the pfn code. I have no idea whether that's even related, but
    it's aggravating. I would like to be able to use Windows Mail in the way it
    appears to be intended. I'm going to C&P this before I try to send it,
    because Windows Mail is going to freeze up again and I'll lose this. (Maybe
    this is an easy fix and I'm an idiot? - When you read this, I will have
    frozen and restarted Windows Mail to get it here.)

    4) I called Toshiba - they have NO idea except to do a system recovery
    (which they don't even say will fix the issue and seems to be pretty much
    their knee-jerk response to everything - the other "fix" was to just not use
    sleep!). But I've JUST gotten my files all back up to date, I don't have a
    good way of backing everything up, and I REALLY don't want to start from
    scratch again!

    5) And I'm a little frightened to even try a system recovery, because even
    though I purchased this computer on 4/26/07, Microsoft's on-line help (which
    should be free for 90 days from purchase date) tells me my product ID for
    Vista isn't valid! I had a problem activating it from the get-go and had to
    call Microsoft and they gave me some other product ID number, which now they
    tell me is invalid?

    I'm using a brand-new Toshiba Satellite A205-S4577, 1 gb ram, and it came
    with Vista Home Premium preinstalled. I haven't installed much of anything,
    except Office 2007, iTunes (has worked), a Palm (not working, but did), and
    my network printer (working). Any help anyone can offer would be GREATLY
    appreciated!
     
    Kcpirana, May 9, 2007
    #1
    1. Advertisements

  2. This does appear to be a driver issue. The fact your devices are working
    does not mean you don't have a problem driver. Have you checked your device
    manufacturer websites for the latest Vista compatible drivers for your
    devices, that includes internal devices as well, graphics cards, soundcards,
    etc?

    Please try to stick to one topic per post as it makes it easier to answer.
    In this instance, before you go any further, it's best to get the device
    driver issue resolved as misbehaving drivers can cause issues in other parts
    of your setup and may impact various operations or functions you are trying
    to perform.
     
    Michael Solomon, May 9, 2007
    #2
    1. Advertisements

  3. As to the issue of Microsoft telling your your product ID was invalid, since
    Vista came preinstalled, Toshiba, the OEM for your laptop is responsible for
    support, not Microsoft and that is probably why they didn't recognize the
    product ID.
     
    Michael Solomon, May 9, 2007
    #3
  4. Kcpirana

    SR Guest

    Hi,

    I think I have a very similar problem. I bought a Sony Vaio VGN-N31M
    last saturday and it's driving me crazy. Here's my problem:

    It's no problem to put Vista into sleep mode, as long as the laptop is
    not running in battery mode. But when in battery mode, the laptop
    reboots (actually it gives me a blue screen I can't see because the
    display is switched off) after switching from standby to hibernate.

    The Sony support gave me the advise to perform a system recovery - which
    I did. The problem did not occur on the clean system directly after the
    recovery, only to come back after I installed some windows updates.
    Then I uninstalled the Microsoft SQL Server (one of the updates was the
    SQL Server SP2). This did indeed solve the problem - until I installed
    the rest of the available updates.

    I already tried to install the latest drivers for the Mobile Intel 945GM
    Express without effect. The release note for this version did actually
    sound very promising:

    issues resolved: WINDOWS VISTA* : System hang up (Blue screen) after
    execute preload recovery on system with battery mode.

    Well, so far there is nothing else I have found out about the problem,
    except that part of the problems are the windows updates I installed
    after the clean recovery.

    SR
     
    SR, May 9, 2007
    #4
  5. Kcpirana

    Joe Guidera Guest

    I suspect items 1 and 2 are the same related issue. What you can do is
    configure Vista so it won't automatically reboot on a blue screen by;

    Hit the start button and type "system" or open control panel/system
    Select "advanced system settings"
    Hit the "settings" button under "startup and recovery"
    Uncheck "automatically restart" under "System Failure"

    Now, when you machine blue screens it won't automatically reboot any more
    and you can get a better look to see if a specific driver is mentioned.

    If not, what you'll need to do is download and install the WINDBG tool from
    Microsoft's web site.

    You'll need to run it as an administrator
    Then use it to open the minidump file created that should be stored in
    c:\windows\minidump


    Issue the following commands:

    ..symfix
    ..reload
    !analyze -v

    This should provide you with some information as to the likely driver that
    is causing the blue screen (among other information).

    For example below is the output on one of my dumps that pinpoints my problem
    as vmnetsrv.sys (which is part of Virtual PC 2007).

    In regards to your question when you attempt to put the machine to
    sleep/hibernate, when the screen goes blank WAIT. Wait at least 10-15
    minutes. It will likely finally blue screen which is useful in determining
    what driver is at fault.

    Best of luck,
    Joe

    --------------------------------- debug output -----------------------
    0: kd> .symfix
    No downstream store given, using C:\Program Files\Debugging Tools for
    Windows\sym
    0: kd> .reload
    Loading Kernel Symbols
    .................................................................................................................................................................................
    Loading User Symbols
    Loading unloaded module list
    ..............
    0: kd> !analyze -v
    *******************************************************************************
    *
    *
    * Bugcheck Analysis
    *
    *
    *
    *******************************************************************************

    DRIVER_POWER_STATE_FAILURE (9f)
    A driver is causing an inconsistent power state.
    Arguments:
    Arg1: 00000003, A device object has been blocking an Irp for too long a time
    Arg2: 85844510, Physical Device Object of the stack
    Arg3: 8793a030, Functional Device Object of the stack
    Arg4: 892a62d0, The blocked IRP

    Debugging Details:
    ------------------

    *** WARNING: Unable to verify timestamp for VMNetSrv.sys
    *** ERROR: Module load completed but symbols could not be loaded for
    VMNetSrv.sys

    DRVPOWERSTATE_SUBCODE: 3

    DEVICE_OBJECT: 8793a030

    DRIVER_OBJECT: 879382e0

    IMAGE_NAME: VMNetSrv.sys

    DEBUG_FLR_IMAGE_TIMESTAMP: 45b74b89

    MODULE_NAME: VMNetSrv

    FAULTING_MODULE: 8c71f000 VMNetSrv

    CUSTOMER_CRASH_COUNT: 2

    DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

    BUGCHECK_STR: 0x9F

    PROCESS_NAME: System

    CURRENT_IRQL: 2

    LAST_CONTROL_TRANSFER: from 8284ada0 to 828d85c9

    STACK_TEXT:
    8360adf4 8284ada0 0000009f 00000003 85844510 nt!KeBugCheckEx+0x1e
    8360ae50 82850441 8360af5c 8360af28 00000001 nt!PopCheckIrpWatchdog+0x165
    8360ae90 828a99d1 82909fc0 00000000 407c8cd0 nt!PopCheckForIdleness+0x33f
    8360af88 828a9321 00000000 00000000 000d910e nt!KiTimerExpiration+0x498
    8360aff4 82890d8d 838d7a30 00000000 00000000 nt!KiRetireDpcList+0xba
    8360aff8 838d7a30 00000000 00000000 00000000 nt!KiDispatchInterrupt+0x3d
    WARNING: Frame IP not in any known module. Following frames may be wrong.
    82890d8d 00000000 0000001a 00c1850f bb830000 0x838d7a30


    STACK_COMMAND: kb

    FOLLOWUP_NAME: MachineOwner

    FAILURE_BUCKET_ID: 0x9F_IMAGE_VMNetSrv.sys

    BUCKET_ID: 0x9F_IMAGE_VMNetSrv.sys

    Followup: MachineOwner
     
    Joe Guidera, May 10, 2007
    #5
  6. Kcpirana

    Kcpirana Guest

    Thank you for the information! I'm going to try this tonight.

    I did worry about posting all these issues together, but I just wasn't sure
    whether the issues were related or completely independent of each other. I
    figured it would be better to throw it all out there and be wrong, than to
    try to describe a problem, only to find out that some of the other
    information was needed. I'm sorry for any confusion!

    Thanks again,
    Kristy
     
    Kcpirana, May 10, 2007
    #6
  7. Couple of suggestions for you...

    Junkware...there's lots of it. I got a new HP laptop 4 weeks or so ago, and
    struggled with it for a week before I finally completely nuked it and
    installed Vista Ultimate from scratch. I realize it's not an option for
    many, but in my case, the results have been pretty good...the system is now
    fast and rock solid. Sadly, I'm missing some HP pieces that I so far haven't
    been able to find. But, on balance, a much better system. The HP came with
    so much crap on it that it was a serious limiting factor. And I did get one
    blue screen in the process - the final straw that prompted the reinstall.

    Otherwise, if this machine is only two weeks old, take it back. Exchange it
    across the board for another one. If the second one has similar problems,
    tell them you'd rather have an HP or Lenovo or something else...

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, May 10, 2007
    #7
  8. Kcpirana

    Kcpirana Guest

    I was thinking the same thing, Dana. At the very least, I think I'm going
    to print out my post here (and some of the advice I received that I tried),
    march into where I bought it, and say "fix it" - particularly the activation
    problem. I love the notebook and I love what Vista will obviously become as
    more bugs are worked out, but man, right now, I feel like banging my head
    against a wall.

    One thing, though, I did find a Vista driver for my networked all-in-one
    Lexmark. Right now, it prints fine, but I know the driver came off the
    original installation disk and even though Windows tells me there isn't a
    better driver, I'm wondering if installing this driver would make a
    difference. I just discovered this today.

    Kristy
     
    Kcpirana, May 10, 2007
    #8
  9. You should be able to find drivers for your HP laptop here:
    http://support.hp.com

    I've been really pleased with my 6 month old HP Pavilion DV6000,
    for which they gave me a free Vista upgrade.

    Gary VanderMolen
     
    Gary VanderMolen, May 10, 2007
    #9
  10. Gary,

    It's not the drivers, it's the other apps. For instance, I have touchpad
    drivers. But without the accompanying apps, there's no way to adjust the
    sensitivity or turn off the double-taps. I have webcam drivers, but until I
    installed Live Messenger, I had no way to adjust the camera features.
    Similarly, I have the fingerprint reader drivers, but without the Verisign
    access manager program, there's no way to actually _use_ the fingerprint
    reader. I have Lightscribe drivers, and fortunately my video software also
    has a CD label program that can write to a Lightscribe, so I'm good there.

    The HP support guys I talked to basically told me the only way was to do a
    full original restore. There's a directory out there with all the apps, but
    apparently not necessarily in an installable state. So for now I do
    without...

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, May 11, 2007
    #10
  11. Kristy,

    Good luck and please let us know how the encounter goes...

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, May 11, 2007
    #11
  12. The touchpad driver I got from HP does allow me to control
    the sensitivity and tapping settings. When you open the Mouse
    applet in Control Panel, isn't there a Device Settings tab?

    All the apps residing in the restore partition should also be
    available for download from HP's support site.

    Gary VanderMolen
     
    Gary VanderMolen, May 11, 2007
    #12
  13. Yes, there is a Device Settings tab in the Control Panel / Mouse. It says
    its a PS2 wheel mouse. When I click the Settings button there, I get a
    dialog where I can set what happens with the two buttons. That's
    it...nothing else anywhere that I can find...

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, May 11, 2007
    #13
  14. Kcpirana

    Kcpirana Guest

    Well, I got a replacement - when I took my Toshiba back to Best Buy, they
    ran it through whatever their system is and it came back "unrepairable." So
    far, so good.

    Except for that sign-in box on the newgroup preview and reply windows. When
    I click it, it doesn't do anything? What should I do about that, since
    obviously now it's something I'm doing wrong...
    Thanks!

    Kristy
     
    Kcpirana, May 14, 2007
    #14
  15. I'm glad they were able and willing to do an exchange. Hopefully this newest
    box will last longer <g>.
    Is this current issue in Windows Mail?

    Dana Cline - MCE MVP
     
    Dana Cline - MVP, May 14, 2007
    #15
  16. Kcpirana

    Kcpirana Guest

    I believe so. I did find one thread just today (after I updated this one)
    that simply said to uncheck the "use newsgroup message rating features" box.
    I did and the Sign In button disappeared. I have no idea what I'm missing,
    but as long as I can post my idiocy as needed without freezing my computer,
    I guess I'm waaaaay ahead.

    Incidentally, they wanted to charge me $100 to back up the information on
    the defective notebook. Since apparently it was defective when I walked out
    of the store, the manager and I had a little "chat" and eventually he saw
    that charging me another $100 wasn't such a good idea...LOL

    Kristy
     
    Kcpirana, May 14, 2007
    #16
  17. Kcpirana

    Marcos Guest

    I have the same problem,
    I was looking in my network(sharing files to my other computer(XP)) and the
    blue screen appeared
    This happened like for a month now
    I did a System restore
    but it happened again
    The error is: ***stop:0X0000004E (0X00000099,0X0001C650,0X00000003,0X0001946F)
    PFN_LIST_CORRUPT
     
    Marcos, Oct 23, 2007
    #17
  18. Kcpirana

    Rick Rogers Guest

    Hi Marcos,

    This one can be difficult to diagnose, as it could be a damaged driver file
    or faulty memory. Is a minidump file being created? Check under
    C:\Windows\minidump for recently created ones that correspond with the stop
    errors you are experiencing. I can examine them to see what may be the
    problem. Send the most recent few (3-4 at most) to me at the email address
    used here with a subject line of 'per req'.
     
    Rick Rogers, Oct 26, 2007
    #18
  19. Kcpirana

    Charlie Tame Guest

    Charlie Tame, Oct 26, 2007
    #19
  20. Kcpirana

    Marcos Guest

    hi
    i think i got the problem resolved,
    the problem reports and solutions said it was the anti-virus (Panda
    Software-Tesco anti-virus) i removed the anti-virus and installed Norton
    Anti-virus.
    if the problem continues i'm going to leave a message
    thanks
     
    Marcos, Oct 26, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.