Slightly OT - Activesync to WM2003 device works via GPRS but not via USB cable?

Discussion in 'Windows Small Business Server' started by David Elders, May 4, 2006.

  1. David Elders

    David Elders Guest

    A little confused.

    Have set-up absolutely loads of Activesync connections for our users from
    their desktops to their Windows Mobile 2003 2nd Edition mobiles [Orange SPV
    C500 here in the UK] but have always to date simply done direct sync from
    desktop to mobile via USB lead. None of our users [yet] feel the need to be
    able to synch entirely remotely while 'out in the field' so to speak. Fair
    enough.

    Have today set-up my own C500 to synch to our Server over a GPRS connection
    and [once we'd used the DisableCertChk tool] that worked absolutely smoothly
    and very quickly it has to be said. However, if we connect the same handset
    via USB lead to our desktop, we cannot synch to the Server. We get a message
    box on the device saying it cannot connect and do we want to try
    pass-through. We say yes but it doesn't work.

    Ideally, if possible, we'd like to be able to synch wirelessly [purely on
    demand rather than real-time, at least at present] but to be able to plug in
    via USB to charge the phone and to synch while in the office in real-time.

    Is this possible or are we being dumbo's here? I get the distinct feeling
    we're missing something really simple...

    Cheers,


    David
     
    David Elders, May 4, 2006
    #1
    1. Advertisements

  2. David Elders

    IT PHYTOSAN Guest

    What you want to do can be done. We do it all the time. Pass through is the
    correct approach, although I have not seen that on recent versions of
    Activesync. Are you running 3.8 which would be the correct version for pre
    5.0 devices? Your problem could be ISA if you are running it. Also
    DisableCertChk should not be necessary. You should instead:

    *Visit a https site of the server that uses the same certificate on the
    client pc's internet explorer.
    *trust that certificate
    *using mmc certificate snap in you should export that certificate as a file
    with default settings to your mobile device.
    *open that file from the mobile device installs your certificate on the
    device.

    HTH

    IT PHYTOSAN
     
    IT PHYTOSAN, May 5, 2006
    #2
    1. Advertisements

  3. David Elders

    Andrew H Guest

    I found that certain routers cannot resolve the server address used by
    Activesync since the request is coming from an internal machine to the
    public address of the SBS (same as the certificate used by ActiveSync, OWA
    and RWW) and not from the external interface.

    One of the other symptoms of this problem is the inability to connect to
    http://server.domainname.com/Exchange from an internal workstation, while
    from an external workstation it works fine. The fact that your GPRS
    connection works while Activesync doesn't may correspond to this
    internal/external problem.

    So far the only solution I've found is to replace the router with another
    brand - but if anyone knows a better solution, I'd like to hear it.
     
    Andrew H, May 5, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.