Slow networking between Vista Home Premium and Windows Home Server

Discussion in 'Windows Vista Networking' started by Quentin, Feb 28, 2008.

  1. Quentin

    Quentin Guest

    Vista Home Premium one end, Windows Home Server the other, both fully updated
    via Windows Update (so no SP1). 100 Mbps network, full duplex.

    Both machines are 2 GB Pentium D Dual core boxes with RAIDed SATA drives.
    Server has a RAID 5 on a 3ware controller, Vista has a RAID 1 mirror on a SiS
    controller.

    My problem is that I’m only getting about 2 Megabytes per second transfer
    speed (approx 20 Mbps). Since these are the only boxes on the network, I’d
    expect to be getting full speed.

    I’ve tried disabling AVG.
    I’ve tried disabling Remote Differential Compression.
    I’ve tried switching to half-duplex.
    I’ve tried disabling TCP autotune and rss.
    I’ve tried disabling TCPA on the server.
    I’ve applied the KB947773 hotfix (updated tcpip.sys) which improved the
    transfer speed to 3 MB /sec
    I’ve tried turning off thumbnails. That reduced the transfer speed to 2 MB /
    sec!
    I’ve tried tweaking HKLM\SOFTWARE\Microsoft\Windows
    NT\CurrentVersion\Multimedia\SystemProfile\NetworkThrottlingIndex
    I've tried changing the network switch into which they're both plugged.

    Anyone got the answer?
     
    Quentin, Feb 28, 2008
    #1
    1. Advertisements

  2. Hi
    Could be Bad network cable, or loose plugs connection.
    Also try to set the TCP Receiving Window on both computers to 256960.
    Jack (MVP-Networking).
     
    Jack \(MVP-Networking\)., Feb 28, 2008
    #2
    1. Advertisements

  3. Quentin

    Quentin Guest

    Thanks.

    Cables are all checked: and it worked fine when I had an XP workstation with
    a W2000 server.

    How do I set the TCP Receiving Window? The Vista box's NIC (SiS) has a
    Receive buffer setting in Properties with a max of 1024, but there's no such
    or similar setting on the Home Server (Intel NIC), and there's nothing
    similar visible in the TCP driver entry in the registry - unless I've missed
    it.


    --

    qts (MCPs: NT, NT Server, NT Enterprise, XP, Windows Server 2003)



     
    Quentin, Feb 28, 2008
    #3
  4. Hi
    Try this one it works in Vista, and Windows 2003. I applied it to my WHS and
    it seems to work, but I did not have time to evaluate the overall outcome.
    So YMMV on WHS.
    TCP Optimizer - http://www.speedguide.net/downloads.php
    Jack (MVP-Networking).

     
    Jack \(MVP-Networking\)., Feb 28, 2008
    #4
  5. Quentin

    Quentin Guest

    Against my better judgement - given the recent press - I installed SP1 and
    the speed has increased to 7 MB / sec. This is better but still not good. I
    should be getting 10+.
     
    Quentin, Feb 28, 2008
    #5
  6. Quentin

    Quentin Guest

    This has actually had no improvement at all on the overnight backup. It's
    still only done 35% in 9 hours. Since this is the first backup, I've got
    about 180 GB to back up.

    Is it possible that there's an issue with the backup process itself? A size
    limit?
     
    Quentin, Feb 29, 2008
    #6
  7. Quentin

    Quentin Guest

    Oh dear. I'm now trying a more intensive test, and the data transfer rate has
    gone down to 4 MB /sec.
     
    Quentin, Feb 29, 2008
    #7
  8. Quentin

    Quentin Guest

    And now it's back down to 3 MB / sec.
    --

    qts



     
    Quentin, Feb 29, 2008
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.