[SOLUTION] You cannot install KB928366 (.Net Framework 1.1 security update)

Discussion in 'Windows Update' started by Patrick Philippot, Jul 16, 2007.

  1. Hi,

    This is an old bug showing up again. Although the official solution
    involves reinstalling the framework after manipulating the registry with the
    installer cleanup tool, there's a much simpler way to fix this:

    1. Instead of using Windows Update, download the KB928366 package from here:
    http://www.microsoft.com/downloads/...CD-C715-4F05-A01F-0455D2D9EBFB&displaylang=en
    Do not install yet.

    2. Download the .Net framework 1.1 redistributable package from here
    http://www.microsoft.com/downloads/...FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3

    3. Use Winzip or a similar utility to unpack dotnetfx.exe in a folder of
    your choice. You should get the following files:
    netfx.msi
    install.exe
    InstMsi.exe
    InstMsiW.exe
    netfx1.cab

    4. Launch the KB928366 installer. It will soon complain that it can find the
    installation CD-ROM (don't ask me why). Browse to the folder where you
    unpacked the dotnetfx files.

    That's it.

    This procedure can be applied to any similar situation regarding .Net
    framework updates. I'm using it since years (that is, since this Windows
    Update bug exists).

    Good luck.
     
    Patrick Philippot, Jul 16, 2007
    #1
    1. Advertisements

  2. that it *can't* find
     
    Patrick Philippot, Jul 16, 2007
    #2
    1. Advertisements

  3. Patrick Philippot

    mouspi Guest

    Ok Patrick,

    It complains, but with another message :
    "Le correctif de mise à jour ne peut pas être installé par le service
    Windows Installer car le programme qui doit être mis à jour est peut-être
    introuvable ou le correctif de mise à jour est peut-être destiné à une autre
    version du programme.Vérifiez que le programme que vous voulez mettre à jour
    se trouve sur votre ordinateur et que vous disposez du correctif de mise à
    jour correct."

    And I Can't browse any folder.

    Thanks for another good idea.

    Mouspi
     
    mouspi, Jul 16, 2007
    #3
  4. This is apparently a different situation. You probably need to
    repair/reinstall the framework by running dotnetfx.exe again. IMHO, in your
    case, the KB installer is looking for registry entries related to the .Net
    framework 1.1 and it didn't find them.
     
    Patrick Philippot, Jul 16, 2007
    #4
  5. Patrick Philippot

    mouspi Guest

    Patrick,

    It seems to work now :
    - I ran dotnetfx.exe
    -I downloaded SP1 then I applied the update KB928366, the way you told.

    When I launched WindowsUpdate, it told me, that I had'nt any update to
    install.

    Thanks

    Mouspi
     
    mouspi, Jul 16, 2007
    #5
  6. Patrick Philippot

    chappy60 Guest

    turn it on shows only 'fair' because I haven't done the update & then changes to 'good' after I've clicked on a couple of screens..........it would seem to me the problem is I do not have 1.1 but rather 2.0 & was asked to install an update for the wrong .Net Framework!!

    Sorry to be so long winded but I'm getting totally frustrated with
    Microsoft! Any advice, many thanks.........p j
     
    chappy60, Jul 16, 2007
    #6
  7. Patrick Philippot

    technogenii Guest

    Hello Patrick,

    Please tell me, do I need to do anything different if I have the same
    problem but with Security Update for Microsoft .NET Framework, Version 2.0
    (KB928365)?

    Many thanks,
    Kristina
     
    technogenii, Jul 16, 2007
    #7
  8. Hi Kristina,
    I never had to fix a version 2.0 update but I think that this should work
    the same way. In many cases, installing the KB package directly instead of
    using Windows Update fixes installation problems. This applies to any KB
    update (you just go to the details page for the update, you download the
    package directly and most of the time, it works while WIndows Update refused
    to install it).

    For the .Net Framework 2.0, the number of files containes in dotnetfx.exe is
    much higher and the installation a little bit more complex. But there's no
    risk trying the 1.1 method.

    Let us know if it works.

    Best greetings from Paris.
     
    Patrick Philippot, Jul 16, 2007
    #8
  9. Patrick Philippot

    putnik Guest

    Please help me, I have told Microsoft Support about this problem and they
    have just said that my problem has been solved and they are closing my case
    file. Well it hasn't been solved at all and I still have an install shield
    icon that wont go away.

    I have downloaded the files you suggest and have extracted the dotnetfix
    files. I have also downloaded and run the cleanup-x86 application from
    previous advice on here.

    However, when I run the installer (I presume you mean
    NDP1.1sp1-KB928366-x86.exe) nothing changes. It does not ask me to browse
    for the extracted files either. The dreaded icon is still there. There is
    still no KB928366 listed in my program files in the Control Panel.

    I then tried to run dotnetfix.exe and it asked me if I wanted to install
    ..Net 1.1. I said I did, but it then told me it was unsuccessful.

    Where do I go from here?

    Michael
     
    putnik, Jul 16, 2007
    #9
  10. Take what you need from the solution. If you don't have .NET Framework 2.0
    installed - you don't need that part of the solution. Same for 3.0. If
    you come to a instruction you cannot follow because you do not have referred
    to file/registry entry - skip over it and consider it done. Don't dwell on
    the parts you *don't* have - be concerned with the parts you do.


    (1) You need to repair .NET Framework 1.1 - obliterating all remnants of it
    and installing it/patching it fully.

    How to troubleshoot Microsoft .NET Framework 1.1 installation issues
    http://support.microsoft.com/kb/824643
    - Unregister and then reregister Windows Installer (See article)

    - Download/install/use:
    http://www.microsoft.com/downloads/...33-0343-4EE4-B0C4-97BD16967A09&displaylang=en
    - Manually remove and then reinstall the .NET Framework 1.1 (See Article)
    For the articles below, follow the "IT professionals" link and find the
    download for your OS.
    - Download/Install http://support.microsoft.com/kb/867460/
    - Download/Install http://support.microsoft.com/kb/886903/
    - Download/Install http://support.microsoft.com/kb/928366/

    Reboot as needed and at the end.

    (2) You need to repair .NET Framework 2.0 - obliterating all remnants of it
    and installing it/patching it fully.

    How to troubleshoot Microsoft .NET Framework 2.0 installation issues
    http://support.microsoft.com/kb/908077/
    - Unregister and then reregister Windows Installer (See article)
    - Manually remove and then reinstall the .NET Framework 2.0 (See Article)
    For the articles below, follow the "IT professionals" link and find the
    download for your OS.
    - Download/Install http://support.microsoft.com/kb/917283/
    - Download/Install http://support.microsoft.com/kb/922770/
    - Download/Install http://support.microsoft.com/kb/928365/

    Reboot as needed and at the end.

    (3) You need to repair .NET Framework 3.0 - obliterating all remnants of it
    and installing it/patching it fully.

    Unfortunately - there is no particular article pertaining to .NET Framework
    3.0 that I could find. I have not had issues, however, just going into the
    Control Panel --> Add or Remove Programs and just locating/removing it and
    its patches. I suggest you do the same and then reboot...

    Download/install using this distributable package:
    http://www.microsoft.com/downloads/...0B-F857-4A14-83F5-25634C3BF043&displaylang=en

    Reboot as needed and at the end.

    (4) Cleanup your updates system...

    Get Dial-a-Fix:
    http://wiki.djlizard.net/Dial-a-fix

    Use its options to fix:
    - Windows Installer
    - Windows Update
    - All the Registration Center options

    Turn off the "Empty System32\Catroot 2"
    Do NOT do "Flush SoftwareDistribution".

    Then click "GO"... May take a while.

    Reboot when it is done...

    (5) Visit http://windowsupdate.microsoft.com/ and scan for updates. Choose
    the critical updates you need and install them. Do not bother getting
    hardware updates (unless you happen to have some Microsoft hardware
    installed) and "Optional Updates" are *usually* just what the name infers -
    but feel free to see if you want any of the "Optional" ones.

    (6) Come back here and let us know how you came out...


    This has now come to light from a poster (Ray&Fran) and should be noted:

    Got everything installed but KB928367? This is caused by corrupted
    ..NET Framework 1.0 components. Simply hide the incorrect update...

    1. Open IE and go to the Windows Update site directly:
    http://www.windowsupdate.com
    2. Click "Custom Install" to scan your system (Not Express Install).
    3. After it finishes, please unclick the incorrect update.
    (Uncheck the box next to it.)
    4. Choose "Don't show this update again"
    (Check the box next to that under the update itself.)
    5. Scan the computer again to check the result.
     
    Shenan Stanley, Jul 16, 2007
    #10
  11. Hi,

    Do you mean that NDP1.1sp1-KB928366-x86.exe executes without any error
    message? If so, the update is probably installed. But Windows Update (and
    the WU icon) can still pretend it is not until you reboot. If you have an
    error message, please tell us hat it says. If this is the error described in
    the initial message of this thread, you should see a browse button in the
    message box. If not, this is another problem and you should proceed as
    specified in the "official" procedure.

    But again, if NDP1.1sp1-KB928366-x86.exe installs without complaining, it
    should be actually installed.
     
    Patrick Philippot, Jul 16, 2007
    #11
  12. Patrick Philippot

    Divelucaya Guest

    Not too long ago Automatic Updates installed the hotfix for >NET Framework
    2.0 (KB928365). Today, AU indicated there was an update to be installed
    (KB928366). I installed it and it showed as being completed (no errors and no
    indication that the computer needed to be restarted). Several minutes later,
    AU showed another update to be installed. I installed it and again it showed
    as being completed and I closed the installation window (with the "Close"
    button, not the "X"). Several minutes later, same thing. This time I jotted
    down the hotfix number to see if it was the same update being installed. The
    4th time AU came up I saw it was indeed the same hotfix update. I decided to
    reboot the computer and saw on the "Turn Off Computer" window that there was
    a message to shutdown the computer to install an update. I did this and after
    the computer installed the update and shut off, I turned the computer back
    on. Within 10 minutes of starting my computer, there was AU again with the
    same hotfix update. If I go to Add/Remove Programs, hotfix KB928365 (.NET
    2.0) is there but not KB928366 (.NET 1.1).

    Now I pretty much only install Microsoft downloads/components that Au
    indicates I need. Add/Remove Programs shows the following:
    Microsoft .NET Framework 1.0 Hotfix (KB930494) ... Installed On 7/11/2007
    Microsoft .NET Framework 1.1 ... No installation date or size
    Microsoft .NET Framework 1.1 Hotfix (KB886903) ... No installation date or
    size
    Microsoft .NET Framework 2.0 Hotfix ... No installation date, Size 88.45
    Security Update for Microsoft .NET Framework 2.0 Hotfix (KB928365) ...
    No installation date or size.

    I shut off AU but I still have the little shield icon, now in red, in my
    system tray. So what do I have to do to successfully installed hotfix
    KB928366? Am I supposed to have the different versions of .NET Framework or
    should I have only 2.0? I did try downloading NDP1.1sp1-KB928366-X86.exe but
    when I tried to run it, absolutely nothing happened. I checked Windows
    Cleanup Utility, and it shows only .NET 1.1 and 2.0 installed. Why does
    Add/Remove Programs show the hotfix for 1.0 installed, but does not show 1.0
    itself as installed. I did read Shenan's post but could not understand if ALL
    6 steps needed to be followed (I do not have .NET 3.0 and I'm not even sure I
    want it after going through this update hell).
     
    Divelucaya, Jul 16, 2007
    #12
  13. Parts (1), (4)-(6) and the additional thing at the very end if necessary of
    the post you responded to.
     
    Shenan Stanley, Jul 16, 2007
    #13
  14. Patrick Philippot

    putnik Guest

    It runs without any apparent complaint or error message. However I have
    re-booted several times and it is still not in the program list in Control
    Panel. It is also still downloaded and waiting to be installed in Update. The
    icon is beginning to become part of the family:)

    By the way I can't uninstall .Net 1.1 because files are missing. This may be
    because I used Ccleaner and deleted hotfix uninstallers to get back some
    100Mb of disk space. Perhaps I shall not be so hasty to cleanup my computer
    in future. Is there any other way of uninstalling it?

    Sorry for being so compulsive but you may be happy to know I have avoided
    going into the registry so far. I think this is too advanced for the general
    public and should not be necessary anyway.

    Couldn't Microsoft issue an automatic update to wipe the lot and start again?

    Michael

    Michael
     
    putnik, Jul 16, 2007
    #14
  15. Patrick Philippot

    Ed Pyle Guest

    I have the same problem as "putnik". KB928366 appears to install properly
    but it is not in the installed programs list and the installation icon will
    not go away. Should I try the solution suggested by "Patrick Philippot"?
     
    Ed Pyle, Jul 16, 2007
    #15
  16. Patrick Philippot

    htc Guest

    That worked perfectly - thanks
     
    htc, Jul 16, 2007
    #16
  17. Patrick Philippot

    Divelucaya Guest

    Okay, tried what you suggested and now the KB928366 update attempt fails each
    time (Error Code: 0x643). However, if I go to the "Turn Off Computer" window,
    it shows an update is ready to be installed. I click on the Turn Off button
    and the screen shows that the update is installing. After the computer shuts
    down I wait a minute or so and restart it. After several minutes, the
    Automatic Updates icon is back in the system tray. On a side note, when I
    check my updates history, it shows the KB928366 update being successfully
    installed every day (and sometimes a couple times a day) since last Wednesday
    (07/11/07). The funny thing is I don't recall seeing the AU icon in the
    system tray until today, although apparently it was going through daily
    iterations of installing this stupid update. And looking through this topic,
    it seems there are many people experiencing the same, or very similar,
    issues. This tells me there is a problem inherent with the update that
    Microsoft is not addressing.
     
    Divelucaya, Jul 16, 2007
    #17
  18. Patrick Philippot

    Divelucaya Guest

    Divelucaya, Jul 16, 2007
    #18
  19. Hi Michael,

    The only simple way to clean up the registry in order to re-install a
    package that has been installed by Windows Installer (.msi package) is to
    use the Windows Install Cleanup Utility
    (http://support.microsoft.com/kb/290301) and to remove the entry
    corresponding to that package. Then you have a chance to re-install. If this
    doesn't work because the installation package still recognizes some entries
    in the registry, then you have to do this manually. That is, manually remove
    the entries that cause the installer to fail. Determining which one is a
    painful process that can be achieved by using a registry monitoring tool
    like RegMon (http://www.microsoft.com/technet/sysinternals/default.mspx /
    http://www.microsoft.com/technet/sysinternals/ProcessesAndThreads/Regmon.mspx).
    This assumes a good understanding of the system, though. I you don't feel
    easy with the registry, don't.
    I agree that such a tool is missing. The structure of the registry regarding
    Windows Installer is not documented and nobody but Microsoft can produce a
    tool that is able to 1) detect an anomaly in the entries describing an
    installed MSI package and 2) cleanup or fix these registry entries. I have
    asked for such a tool multiple times during the last years but Windows
    Install Cleanup Utility is the only tool that they produced and it's
    obviously not enough.
     
    Patrick Philippot, Jul 17, 2007
    #19
  20. Patrick Philippot

    putnik Guest

    Patrick,

    Thanks for all your help! I have downloaded the Windows Install Cleanup
    Utility and removed .NET 1.1 as much as I could. The msicoree.dll could not
    be removed and one registry entry was already missing. Some files in the
    %temp% folder were busy.

    The dial-a-fix cleanup tool takes a fair time but finally completed it's job.

    The program list showed .NET 1.1 as installed twice but trying to remove it
    brought up a message that it was already removed. I deleted the entries on
    the list using Ccleaner.

    dotnetfix.exe reinstalled .NET 1.1 ok and NDP1.1sp1-KB367460.exe installed
    the service pack NDP1.1sp1-KB928366.exe then installed ok. I re-booted
    between each for good measure.

    So then I went to the Update site and found no updates waiting which makes a
    welcome change. However, the history shows numerous "successful"
    installations o KB928366 and a few "unsuccessful" ones today. It does not
    show a successful installation has occurred today though. Can I reset this
    list?

    I had to run the install shield icon again to get rid of it.

    Now the program list shows .NET 1.1 and KB928366, but now does not show the
    SP1 service pack KB367460.


    Well, I think I am there. Thanks again for your particular help.

    No thanks to Microsoft and really, I might have put up with all this on my
    first PC in 1886 when I had 1Mb of RAM and learnt 'C' in my lunch breaks, but
    now in 2007? It's a complete farce!

    Michael
     
    putnik, Jul 17, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.