[SOLUTION] You cannot install KB928366 (.Net Framework 1.1 security update)

Discussion in 'Windows Update' started by Patrick Philippot, Jul 16, 2007.

  1. The information listed in the history seems to come from various registry
    entries, including the Windows Installer entries. I do not recommend trying
    to change anything there. I'm not aware of any official way to reset this
    list. Also, resetting the list would probably trigger the re-installation of
    at least a few packages.

    Glad to see that everything is ok now.
     
    Patrick Philippot, Jul 17, 2007
    #21
    1. Advertisements

  2. Thanks, your post has pointed me to a solution. The manual installer
    complained that SP1 was not installed. I downloaded and ran the SP1 installer
    (KB867460) which then complained that SP1 was already installed. I let it
    install over top of the existing install and now the update worked. It seems
    that the .net 1.1 installer has SP1 incorporated in it, but the update
    installer does not detect it.
     
    NewerIsntAlwaysBetter, Jul 17, 2007
    #22
    1. Advertisements

  3. Patrick Philippot

    JD Guest

    I'm using ZipCentral and it will not unzip dotnetfx.exe. The error is
    "This is not a valid Zip archive. Please try to obtain a new copy of
    this file."

    Changing the extension to .zip didn't help.

    I don't really want to install WinZip. Any advice?
     
    JD, Jul 17, 2007
    #23


  4. I suspect it's a self-extracting archive. Often such files have command line
    support to allow you to do things such as initiate logging (for example).
    So, they often also provide for some kind of help with their syntax.
    I would try copying the executable to an otherwise empty directory (JIC <w>)
    and then execute it in a cmd window with /? as the only operand.
    I you're lucky that will just display all the possible operands allowed from the
    command line. However, another thing that these self-extracting files do
    (perhaps unintentionally) is do their extractions to a new directory, then pause
    with an error message saying your syntax is invalid. If you acknowledge the
    message they will then delete the new directory. So, as long as you don't
    acknowledge the message you would then be able to access the extacted files
    (provided you could find them <w>). In order to assist with that task you could
    run ProcessExplorer (e.g. to find out what directories the extraction program
    has open) or trace the whole extraction with ProcMon or simply find all new
    directories created that day (e.g. Win-F).


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jul 17, 2007
    #24
  5. Patrick Philippot

    JD Guest

    What you're saying is a little beyond me. Sorry.
     
    JD, Jul 17, 2007
    #25
  6. Patrick Philippot

    bill B: Guest

    Patrick Philippot
    Thanks it works
    Good luck yall.
     
    bill B:, Jul 18, 2007
    #26
  7. Patrick Philippot

    putnik Guest

    I downloaded a one month trial version of WINRAR. But I suggest you uncheck
    many of the boxes during the installation, as otherwise it tends to put
    itself on every menu on your computer.

    Make a new folder so that when you click on "extract to..." so it knows
    where to put the contents.

    Actually once I had got rid of my original .NET stuff, I just ran
    dotnetfix.exe and it installed without any apparent need to be extracted
    anyway.

    Michael

    Michael
     
    putnik, Jul 18, 2007
    #27
  8. Hi,

    You can also extract the files directly by using this command:

    dotnetfx.exe /C /T:c:\<yourfolder>

    Regards.
     
    Patrick Philippot, Jul 18, 2007
    #28
  9. You can also use the following command:

    dotnetfx.exe /C /T:c:\myfolder
     
    Patrick Philippot, Jul 18, 2007
    #29
  10. Hi,

    1. Put dotnetfx.exe in a folder whose name is not too long to type (for
    example, c:\dotnetfx)
    2. Start | Programs | Accessories | Command prompt . This opens a command
    prompt window.
    3. Enter "cd c:\dotnetfx" (without the quotes)
    4. The command line prompt should now be "c:\dotnetfx>"
    5. Enter "dotnetfx.exe /C /T:c:\dotnetfx" without the quotes. The files
    should then be extracted in the same folder as dotnetfx.exe.

    Then proceed as described in the initial post.

    Regards.
     
    Patrick Philippot, Jul 18, 2007
    #30
  11. Patrick Philippot

    JD Guest

    Please be patient with me. I'm not familiar with commands.

    When I select Start, Run, cmd I get the command window but it's already
    got C:\Documents and Settings\username typed in.

    My copy of dotnetfx.exe is located at E:\Download\XPUpdateFiles and I'm
    trying to extract it to e:\Download\dotnetfix

    What do I type at the command prompt?
     
    JD, Jul 18, 2007
    #31
  12. Patrick Philippot

    JD Guest

    It installed and didn't ask for the extra files. Windows update didn't
    list the .net update so everything seems to be OK. Thanks for being so
    patient!
     
    JD, Jul 18, 2007
    #32
  13. Patrick Philippot

    Ed Pyle Guest

    I have been following this thread since it started. I finally succeeded in
    re-installing Microsoft .NET Framework 1.1. However, I had to manually
    remove all vestiges of it in the registry before it would re-install and
    successfully apply the KB928366 update.

    I was wondering, is there is any advantage to installing 2.0?
    How do I know whether I need the x86 or the x64 version?
     
    Ed Pyle, Jul 19, 2007
    #33
  14. Ed Pyle wrote:
    Plan on getting anything that uses .NET Framework 2.0?
    How about .NET Framework 3.0?

    Do you have a 64 bit OS or a 32bit OS?
    (You'd know if you had a 64 bit OS.)
     
    Shenan Stanley, Jul 19, 2007
    #34
  15. Patrick Philippot

    technogenii Guest

    Unfortunately this approach didn't work for me. I tried it 3 times without
    any success. I wrote to Microsoft and they got me to download, install and
    run the Microsoft Windows Installer CleanUp utility, remove all the .NET
    Framework applications and updates and then reinstall. Now all seems to work.

    Thanks for you help anyways!

    Kristina
     
    technogenii, Jul 19, 2007
    #35
  16. Patrick Philippot

    Sliverman Guest

    you could get izarc instead of zipcentral because zipcentral only
    opens zip files but izarc can open self-extracting archives
     
    Sliverman, Jul 20, 2007
    #36
  17. Patrick Philippot

    robie Guest

    Hi
    Even thought I was able to install this update, you (I) still cannot go into
    hibernation mode.
    ..net framwork is running..
    right?
     
    robie, Jul 20, 2007
    #37
  18. Patrick Philippot

    Mike Nichols Guest

    This solution worked for me - Thank You.
     
    Mike Nichols, Jul 21, 2007
    #38
  19. Patrick Philippot

    SBKaren Guest

    I've tried just about all I want to try too. I've spent far too much time on
    this. It's Microsoft's turn to do something. Anything....a critical update
    isn't any good if it doesn't install right. So Microsoft....any solutions?
     
    SBKaren, Jul 23, 2007
    #39
  20. *If* they were going to come up with a solution that did not involve the
    end-user doing something - it would have been done by now - I think. It
    *might* still happen by the second Tuesday of next month - but if you are
    depending soley on that - just take your computer to someone who has the
    skills to fix it and pay for it - because the chances (as I see it) are slim
    that there will be any sort of fix beyond those offered throughout these
    newsgroups.

    I could be incorrect - it could still happen - but as time passes between
    the original incident (July 10, 2007) and now (July 23, 2007) -- it becomes
    less and less likely there will be any fully automated solution for you.

    (1) You need to repair .NET Framework 1.1 - obliterating all remnants of it
    and installing it/patching it fully.

    How to troubleshoot Microsoft .NET Framework 1.1 installation issues
    http://support.microsoft.com/kb/824643
    - Unregister and then reregister Windows Installer (See article)
    - Download/install/use:
    http://www.microsoft.com/downloads/...33-0343-4EE4-B0C4-97BD16967A09&displaylang=en
    - Manually remove and then reinstall the .NET Framework 1.1 (See the 824643
    Article)
    For the articles below, follow the "IT professionals" link and find the
    download for your OS.
    - Download/Install http://support.microsoft.com/kb/867460/
    - Download/Install http://support.microsoft.com/kb/886903/
    - Download/Install http://support.microsoft.com/kb/928366/

    Reboot as needed and at the end.

    (2) You need to repair .NET Framework 2.0 - obliterating all remnants of it
    and installing it/patching it fully.
    How to troubleshoot Microsoft .NET Framework 2.0 installation issues
    http://support.microsoft.com/kb/908077/
    - Unregister and then reregister Windows Installer (See article)
    - Manually remove and then reinstall the .NET Framework 2.0 (See Article)
    For the articles below, follow the "IT professionals" link and find the
    download for your OS.
    - Download/Install http://support.microsoft.com/kb/917283/
    - Download/Install http://support.microsoft.com/kb/922770/
    - Download/Install http://support.microsoft.com/kb/928365/

    Reboot as needed and at the end.

    (3) You need to repair .NET Framework 3.0 - obliterating all remnants of it
    and installing it/patching it fully.

    Unfortunately - there is no particular article pertaining to .NET Framework
    3.0 that I could find. I have not had issues, however, just going into the
    Control Panel --> Add or Remove Programs and just locating/removing it and
    its patches. I suggest you do the same and then reboot...

    Download/install using this distributable package:
    http://www.microsoft.com/downloads/...0B-F857-4A14-83F5-25634C3BF043&displaylang=en

    Reboot as needed and at the end.

    (4) Cleanup your updates system...

    Get Dial-a-Fix:
    http://wiki.djlizard.net/Dial-a-fix

    Use its options to fix:
    - Windows Installer
    - Windows Update
    - All the Registration Center options

    Turn off the "Empty System32\Catroot 2"
    Do NOT do "Flush SoftwareDistribution".

    Then click "GO"... May take a while.

    Reboot when it is done...

    (5) Visit http://windowsupdate.microsoft.com/ and scan for updates. Choose
    the critical updates you need and install them. Do not bother getting
    hardware updates (unless you happen to have some Microsoft hardware
    installed) and "Optional Updates" are *usually* just what the name infers -
    but feel free to see if you want any of the "Optional" ones.

    (6) Come back here and let us know how you came out...


    This has now come to light from a poster (Ray&Fran) and should be noted:

    Got everything installed but KB928367? This is caused by corrupted
    ..NET Framework 1.0 components. Simply hide the incorrect update...

    1. Open IE and go to the Windows Update site directly:
    http://www.windowsupdate.com
    2. Click "Custom Install" to scan your system (Not Express Install).
    3. After it finishes, please unclick the incorrect update.
    (Uncheck the box next to it.)
    4. Choose "Don't show this update again"
    (Check the box next to that under the update itself.)
    5. Scan the computer again to check the result.
     
    Shenan Stanley, Jul 23, 2007
    #40
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.