Sound Blaster Live annoyance

Discussion in 'Windows Vista Hardware' started by zoner, Apr 22, 2007.

  1. zoner

    zoner Guest

    I installed the Sound Blaster Live, drivers only, in XP compatibility
    mode. It installed and works fine but every time I start Vista the
    following message pops up and then disappears.
    "Completing installation of your audio card", "read reg"

    What do I delete to get rid of this message?
     
    zoner, Apr 22, 2007
    #1
    1. Advertisements

  2. zoner

    Mary Guest

    A new sound card. Sound Blaster Live is not scheduled for a vista driver
    update. The site says this: Please note that the product you have selected
    has been classified as "End of Service Life"
     
    Mary, Apr 23, 2007
    #2
    1. Advertisements

  3. zoner

    Mary Guest

    Read the posts further down this forum. One poster installed the incorrect
    Audigy vista drivers and got the SB Live card to work. I still think you
    should update to a newer card. Be advised that even new cards have some
    problems with Vista. My Creative card has vista drivers and has sound, but no
    gameport support yet.
     
    Mary, Apr 23, 2007
    #3
  4. zoner

    Rich Guest

    Only the 24 bit (newer) models of "Live" have Vista drivers available.
     
    Rich, Apr 23, 2007
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.