SP1 install error 80070570

Discussion in 'Windows Vista General Discussion' started by dkintheuk, Apr 28, 2008.

  1. dkintheuk

    dkintheuk Guest

    Hi all,

    I get this error when i try to install service pack 1. The download
    takes an absolute age as well (in excess of 4 hours and i have an 8Meg
    broadband connection).

    It seems to download fine but install always fails with the above
    error.

    Does anyone have any good ideas?

    Cheers,

    Rob.
     
    dkintheuk, Apr 28, 2008
    #1
    1. Advertisements

  2. dkintheuk

    TaurArian Guest

    Have you tried the manual install?

    Windows Vista Service Pack 1 (SP1) - 434.5 MB
    http://www.microsoft.com/downloads/...6d-5ebb-413b-89c9-cb3d06d12674&DisplayLang=en
    Windows6.0-KB936330-X86-wave0.exe

    Windows Vista Service Pack 1 for Windows Vista 64-bit (Size: 726.5MB)
    http://www.microsoft.com/downloads/...4B-32B2-41CC-BD8B-D71EDA5EC07C&displaylang=en
    Windows6.0-KB936330-X64-wave0.exe

    Windows Vista Service Pack 1 - All Language Standalone DVD ISO
    http://www.microsoft.com/downloads/...FamilyID=a45652b1-e838-420a-b065-83960458e2ec
    6001.18000.080118-1840_iso_client_sp_wave1-FRMCSP1_DVD.iso - 1418.1 MB

    Things to know before you download Windows Vista SP1
    http://technet.microsoft.com/en-us/windowsvista/bb968859.aspx

    Otherwise -

    Unlimited installation and compatibility support for Vista SP1 is available at
    no charge through 18 Mar-09
    .. US:
    http://support.microsoft.com/oas/default.aspx?ln=en-us&prid=11274&gprid=500921
    .. CA:
    http://support.microsoft.com/oas/default.aspx?ln=en-ca&prid=11274&gprid=500921
    .. UK:
    http://support.microsoft.com/oas/default.aspx?ln=en-gb&prid=11274&gprid=500921
    .. AU:
    http://support.microsoft.com/oas/default.aspx?ln=en-au&prid=11274&gprid=500921
    .. Other: http://support.microsoft.com/oas/default.aspx
    | select Windows Vista | select Windows Vista Service Pack 1


    --

    TaurArian [MVP] 2005-2008 - Update Services
    http://taurarian.mvps.org
    ======================================
    How to ask a question: http://support.microsoft.com/kb/555375
    Computer Maintenance: Acronis / Diskeeper / Paragon / Raxco



    | Hi all,
    |
    | I get this error when i try to install service pack 1. The download
    | takes an absolute age as well (in excess of 4 hours and i have an 8Meg
    | broadband connection).
    |
    | It seems to download fine but install always fails with the above
    | error.
    |
    | Does anyone have any good ideas?
    |
    | Cheers,
    |
    | Rob.
     
    TaurArian, Apr 28, 2008
    #2
    1. Advertisements

  3. dkintheuk

    Bob Eyster Guest

    If it's taking 4 hrs to download with broadband (8mg) something is wrong. It
    should take about 40 minutes at most
     
    Bob Eyster, Apr 28, 2008
    #3
  4. dkintheuk

    ZaPanda Guest

    Service Pack 1 Update
    Windows Vista error 80070570 or error 0x80070570
    Windows resource protection could not perform the requested operation.

    Hey,
    I just finished a ridiculously long session with tech support—we’re talking
    five hours plus here. I’m posting this in the hopes that it will save some
    poor muppet from wasting his or her entire day. Before I called tech
    support, I did EVERYTHING that was suggested on the self-help guides, with no
    success (e.g. ran the Chkdisk utility, virus scan, ran SP 1 as standalone).
    After five hours of tinkering, I broke down and called Microsoft.

    My background: I don’t know jack about computers, but I’m the king of
    messing with stuff until it works. What I suggest here may work for you, but
    you’re on your own. Microsoft will walk you through this if you have the
    time. To someone who is more experienced, my directions will sound naïve,
    but I don’t care. As I said before, if I save one person the agony of
    spending a day fixing something that should never have broken in the first
    place, then my work is done.

    My situation: My dad bought a spanking new laptop and Service Pack 1 failed
    to install during a scheduled, 3a.m. update. The good son (me) was asked to
    fix the problem.
    What is detailed below is the process tech support walked me through over an
    entire afternoon.

    1. The problem was diagnosed as faulty/corrupt system files. If a single
    system file is corrupt, Vista can’t update.
    2. Go into Programs and Features and uninstall you antivirus software. I
    was running Trend Micro (obviously don’t do anything that could cause
    problems with your antivirus software down).
    3. Before you start all the baloney that follows, make sure to download and
    save a STAND ALONE COPY of SP1 to your desktop. Depending upon your
    connection speed, this may take an hour or more. Do not run the file from
    the on-line source. Save the file somewhere like your desktop.

    [cut and
    paste]http://download.microsoft.com/downl...4c056d4c34d/Windows6.0-KB936330-X86-wave0.exe

    4. Go to Control PanelPrograms and Features Click Turn Windows features on
    or off (in upper left corner)Click Continuehit + key next to Microsoft NET
    Framework 3.0 uncheck XPS vieweruncheck Remote Differential Compression
    uncheck Windows DFS Replication Service.
    5. Confirm everything. Restart your system. With windows running, load the
    system restore DVD that came with your computer. This should fix the system
    files. As soon as you put in the DVD, you should click on the Upgrade
    feature. THIS PROCESS WILL TAKE AN HOUR or more. Your computer will turn
    off and on many times, so if you’re running a laptop make sure you’re plugged
    in and not on battery power.
    6. As soon as the process is over it will give you the option for, um,
    something. Click “ask me later.â€
    7. Take the DVD out (you may be able to do the SP1 update with the disk in,
    but why chance it).
    8. Now you’re ready to run SP1. Click on the file and run it. (once again,
    this will take an hour or more and your computer will turn off and on many
    times. Don’t touch the machine while it’s updating.).
    9. When the process is over your computer should give you the message that
    SP1 installed successfully.
    10. Go back to the Turn Windows features on or off, and click the three
    things from step 4 back on.
    11. Reinstall your anti-virus software.

    F.Y.I, for some reason, the update knocked all the Bluetooth stuff off-line,
    so I had to re-install the drivers for that stuff too.
    Hope this sheds some light on the situation. Let me know if this works for
    anyone. Best of luck. ~ZP
     
    ZaPanda, Jul 15, 2008
    #4
  5. Yes, I have had to do an in-place-upgrade to deal with courrupted folders
    before upgrading to SP1 so I am not surprised.

    The drivers that did not reinstall after the upgrade were probably some not
    properly written to allow automated reinstallation. Such drivers work fine
    except for that and user reinstallation is the resolution. Such drivers
    were what caused MS to delay putting SP1 on Windows Update for awhile to
    give vendors a chance to provice new drivers.
     
    Colin Barnhorst, Jul 15, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.