SP1 = System failure on old Pentium systems

Discussion in 'Server Setup' started by merc, Apr 23, 2005.

  1. merc

    merc Guest

    I spent the past 5 days investigating this and no matter what I try, SP1
    can't be used on old Pentium systems. I have 3 old Pentium servers that have
    no harware in common, except for them using Pentium 233 MMX processors.

    Upgrading all 3 of the systems to SP1 resulted in system failures that,
    required all 3 systems to be rebuilt to Windows Server 2003 w/o SP1. Each
    system would report that a file (usually ntoskrnl.exe, but not always) was
    either missing or corrupt, but neither was true.

    After the systems were lost, I tried rebuilding them using a Windows Server
    2003 with Service Pack 1 CD, but they would fail to reboot after the files
    were copied over. It is not a media problem, as the same media has been used
    for successful installations on all other types of hardware. Only the old
    Pentium 233 MMX systems have a problem.
     
    merc, Apr 23, 2005
    #1
    1. Advertisements

  2. Hello Merc,
    Do you have the exact errors that you recieved?
    Do you have any of the log files from the failed installs of the service
    pack?
    Do you have a copy of the boot.ini file during the failed install?
    What type of drives, partitions and controllers in the system?
    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
     
    Darrell Gorter[MSFT], Apr 24, 2005
    #2
    1. Advertisements

  3. merc

    merc Guest

    I don't have a exact error that I was receiving, but it was something like
    this:

    The file <insert file> is either corrupt or missing. <instructions on how
    to fix the issue>

    I tried to boot the system with loggin turned on, but no log files were
    created. If you have /sos turned on, it fails on the screen where it is
    loading the system files into memory. And it usually fails on the first file
    or the last file, but it always fails on this screen.

    The boot.ini file is exactly the same as it was when running w/o SP1, except
    for the option "/noexecute=optout" being added. I tried booting without this
    option, and ended up with the same results.

    [boot loader]
    timeout=5
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows Server 2003,
    Enterprise" /noexecute=optout /fastdetect
    C:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /cmdcons

    The drives are all IDE drives with either a single primary partition, or 2
    primary partitions (the second is just a 8G backup booting partition). The
    motherboards are all different, no-name, AMI, Toshiba (laptop) with the HD
    controllers embedded. As I said in the original message, other than the
    processor, the systems have no hardware in common.

    Thanks

     
    merc, Apr 24, 2005
    #3
  4. merc

    merc Guest

    Darrell,

    Is there any word on this? I'd like to install SP1 on these machines, but
    SP1 doesn't work. Is there going to be an SP1a?

    Thanks...


     
    merc, Apr 29, 2005
    #4
  5. Hello Merc,
    No there are no plans for an SP1a.
    The error message is usually indicative of a problem with the memory,
    processor of drives.
    I would use the Window Memory Diagnostic to check the memory.
    The exact file that is missing may give me some clue as to how far the OS
    is booting.
    If the file is kernal, then we may not be locating the OS volume properly
    or we may be thinking that the volume has changed for some reasons.
    The file could have been corrupted during the file copy process
    Create a slipstreamed share of Windows Server 2003 SP and try installing a
    new instace of Recovery Console.( you may want to back up the old instance
    first or you may have to reinstall it)
    When that is installed boot to Recovery Console and run MAP ARC.
    What do we report the partitions as? If they are different than what is in
    boot.ini currently we are seeing them properly.
    What controllers are in the system and what drives?
    IS there more than one controller and more than one hard drive?
    We may be detecting something that wasn't present before so we are adding
    in a controller or drive that we didn't see so the arc path could have
    changed.
    Create a floppy with the boot.ini, NTLDR and NTdetect.com on it from the
    existing OS.
    After installing SP1 and getting the error.( record the error if you do
    this)
    Try booting the floppy to see if the old copies of NTLDR, NTDetect.com and
    boot.ini allow you to boot the OS.
    It doesn't sound like we are getting far enough to start loading the OS,
    but the missting file in the error will tell us that.
    So I suspect all we are loading is NTLDR, NTDetect.com. and boot.ini and
    then nor locating the system to continue the boot.
    Thanks,
    Darrell Gorter[MSFT]

    This posting is provided "AS IS" with no warranties, and confers no rights
    --------------------
     
    Darrell Gorter[MSFT], Apr 30, 2005
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.