SPDIF Pass Through Does Not Work in MCE?

Discussion in 'Windows Media Center' started by robdes, Dec 18, 2003.

  1. robdes

    Guest

    On Thursday, December 18, 2003 10:01:46 AM UTC+1, Venger wrote:
    > I had similar issues when setting up my audigy2 NX to work with dolby
    > and DTS correctly. If you are using WinDVD 4 or above, and a SB
    > Audigy, here is what I did to get 5.1 sound to default in MCE.
    >
    > 1. Make sure your audigy is set to Digital Output Only.
    > 2. Make sure you have 5.1 speakers selected in the XP speaker settings
    > AND the Creative speaker settings app (FYI, I had to disable AC3 in
    > the Creative software for this to work)
    > 3. Open WinDVD and get into Audio mode to select Digital/SPDIF output
    > 4. Run Regedit and navigate to
    > [HKEY_LOCAL_MACHINE\SOFTWARE\Intervideo\Common\Audiodec]
    > 5. Create new DWORD value and name it "audio" (without the quotes)
    > 6. Open the value, and set the HEX value to 6 (this will force 6
    > channel output)
    > 7. Open MCE and make your way to the DVD audio settings... once you
    > select SPDIF now, it will remember it and output SPDIF every time you
    > put in a 5.1 or DTS DVD. I get the DD or DTS light every time on my
    > receiver now when the source plays.
    >
    > Hope that helps.
    >
    > Posted via http://www.xpMCE.com
    > Everything about Windows XP Media Center Edition


    Hi! Thanks a lot !!!! I Have Windvd 8 oem and a Creatice X-Fi Sigital Music Premium Audio interface running under Windows 7 and I could not get 5.1 sound Through the SPDIF link. In fact in W7 the appropriate register key hasto be entered under [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Intervideo\Common\Audiodec] with the same parameters a you indicate.
    This may help someone who has the same issue. Thx again
    BR, F-X.
     
    , Jan 3, 2014
    #21
    1. Advertisements

  2. robdes

    Guest

    On Thursday, December 18, 2003 7:01:47 AM UTC+1, robdes wrote:
    > I connect my PC to an AV reciever via a digital coax cable.
    >
    > I have the SPDIF pass through selected on the my audigy control panel
    > as well as in the audio setting in MCE and the audio setting in the
    > DVD player.
    >
    > If I play a DVD via InterVideo WinDVD (this is what shipped on my
    > gateway) it passes the raw digital signal to the AC reciever for
    > decoding there (I know this becuase my Sony reciever has a blue light
    > that inidcates it is receiving and decoding a multi-channel signal).
    >
    > However when I switch to MCE and play the same DVD is just sends a L/R
    > signal to the receiver.
    >
    > This is the same DVD, the only difference is the app from which I play
    > it (Intervideo vs MCE).
    >
    > HELP!!!!
    >
    > Posted via http://www.xpMCE.com
    > Everything about Windows XP Media Center Edition


    Hi! Thanks a lot !!!! I'm using Windvd 8 oem and a Creative X-Fi Digital Music Premium Audio interface running under Windows 7 Ultimate edition and Icould not get 5.1 sound through the SPDIF link. In fact in W7 the appropriate register key has to be entered under [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Intervideo\Common\Audiodec] with the same parameters you indicate.
    This may help someone who has the same issue. Thx again
    BR, N.
     
    , Jan 3, 2014
    #22
    1. Advertisements

  3. robdes

    Guest

    On Sunday, December 21, 2003 12:32:48 PM UTC+1, Venger wrote:
    > Yes, it works for me with the latest version (5.3 Plat). Don't know
    > about on-board SPDIF as I'm using a USB2 Audigy2 NX, which works
    > fine. I'm guessing as long as you can use pass-through of signal on
    > your on-board SPDIF, then it should work (i.e., your sound card
    > doesn't do the decoding and sends the signal to your external
    > decoder).
    >
    > Posted via http://www.xpMCE.com
    > Everything about Windows XP Media Center Edition




    On Sunday, December 21, 2003 12:32:48 PM UTC+1, Venger wrote:
    > Yes, it works for me with the latest version (5.3 Plat). Don't know
    > about on-board SPDIF as I'm using a USB2 Audigy2 NX, which works
    > fine. I'm guessing as long as you can use pass-through of signal on
    > your on-board SPDIF, then it should work (i.e., your sound card
    > doesn't do the decoding and sends the signal to your external
    > decoder).
    >
    > Posted via http://www.xpMCE.com
    > Everything about Windows XP Media Center Edition



    Hi! Thanks a lot !!!! It works also with another config. I'm using Windvd 8 oem and a Creative X-Fi Digital Music Premium Audio interface running under Windows 7 Ultimate edition and I could not get 5.1 sound through the SPDIF link. In fact in W7 the appropriate register key has to be entered under[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Intervideo\Common\Audiodec] withthe same parameters you indicate.
    This may help someone who has the same issue. Thx again
    BR, N.
     
    , Jan 3, 2014
    #23
    1. Advertisements

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
  1. Grae

    xbox360 hd-dvd drive and spdif pass-thru

    Grae, Apr 22, 2007, in forum: Windows Vista Hardware
    Replies:
    0
    Views:
    381
  2. Don Lindbergh

    USB soundcard with AC3/DTS SPDIF Pass through

    Don Lindbergh, Sep 14, 2006, in forum: Windows Vista Music, Pictures and Video
    Replies:
    1
    Views:
    956
    Steve Urbach
    Sep 14, 2006
  3. Don Lindbergh
    Replies:
    1
    Views:
    740
    mikwiz
    Sep 15, 2006
  4. Yavin

    SCSI Pass Through - DeviceIoControl does not return!

    Yavin, Sep 6, 2004, in forum: Windows Vista Drivers
    Replies:
    2
    Views:
    1,785
    Yavin
    Sep 7, 2004
  5. ajlimberis

    MCE2005 and Dolby Digital pass thru SPDIF

    ajlimberis, Nov 2, 2004, in forum: Windows Media Center
    Replies:
    8
    Views:
    371
  6. Rob
    Replies:
    6
    Views:
    504
  7. Aris, Greece

    spdif pass through problem

    Aris, Greece, Apr 19, 2006, in forum: Windows Media Center
    Replies:
    1
    Views:
    381
    Randy M
    Jul 2, 2006
  8. Nordlicht
    Replies:
    1
    Views:
    693
    ferzkopp
    Jun 20, 2008
Loading...