sql server icon disappear and SQL-DMO access violation

Discussion in 'Windows Server' started by Charles Lin, Nov 29, 2004.

  1. Charles Lin

    Charles Lin Guest

    hi folks,

    I have tried to installed Microsoft SQL Server 2000 Desktop Engine SP3a and
    the full SQL server 2000 on a Win 2000 server with the same result. This is
    the problem I see...

    With SQL installed and server rebooted, initially I see the sqlmangr.exe
    icon in the sys tray. But when I put my icon on it, it disappears. However,
    sqlserver.exe is still running in the Task Manager and also shows as
    "Started" in the Service Control Panel.

    I am looking at this Win 2000 server remotely, through either Terminal
    Service or VNC - both method gave the same result above.

    I think there is a problem because I have a third party application that
    invokes SQL-DMO to create database. Let's call the program x.exe for
    simplicity. When I execuate x.exe, I get a "SQL-DMO code execution error -
    Access Violation" and code 80040005

    I think my inability to invoke x.exe is tied to the sql server manager icon
    disappearing from the sys tray. In other words, there is something wrong
    with the sql server installation, although sql server installation log does
    not seem to indicate any problem.

    your help is greatly appreciated.

    thank you,

    Charles
     
    Charles Lin, Nov 29, 2004
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.