SRV record for Exchange AutoDiscover

Discussion in 'DNS Server' started by JohnB, Jan 5, 2010.

  1. JohnB

    JohnB Guest

    We use an outside provider for our Exchange email. And using RDP over HTTP.
    For Outlook 2007 clients, they using something called AutoDiscover. And
    Autodiscover requires a SRV record for autodiscover.domainName.com
    I created the autoDiscover SRV record yesterday to point to their Exchange
    server. It looks like the record was created correctly with our Registrar,
    the only part I wasn't sure of was Priority and Weight. I left those at
    zero. Could that be a problem? I used 443 for the port number.
    The only problem is, it seems though the record wasn't created, or at least
    the site that I use to check it, doesn't see it:
    http://www.hscripts.com/tools/HDNT/dns-record.php
    The domain name is blackDiamondRanch.com

    I know they say it can take 24 hours for it to replicate... it's been 22
    hours.
    The problem with Outlook 2007 clients is Out of Office Assistant doesn't
    work. It says the server cannot be located. And all of the research points
    to the need for a SRV record for autoDiscover. Are there any other ways
    (websites,etc) to see if this SRV record has been created, and replicated?

    I checked this site: https://www.testexchangeconnectivity.com/
    I can't do the test on there for OOF, it states that my Inbox needs to be
    empty in order to do that. I really don't want to delete all my email.
    I did the test for RDP over HTTP: it has lots of problems related to
    AutoDiscover, but did have this one success:
    Successfully retrieved AutoDiscover SRV record from DNS

    So it looks like from there, that the SRV record did get created.

    Any suggestions on this? I need to get this OOF working.

    Thanks
     
    JohnB, Jan 5, 2010
    #1
    1. Advertisements


  2. Priority should be 0, and weight should be 100.

    I went to that site, typed in blackDiamondRanch.com and selected to see SRV
    records, but none came up. How did you create the SRV record? I looked up
    your domain name for SOA info, and it appears you are using network
    Solutions, which does support SRV records.

    Also, Exchange doesn't necessarily need an SRV for Outlook Anywhere to work.
    In many cases if a registrar doesn't support SRV records, you can simply
    create an A record called autodiscover pointing to your
    mail.blackDiamondRanch.com, which should work.

    As for OOF, is it not working on your mailbox, or others as well? Maybe
    there is a corrupted rule causing it. Have you cleaned or disabled any rules
    and tried again? If you create a new test account, send a few emails to is,
    and use that for the test, does the OOF test succeed? Take a look at the
    following on how to troubleshoot OOF.

    Troubleshooting Out of OfficeMar 25, 2008 ... The typical solution here is
    to recognize that Exchange has a ... Now you can test and re-test to make
    sure that Out of Office is indeed not working correctly. ... However, before
    you do that, remember to export your inbox rules via .... Of course, the
    user will now need to reset their Out of Office ...
    http://www.msexchange.org/articles_...2007/tools/troubleshooting-out-of-office.html

    --
    Ace

    This posting is provided "AS-IS" with no warranties or guarantees and
    confers no rights.

    Please reply back to the newsgroup or forum for collaboration benefit among
    responding engineers, and to help others benefit from your resolution.

    Ace Fekay, MCT, MCITP EA, MCTS Windows 2008 & Exchange 2007, MCSE & MCSA
    2003/2000, MCSA Messaging 2003
    Microsoft Certified Trainer

    If you feel this is an urgent issue and require immediate assistance, please
    contact Microsoft PSS directly. Please check http://support.microsoft.com
    for regional support phone numbers.
     
    Ace Fekay [MCT], Jan 5, 2010
    #2
    1. Advertisements

  3. You can verify if your srv record is created in a command prompt. Go
    to start, run and type in the prompt:

    nslookup -type=srv _autodiscover._tcp.company.com

    Look for srv hostname value. It should be your hosted providers mail
    server.

    If the srv record is created as according to the
    testexchangeconnectivity test, then it could be the value of the
    external webservices parameter is incorrect. You can see this by
    pressing ctrl+right click on the Outlook Icon on the bottom right tray
    and choose "TEST EMAIL AUTO CONFIGURATION" enter your email address.

    Since you probably don't have access to check or change these; you
    will have to call your hosted provider. They would be the point of
    contact to set up your availability service if they support it in the
    first place.


    James Chong (MVP)
    MCITP | EA | EMA; MCSE | M+, S+
    Security+, Project+, ITIL
    msexchangetips.blogspot.com


    James,

    I ran an nslookup on it, and comes back to John's MX record:
    Non-authoritative answer:
    _autodiscover._tcp.blackdiamondranch.com SRV service location:
    priority = 0
    weight = 0
    port = 443
    svr hostname = asp-4.reflexion.net

    My feeling is that asp-4.reflexion.net is not the actual Exchange server,
    and may possibly be a third party mail hosting provider that's forwarding
    mail to John's Exchange server. If this server is SBS, then it may be using
    the POP3 connector. Hence why I believe OOF is not working if truly the MX
    record is actually a third party, even though the Exchange test says it
    successfully resolved an Autodiscover record, which is just a resolution
    test, nothing else.

    I also notice both weight and priority are 0. Priority is ok, but the weight
    should be 100.

    I guess we'll need John to respond with more info on how it's all setup,
    including if this is SBS 2008 with the POP3 connector.

    Ace
     
    Ace Fekay [MCT], Jan 5, 2010
    #3
  4. JohnB

    JohnB Guest

    I tried the NSlookup, I get this:
    *** Server.DomainName.local can't find
    _autodiscover._tcp.asp-4.reflexion.net: Non-existent domain

    I also tried it with just reflexion.net and got the same message

    When I do test Email Auto Config I get this:
    AutoConfiguration was unable to determine your settings.

    I'm going to contact the email provider next


    You can verify if your srv record is created in a command prompt. Go
    to start, run and type in the prompt:

    nslookup -type=srv _autodiscover._tcp.company.com

    Look for srv hostname value. It should be your hosted providers mail
    server.

    If the srv record is created as according to the
    testexchangeconnectivity test, then it could be the value of the
    external webservices parameter is incorrect. You can see this by
    pressing ctrl+right click on the Outlook Icon on the bottom right tray
    and choose "TEST EMAIL AUTO CONFIGURATION" enter your email address.

    Since you probably don't have access to check or change these; you
    will have to call your hosted provider. They would be the point of
    contact to set up your availability service if they support it in the
    first place.


    James Chong (MVP)
    MCITP | EA | EMA; MCSE | M+, S+
    Security+, Project+, ITIL
    msexchangetips.blogspot.com
     
    JohnB, Jan 5, 2010
    #4
  5. Make sure of the DNS server to which you're connecting.
     
    Ed Crowley [MVP], Jan 5, 2010
    #5
  6. JohnB

    JohnB Guest

    I called the provider and they now say we need a CNAME record. I checked
    with Network Solutions, and it was there. But apparently it was configured
    wrong. In the Alias box it should have been just AutoDiscover. Instead it
    had autodiscover.domainName.com. It adds the domain name automatically, so
    it had been doubled up.
    I changed it... now I'll wait for that to replicate and try it again.



    Yes that could be the case, just because you have an srv record will
    not mean it will work. The srv record will need to point to an
    Exchange server with the Autodiscover services. asp-4.reflexion.net
    seems to be qmail not Exchange.

    Your best bet would be to call the hosted provider and open up a
    ticket since you really don't control the server.

    James Chong (MVP)
    MCITP | EA | EMA; MCSE | M+, S+
    Security+, Project+, ITIL
    msexchangetips.blogspot.com
     
    JohnB, Jan 5, 2010
    #6
  7. JohnB

    JohnB Guest

    That was it. The CNAME record. OOF just started working.
     
    JohnB, Jan 5, 2010
    #7

  8. I haven't used CNAME records for the autodiscover feature, but if it works
    for you, then I'm happy to hear it was resolved.

    Ace
     
    Ace Fekay [MVP-DS, MCT], Jan 6, 2010
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.