Standard account can not run exe's when "run as administrator" is selected

Discussion in 'Windows Vista Administration' started by tankman1989, Sep 6, 2009.

  1. tankman1989

    tankman1989 Guest

    I am trying to start a new method of using my computer and am not going
    to run my profile as an Admin account. I am used to Linux and having to
    use SU or SUDO, so this should not be much different.

    I am running into the same problem that pushed me away from this model
    before. I did a fresh install of a laptop, ran all Vista Home Premium
    updates, created a standard account, logged into the standard account,
    selected an exe on my C:, right clicked and selected "Run as
    Administrator" and I get this message *"Windows can not access the
    specified device, path, or file. You may not have the appropriate
    permissions to access the item."*

    This error seems familiar as I tried this before and had the same
    problem. This pushed me into using an account that had elevated Admin
    privileges all the time (bad idea for someone who uses the internet and
    installs a lot of programs).

    What is the deal and how can I fix it?
     
    tankman1989, Sep 6, 2009
    #1
    1. Advertisements

  2. tankman1989

    Flavius Guest

    You can safely use not-build-in admin account with UAC turned
    on,because UAC pernamently seperate permissions as limited rights for
    user and admin rights see also:'User Account Control Step-by-Step Guide'
    (http://technet.microsoft.com/en-us/library/cc709691(WS.10).aspx).When
    you working normally on your admin account your are counting as limited
    user,if you want to do any which require admin rights you have to be
    authenticated (through UAC),when you'll authenticate permission are
    elevate for only required process not for all. This is difference
    solutions than SUDO or even SU from Linux but I guarantee it is fully
    safe also_Of course build-in admin account shouldn't be use in daily
    work and normally should be disabled.Build-in admin account should be
    used only in extremaly situations when normal not-build-in admins
    accounts are corrupted and impossible in any way to fix problems.

    Exactly relate to error message:
    Do you have the same error message on your (not-build -in) admin
    account? -if yes I would suspect any protected software:uninstall
    non-system firewall if you're using.If this is only on standard account
    possible also wrong UAC settings for standard users,you have to check
    UAC configuration:'How do I change the behavior of the User Account
    Control message? - Windows Vista Help'
    (http://windowshelp.microsoft.com/Windows/en-US/Help/1cc0e3a8-2cc0-43dc-b063-fa26fe5962c01033.mspx)
    '2.2.11 User Account Control'
    (http://msdn.microsoft.com/en-us/library/cc232771(PROT.10).aspx)
     
    Flavius, Sep 6, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.