Steam will not start as of Vista updates yesterday

Discussion in 'Windows Vista Games' started by Dave, Nov 15, 2007.

  1. Dave

    Dave Guest

    I am running Vista 64 bit Home Premium edition. Whenever I try to start any
    of my Steam games, the update for Steam gets to 26% and says that two copies
    of Steam are open (which they are not), and lets me go no further. I have
    never had any problems before, why has this just happened? I tried
    rebooting, and had seen some posts about a Vista update for a malicious
    spyware removal tool that may have something to do with it. Any ideas??
     
    Dave, Nov 15, 2007
    #1
    1. Advertisements

  2. Dave

    Andy [YaYa] Guest

    Run as Admin or disable UAC temporarily, see if that helps.

    Haven't seen any problems on my system today with Steam, played some TF2
    this morning.

    Worse case, uninstall Steam (save the steamapps folder somewhere), reinstall
    from the web download, copy the steamapps folder back into place and see if
    that helps.

    Good luck,
    A.
     
    Andy [YaYa], Nov 15, 2007
    #2
    1. Advertisements

  3. Dave

    Mike Wiggins Guest

    Don't know if this applies to 64-bit, but I had the same problem on an XP
    and Vista machine so I'm thinking it's a Steam problem. The solution I found
    is to delete ClientRegistry.blob from the Steam folder.
     
    Mike Wiggins, Nov 15, 2007
    #3
  4. Dave

    Jay Arr Guest

    I had the same problem. I read through the Steam suggestions for Vista and
    one item jumped out of the page - "Do not run Steam games in backward
    compatibility mode". Using that advice I unchecked the "Run this program
    in compatibility mode for <Windows XP (Service Pack 2)>" and the problem was
    solved. Thank goodness. It took me 3 hours to cure this problem which
    appears to have arisen with the arrival of the MS update on the 15th Nov.

    Happy to be back on-line with the magnificent Team Fortress 2.

    Jay Arr
     
    Jay Arr, Nov 16, 2007
    #4
  5. Dave

    sl4psh0t Guest

    Hi,
    This happened to me also around the same time 11/14 or so, I'm running
    vista 32

    Tried changing compatability mode and restarted but it didn't work.

    Also steam is not set to automatically start and UAC is deactivated

    I totally agree that it's a steam problem but I really dobt that they
    know what it is.

    Last time it happened the problem magically ended up fixing itself and
    I was able to login again about 5 days later.

    Finally got an email from steam support say that they noticed I was
    logining in again and if they could closed the incident.

    Going to try deleting ClientRegistry.blob as was suggested above.
     
    sl4psh0t, Nov 16, 2007
    #5
  6. Dave

    Andy [YaYa] Guest

    Yeah, for future reference, you should ONLY check stuff in the compatibility
    mode tab as a last resort, if all other troubleshooting fails. Usually games
    that have been updated or were released with Vista Support (Like Steam)
    shouldn't need faking/tricks to get them to work correctly. If the box says
    "Vista Supported" then you shouldn't have to use that stuff.

    Grats btw.
     
    Andy [YaYa], Nov 16, 2007
    #6
  7. Dave

    Ken Guest

    Yup deleting ClientRegistry.blob worked like a charm, thanks for the
    help!
     
    Ken, Nov 16, 2007
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.