Still Can't Delete a file

Discussion in 'Windows Vista File Management' started by Justin, Oct 20, 2009.

  1. Justin

    Justin Guest

    Windows Vista Ultimate 64.
    I right click and hit delete on a file and I get
    Item not found
    This is no longer located in C:\Users\Justin\Downloads verify the items
    location and try again.
    The file is a MS Word docx, downloaded from my college's Blackboard system.
    I booted into safe mode (under the admin account) and ended up with the
    same message.
    I was told this could possible be an issue with Temporary Internet files
    and IE - I use Firefox. Nonetheless, I cleared out the TIF on both
    browsers and the file is still there.
    Justin, Oct 20, 2009
    1. Advertisements

  2. Justin

    Tae Song Guest

    You might try starting elevated Command Prompt (start as administrator) and
    try deleting it. Elevated Command Prompt will sometimes allow you to delete
    files you can't through the GUI, because the GUI treats files differently
    depending on various settings and context.

    You might also try running/scheduling a CHKDSK /F to check for file record
    Tae Song, Oct 20, 2009
    1. Advertisements

  3. Justin

    Dave-UK Guest

    Can you move the file to your desktop and delete?
    Can you right-click and Sento the recycle bin?
    If you rename it can you delete it?
    If you right-click Properties > Security do you have full control?
    If not, can you edit permissions to give you full control?
    If none of the above help then you could try taking ownership:
    Dave-UK, Oct 20, 2009
  4. Justin

    Justin Guest

    I already have ownership.
    Justin, Oct 20, 2009
  5. Justin

    Dave-UK Guest

    How did you get ownership ?
    You said you downloaded it from another computer onto your machine.
    Right-click the file > Properties > Security > Advanced > Owner tab.
    What does it say in the 'Current owner box'?
    If it isn't you, you haven't taken ownership.
    Dave-UK, Oct 20, 2009
  6. Justin

    Justin Guest

    I downloaded it from the internet - my college's Blackboard system.
    It has my account listed as the Current owner.
    Justin, Oct 20, 2009
  7. Justin

    Dave-UK Guest

    Then I am out of ideas regarding permissions.
    If it were my machine the next step would be to boot from a BartPE or linux
    disk and delete from there.
    (If you can't get such a disk I can give you a link to mine.)
    Dave-UK, Oct 20, 2009
  8. Justin

    rak Guest

    It may not help the root cause of your problem, which is beyond me, but I
    have found that I can get rid of files like this by using freeware such as
    Eraser that writes over the file. You might want to try something similar.
    rak, Oct 20, 2009
  9. Justin

    Just Me Guest

    Have you tried something like:
    Just Me, Oct 20, 2009
  10. Justin

    Dave-UK Guest

    Have you managed to delete it yet ?
    Dave-UK, Oct 22, 2009
  11. Justin

    Dave-UK Guest

    How's the file deletion saga going ? Still having problems?
    Dave-UK, Oct 25, 2009
  12. I fussed around without success. Then downloaded the freeware Unlocker
    1.8.8, and it removed without a problem. Really frustrating that I couldn't
    find a simple solution.
    JoshinBuffalo, Nov 7, 2009
  13. Justin

    Justin Guest

    Sorry Dave, I was working on something else.
    I'm a student so I have pieces of time on and time off.
    The problem has gotten worse - I not have several files that won't
    delete - torrents in my Downloads folder. Now before you say somethign
    abotu downloading unsafe stuff, I was downloading Formula 1 races and a
    TV show - no software and they are all in the xvid format - no
    proprietary players. I use VLC to play them.

    Here is what I have:
    When I right click and hit properties

    Delete confirmation:

    It barks at me saying it can't delete

    Here is the security tab for one of the files.

    So far I tried a utilility called move on boot - didn't work because
    moveonboot can't find the file. I point it directly to the phantom file
    and it barks at me saying it can't find it.

    Apparently there's a pointer to a nonexistent file.
    Deleting in safe mode - no same thing can't find the files.
    ran malwarebytes check - clean.
    I tried to rename the files - no dice - access denied.

    I tried the following batch file
    @echo off
    del -p -f %1

    goto exit

    no effect whatsoever.

    ran sfc /scannow
    found nothing wrong.

    My next step is to download a knoppix CD, boot from that and try
    deleting without even entering Windows.
    Justin, Nov 11, 2009
  14. Justin

    Dave-UK Guest

    I don't use Torrent software myself but having Googled your problem
    apparently there is some setting somewhere where you can select an
    option/button to "delete torrent & data".
    I'd have a look for that option first.

    This post has a method:
    It's because the name of the file has spaces or something that makes
    Vista think it doesn't exist or is an empty file.
    Dave-UK, Nov 11, 2009
  15. Justin

    Justin Guest

    Yeah, I just figured it out.
    Justin, Nov 11, 2009
  16. Justin

    anh Guest

    You should try a couple of freeware programs that deal with situation
    like this

    1) Unlocker is a good little utility.

    'Unlocker 1.8.8 Download - Freeware - Utilities Category

    2) Move On Boot is also good

    'MoveOnBoot - Rename, Move, Delete Locked Folders and Locked Files o
    Restart' (

    If those two don't resolve the problem, here is another solution, bu
    it's only for the technically proficient

    1) Shut down and unplug your computer.

    2) Pick it up, taking care to lift it safely

    3) Put it in the boot of your car (we technicians call this a reboot)

    4) Drive to a lake, a scenic one for preference. Stop off on the way t
    pick up some cold beers

    5) Take computer out of boot, carry to lake edge and throw it in

    6) Take out beers and drink by side of lake, reflecting on how muc
    better your life is now that your computer is at the bottom of the lake

    That's it
    anh, Nov 12, 2009
  17. Justin

    Bob Guest

    Bob, Nov 12, 2009
  18. Justin

    Justin Guest

    Or get a mac! I already have a Macbook 15.
    I tried those utilities per advice from the kids at

    Right after I got the problem fixed they banned me. :)
    Justin, Nov 13, 2009
  19. Justin

    Justin Guest

    Tried it - didn't work.
    The problem turned out to be an issue with spaces at the end of a
    filename. Windows can't find the file for whatever reason.
    I solved it be "del *torrent* and that was it.
    Justin, Nov 14, 2009
  20. Justin


    Jun 26, 2013
    Likes Received:
    you can use unlocker to find which process is accessing and lock the file
    justintjacob, Jun 26, 2013
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.