Still Trying to KILL wmplayer.exe DEAD, DEAD, DEAD

Discussion in 'Windows Vista General Discussion' started by Guest, Jan 27, 2009.

  1. Guest

    Guest Guest

    Vista sp1
    Wmplayer.exe is causing me grief.
    I can't burn a CD because the drive is in use by...
    you guessed it...wmplayer.exe. Yes, I can start task manager
    and kill it and restart the burning program.
    Not at all clear how it's getting started.
    Some suggest that it's being started by mobsync.exe
    when I insert a flash drive. Since I always have
    a flash drive inserted...

    Often, but not always, I can't eject a flash drive because
    it's in use. Killing wmplayer usually, but not always releases it.

    I rename wmplayer, it comes back.
    I renamed the file, and the one in the prefetch cache
    and turned off system restore. Turned off automatic updates.
    Two days later, I try to burn a CD and can't...wmplayer back.

    Is there a dummy file that just sleeps that I can rename as wmplayer.exe
    and make windows quit reinstalling it?

    I don't want windows to sync anything or play anything or index
    anything. When I insert media or a flash drive, I want a drive
    letter assigned and NOTHING else.

    I don't want wmplayer to run EVER. How do I stop this
    invasive program???

    Thanks, mike
     
    Guest, Jan 27, 2009
    #1
    1. Advertisements

  2. Have you considered checking the default actions for media insert and, where
    necessary, disabling Media Player from there? Open Control Panel then
    AutoPlay.
     
    Richard G. Harper, Jan 27, 2009
    #2
    1. Advertisements

  3. Guest

    Guest Guest

    First thing I tried.
     
    Guest, Jan 28, 2009
    #3
  4. Guest

    MollieAnn Guest

    Have you tried disabling the "Windows Media Center Extender Service" i
    services
    (start, type "services.msc" (w/o quotes), then find above an
    disable.

    Good luck

    Molli
     
    MollieAnn, Jan 28, 2009
    #4
  5. Guest

    zachd [MSFT] Guest

    Let's step back to the beginning: ~why~ is the player using the CD player at
    that time when you're trying to burn? If the player isn't burning, I don't
    believe it's going to try to acquire a lock on the burner: that seems like
    something else might be going on.
    What app are you using to burn?

    As regards "not starting the player" : you're starting services (mobsync,
    for example) that use the player.

    As regards "killing the player": what you're trying to do there is not
    supported. Third party system-destroying tools such as vLite might give you
    what you want there, but : you really would be taking a hammer to your
    system and breaking it.
     
    zachd [MSFT], Jan 28, 2009
    #5
  6. Guest

    Guest Guest

    My question exactly...

    If the player isn't
    imgburn 2.4.1.0
    Been using it for ages on xp on the same hardware with no problem.
    One thing I just realized is that I replaced a USB hard drive with
    a USB flash drive at about the same time I switched from XPSP2 to
    VistaSP1 They are known to behave differently.
    Yep. That's been discussed. I found some tools to disable that,
    but I'm waiting till the next system backup before I try it.
    Unknown tools from unknown developers is risky.

    When I plug in a usb drive, I want a drive letter assigned...NOTHING ELSE!!!
    There's supported and then there's useful unsupported. Most of the best
    stuff is in the latter category.
    Third party system-destroying tools such as vLite might give
    I'll have to take another look. Thought vlite only worked on the
    initial install setup. Can I apply it after the fact?
    , but : you really would be taking a hammer to
    If that's what it takes...
    I've never found ANY reason to knowingly activate wmplayer.
    Removing the player system may have unintended consequences with other
    players that expect certain OS support files. If I can just prevent
    it from executing, I'd be a happy camper. Renaming the file works for a
    while. If I could prevent it reinstalling itself, I'd be a happy camper.

    One man's breakage is another man's fixing.
     
    Guest, Jan 30, 2009
    #6
  7. Guest

    Guest Guest

    Yep, that was one of the first things I tried.
    I just looked again. There's a thing called
    "windows media center service launcher".
    Says it's only used for TV, but I disabled it too.
    There were other windows media services set to manual.
    I disabled all of them.
    I'll see if that help.

    I thought I'd also disabled windows update, but it
    was running. Disabled that too.
    Will be interesting to see if my system boots.
    Thanks, mike
     
    Guest, Jan 30, 2009
    #7
  8. Guest

    Guest Guest

    Mine won't burn until I kill wmplayer.exe. Then it will allow the burn
    but the verify fails. Rebooting solves the problem. I haven't done a LOT
    of experimenting, but it appears that if I kill wmplayer BEFORE starting
    imgburn, I get a successful burn.
    Can't hurt to try the new version.
    thanks, mike
     
    Guest, Jan 30, 2009
    #8
  9. Guest

    Placehold Guest

    Placehold, May 20, 2009
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.