Stuck at "Checking for the latest updates for your computer..."

Discussion in 'Windows Update' started by vasilemj, Aug 25, 2006.

  1. vasilemj

    vasilemj Guest

    Whenever I go into Windows Update and select either "Express" or "Custom" the
    update appears to hang at "Checking for the latest updates for your
    computer..."

    I also notice that SVCHost jumps up to nearly 100% and is consuming the
    entire CPU.

    Any suggestions on how to resolve this would be greatly appreciated.

    Thanks,
    Mark V.
     
    vasilemj, Aug 25, 2006
    #1
    1. Advertisements

  2. vasilemj

    globalnett Guest

    this is happening to me too.... w2k sp4 / IE6
    I even pulled the hardrive+installed in another system+formatted and fresh
    load of os......same exact issue. overnight it did get updates+installed but
    now
    it keeps getting the same one-installs-goes back and gets it again,over+over
     
    globalnett, Aug 25, 2006
    #2
    1. Advertisements

  3. vasilemj

    dave xnet Guest

    Hello, there have been many reports of this recently, quite a few
    on win2k and mosty apparent on older, slower machines.

    Take a look at windowsupdate.log and look for any smoking guns.

    Dave
     
    dave xnet, Aug 25, 2006
    #3
  4. vasilemj

    vasilemj Guest

    My machine happens to be running Windows XP Home Edition. It is about 6-7
    years old but has been running very smoothly without a hitch.

    384 MB RAM
    768 MHz (or close to that....I'm not in front of it right now)
     
    vasilemj, Aug 26, 2006
    #4
  5. vasilemj

    Colley Phil Guest

    I'm experiencing this as well and it's driving me mad. It has worked happily
    in the past up until a couple of weeks ago. My PC is only a couple of years
    ago and a good spec, so this isn't an issue. Any info very welcome!
     
    Colley Phil, Aug 30, 2006
    #5
  6. vasilemj

    vasilemj Guest

    Coincidentally, I recently read an article on WindowsSecrets.com that talked
    about alternatives to Windows Update. If you're interested, the article can
    be found here:

    http://windowssecrets.com/comp/060720/

    I have not personally tried the solution recommended but it seems like it
    would be a good work-around.
     
    vasilemj, Aug 30, 2006
    #6
  7. Me, too. It took so long for the analysis (more than 5 minutes) that I
    thought the PC had "hung". Finally, I just let it "hang" while I watched
    a TV program, and then after 5 to 10 minutes, I looked over and the
    PC was showing a dialog box asking if I wanted a standard or
    custom installation. Now I just automatically click on Updates and
    watch TV or fix breakfast. This only started a couple months ago.

    My PC has a 450MHz Intel PII, 384MB of DRAM, and a 7,500rpm
    hard drive with 8GB of empty space in the OS's partition. I've been
    running WinXP Pro for a couple years without this long delay. The
    start of the problem *may* have coincided with the installation of
    Visual Studio.NET for C# and SQL Server Express.

    *TimDaniels*
     
    Timothy Daniels, Aug 31, 2006
    #7
  8. vasilemj

    vasilemj Guest

    I always get to the screen where it asks me to select either "Express" or
    "Custom". I have always selected "Custom" and that's where it hangs as I
    have previously described. Not sure what would happen if I selected
    "Express" but I would prefer not to do this.
     
    vasilemj, Sep 1, 2006
    #8
  9. I guess we have different problems, then. Just getting to that screen
    takes ages for my PC.

    *TimDaniels*
     
    Timothy Daniels, Sep 1, 2006
    #9
  10. vasilemj

    Colley Phil Guest

    This is exactly where it hangs for me so i guess we've got the same problem.
    Here is what I've just done, and it has vastly improved the situation. It
    does happen with both express and custom.

    I put windows update on and selected express - I had enabled pop up on MS
    Update site by selecting tools, pop up blocker, pop up blocker settings, add
    (not convinced this did anything other than allow me to see the green bar
    going across while it was searching for updates but can't be bothered to
    prove or disprove). Once I had selected express, I walked away for an hour.
    When I came back it had got to the update stage.

    I went back in and chose custom and installed every update going (thank god
    I'm broadband!). Now when I go in and select express or custom and observe
    in task manager, the CPU is fluctuating between 50 and 100% rather than
    flat-lining at 100% as before. The check is now only taking about a minute
    compared with up to one hour before.

    I still need to keep auto updates disabled though, but that's OK as I don't
    want this on as I like some control - I now just get annoyed by that stupid
    balloon now saying my computer is at risk as auto updates are disabled - no
    it isn't, it's right up to date!!!

    I'm still not happy with this as I'd like the CPU usage problem sorted, but
    at least I now have it manageable. I will now update every week.

    Hope this is helpful, but sorry not a complete solution. BTW thanks for the
    link you sent. Interesting and I'll definitely give it some thought.

    Cheers, colley phil.
     
    Colley Phil, Sep 1, 2006
    #10
  11. vasilemj

    vasilemj Guest

    Thanks Colley. I'll give this a shot and let you know how it works on my end.
     
    vasilemj, Sep 6, 2006
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.