Submit Form - 400 Bad Request Error

Discussion in 'Internet Explorer' started by Majortomm, Jun 12, 2007.

  1. Majortomm

    Majortomm Guest

    I have been trying to log into a site
    (https://secure.ingdirect.com/myaccount/InitialINGDirect.html?command=displayLogin)
    and as soon as I fill out the form and click "Next" the page immediately goes
    to 400 bad request error. There is no page load time, the error is
    immediate. I can go the site using Firefox or using IE7 on my other computer
    just fine. I have compared the security settings and I cant find a
    difference between the working and non-working IE7's.

    Here is my IE deets:
    Version: 7.0.5730.11
    Update Versions: 0

    Thanks
     
    Majortomm, Jun 12, 2007
    #1
    1. Advertisements

  2. Majortomm

    Leonard Grey Guest

    Same problem when you run IE 7 with no add-ons?

    Start > All Programs > Accessories > System Tools > Internet Explorer
    (No Add-ons)
     
    Leonard Grey, Jun 12, 2007
    #2
    1. Advertisements

  3. Majortomm

    Majortomm Guest

    I just tried your suggestion and I get the same error message if I use the No
    Add-ons option.
     
    Majortomm, Jun 12, 2007
    #3
  4. Majortomm

    Leonard Grey Guest

    Still have the problem after you reset IE 7 to its defaults?
    Internet Explorer > Tools > Internet Options > Advanced tab > Reset
    Internet Explorer settings

    Conflict with pre-existing security software?
    Check to make sure all security software is compatible with IE 7.

    Malware on the computer?
    Scan with several of the stronger online malware scanners, followed by
    HiJack This.
     
    Leonard Grey, Jun 12, 2007
    #4

  5. FWIW I can't test that case exactly, since I don't have an account there.
    However, FYI HTTP 400 is often a symptom of using HTTP 1.0
    when HTTP 1.1 is expected by the host server. So, if you have HTTP 1.0
    specified try changing both HTTP settings to HTTP 1.1.
    (In fact, that idea would make more sense to me if the URL wasn't HTTPS, so YMMV.)

    BTW I'm getting a Certificate Error message for that site with IE7,
    so if you're seeing that too and not telling us about that,
    it could be significant too. Leonard might even be able to help
    you with that, for example: ; )

    http://www.microsoft.com/communitie...b77a99-230e-4144-b736-38e68ed28bd2&sloc=en-us


    If you're technically minded at all you might want to try Fiddler2
    (or Fiddler + RPASpy). That would give you a different
    perspective on the actual details for your problem scenario.

    http://www.fiddler2.com/fiddler2/faq.asp

    (Live Search for
    Fiddler2 RPASpy
    )

    <quote>
    you should no longer need to use RPASpy with Fiddler2
    </quote>


    HTH

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jun 13, 2007
    #5
  6. Majortomm

    Leonard Grey Guest

    I didn't get a certificate error -- but then, I didn't try to log in.
     
    Leonard Grey, Jun 13, 2007
    #6
  7. Majortomm

    Majortomm Guest

    I have gone through and reset everything back to the IE defaults and I even
    did the IE reset option that wiped everything out and removed the Google
    Toolbar. All of this still produced the same error message. I have also run
    my spyware applications and everything is clean. It seems to be only
    happening when I try and submit form data through an HTTPS session. The 400
    error is immediate, it is like IE is not even trying to post the data to the
    server it just goes straight to the error page. I am not getting any type of
    certificate error so I dont see what is happening there. I have also made
    sure that all the HTTP 1.0, 1.1 options are checked as well. If I bring up
    IE7 on my other computers it works fine so I know its not the site/server.

    Stumped and Confused :-(
     
    Majortomm, Jun 13, 2007
    #7

  8. After I posted I read Eric Lawrence's FAQ more carefully
    and figured out that the Certificate Error symptom could be due
    to using Fiddler2. Then I also realized that that could have been
    part of your answer to the earlier question too. <eg>


    Robert
    ---
     
    Robert Aldwinckle, Jun 13, 2007
    #8
  9. Majortomm

    Simon Tang Guest

    I've been having this issue too- for Windows Live and Facebook apps. I haven't resolved it yet, but I'd like to know why this is:
    I can access Windows Live messenger and Gmail but not Windows Live. I'm using a new XP computer and my other one works just fine. I'm using IE7 with Google Toolbar, and I wondered if maybe Google could have caused this? I have tried it with no add ons as well.
    Any help would be greatly appreciated.
     
    Simon Tang, Jul 31, 2008
    #9
  10. Majortomm

    Gordon Guest

    <VB Sigh> WHAT ISSUE?

    This is NOT some "forum" - this is a global Usenet Newsgroup. Please QUOTE
    the post you are replying to, reply to the thread and do NOT change the
    subject line.
     
    Gordon, Jul 31, 2008
    #10
  11. Majortomm

    N. Miller Guest

    Would you be referring to this:

    | http://groups.google.com/group/micr...c520590ef8f/b188b36baedf2ffd#b188b36baedf2ffd

    Did you read the entire thread?

    --
    Norman
    ~Shine, bright morning light,
    ~now in the air the spring is coming.
    ~Sweet, blowing wind,
    ~singing down the hills and valleys.
     
    N. Miller, Jul 31, 2008
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.