Suddenly cannot see other computers in my Workgroup and they can't see me

Discussion in 'Windows Vista Networking' started by Rev. Michael L. Burns, Apr 21, 2009.

  1. I have a home network that consists off an XP Desktop, a Vista Desktop, a XP
    Notebook and a Vista Tabletpc. They could all see and access each other with
    no problem. The Tabletpc and Notebook both are connected by wireless while
    the desktops are connected by Cat5.

    This morning I went to use the Tabletpc and it cannot see either of the
    other computers and they cannot see the Tabletpc., regarless whether I am
    connected by wireless or Cat5. However, they can see and access each other
    fine. The other three computers can see and access each other fine.

    I have tried everything I can think of to get the tabletpc to recongnize
    the other computers an vise-versa to no avail.

    The last time I used the tabletpc on my home network was about 8 days ago
    and it was working fine. That night I was admitted to the hospital for a
    week. While there I connected to the hospital's wifi. Not sure if this
    changed something or not but other than that I have not downloaded any
    software, updates, etc.

    I might add that I can access the internet fine through the tabletpc.

    Any ideas what may be causing this?

    Michael
     
    Rev. Michael L. Burns, Apr 21, 2009
    #1
    1. Advertisements

  2. Compare the problematic computer ipconfig /all with other computers. Or post
    them here.

    --
    Bob Lin, MS-MVP, MCSE & CNE
    Networking, Internet, Routing, VPN Troubleshooting on
    http://www.ChicagoTech.net
    How to Setup Windows, Network, VPN & Remote Access on
    http://www.HowToNetworking.com
     
    Bob Lin \(MS-MVP\), Apr 21, 2009
    #2
    1. Advertisements

  3. in network and sharing center make sure the active network is shown as
    'Private network', not public network (it should have got set as public when
    you connected to the public WIFI, but perhaps is not getting set back to
    Private now that you are home.
     
    Michael Walraven, Apr 21, 2009
    #3
  4. I verified that it is Private and network discovery is on.

    Michael
     
    Rev. Michael L. Burns, Apr 21, 2009
    #4
  5. Rev. Michael L. Burns

    Chuck [MVP] Guest

    Michael,

    Logs from "browstat status", "ipconfig /all", "net config server", and "net
    config workstation", from each computer, may provide essential clues that lead
    to identification of the problem. Read this article, and linked articles, and
    follow instructions precisely (download browstat!):
    <http://networking.nitecruzr.net/2005/05/troubleshooting-network-neighborhood.html#AskingForHelp>
    http://networking.nitecruzr.net/2005/05/troubleshooting-network-neighborhood.html#AskingForHelp
     
    Chuck [MVP], Apr 21, 2009
    #5
  6. All IP address in same network? (192.168.1.x for instance).
    Could also be a firewall preventing discovery, if you have added updated or
    otherwise modified your security software that might be a place to check.

    As a magic incantation I have sometime been successful by turning off a
    function and then turning it back on. Doesn't cost much to try.
     
    Michael Walraven, Apr 21, 2009
    #6
  7. I just noted in the Network and Sharing Center under under File Sharing,
    there are two options, On or Off. When I select On and then Apply it does
    not show as on but as Custom which isn't one of the options. Check of drive
    C shows that it is being shared. Could the Custom be part of the problem.
    Ipconfig/all on Notebook (which works) and tabletpc (which doesn't) show no
    differences other than network card type.

    Michael
     
    Rev. Michael L. Burns, Apr 21, 2009
    #7
  8. My settings are:
    Network discovery - ON
    File Sharing - ON
    Public folder sharing - ON (Password required)
    Printer sharing - ON (Password required)
    Password protected sharing - ON
    Media sharing - Off

    This is pretty much the way Microsoft Recommends for my machine. Other
    setups will work of course but may be more interesting.

    Sharing the C:\ (root) drive is discouraged. You should consider why you are
    doing that! (If you did not do it, then you may have a problem with a
    compromised system).

    As I understand, Custom can result if some services have been turned off and
    also if some firewall setting interfere with the operations.

    Michael
     
    Michael Walraven, Apr 21, 2009
    #8
  9. Michael,

    My settings are the same as yours with the exception of always showing
    Custon for File Sharing. Any ideas as to what services may be turned off?

    Michael
     
    Rev. Michael L. Burns, Apr 21, 2009
    #9
  10. Michael,

    Got it working fine now. You pointed me in the right direction. Not sure how
    or why, but the following services were turned off: Workstation, Remote
    Registry, Shell Hardware Detection and Windows Media Player Network. I
    enabled them all and can see and access files on all computers now an they
    can see and access my files.

    Thanks to you and all who offered assistance.

    Michael
     
    Rev. Michael L. Burns, Apr 21, 2009
    #10
  11. from a google <<"network and sharing center" custom>>

    "Network discovery requires that
    the dnscache, fdrespub, ssdpsrv, and upnphost services are started, that the
    Windows Firewall
    exception for network discovery is enabled, and that other
    firewalls are not interfering with network discovery. If some but not all of
    these are true, the network discovery state will be shown as Custom."

    not sure if that also applies to File Sharing

    you might open Windows Firewall, change settings, exceptions, make sure
    checks are on for File and Printer Sharing. Also consider Advanced tab,
    restore button.

    Michael
     
    Michael Walraven, Apr 21, 2009
    #11
  12. glad to see you got it solved, and thanks for feedback for the next person
    with a similar problem.
     
    Michael Walraven, Apr 21, 2009
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.