Suddenly Can't Print .. no clue why

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Snuffy2, Jul 17, 2009.

  1. Snuffy2

    Snuffy2 Guest

    So I've got a problem I just don't know how to resolve or further debug.

    I've got a Thinkpad Laptop running Vista x64 Ultimate. I reinstalled
    the OS ~3 weeks ago and installed my print drivers. I have 2 network
    printers and I also use doPDF to create PDFs. All of these were working
    just fine.

    Today they are not printing correctly, but not in a way I can figure
    out. Applications give me an error saying there is an unknown error or
    that there is no default printer installed. This happens in Firefox,
    OpenOffice, Acrobat, Thunderbird and others.

    The weird thing is that if I goto control panel and try to print a test
    page with any of the printers it works fine. In addition, I can print
    txt files from both Notepad & Wordpad, but still not from Openoffice.

    So why is it I can print simple txt files & test pages but not from the
    apps I need to print from. BTW this happens for all the printers I have
    installed including the 2 network printers, the local PDf printer
    (doPDF), & the XPS printer. These all worked last time I printed (a few
    days ago), but not today.

    What can I do to ideally fix this or at least better debg this?

    Thanx
     
    Snuffy2, Jul 17, 2009
    #1
    1. Advertisements

  2. First thing I'd do is use System Restore to return a couple of days ago to
    when all seemed OK. Then while it's running and printing OK, look at what
    you are downloading/installing/updating and see which app is causing the
    problem.
     
    Cari \(MS-MVP\), Jul 17, 2009
    #2
    1. Advertisements

  3. Snuffy2

    Snuffy2 Guest

    Anyone with ideas
     
    Snuffy2, Jul 22, 2009
    #3
  4. Did System Restore not work?
     
    Cari \(MS-MVP\), Jul 22, 2009
    #4
  5. A good first step is to open Control Panel and uninstall the printer that is
    not working. Reboot and let Windows discover the 'new' printer and install
    the drivers for it. Often that works
    A good second step is to use System Restore and restore to the most recent
    date the printer did work.
     
    Little Charlie, Jul 22, 2009
    #5
  6. Snuffy2

    Snuffy2 Guest

    System restore and uninstalling and reinstalling the printers have no
    worked

    Anything else? I really would like to print again
     
    Snuffy2, Jul 26, 2009
    #6
  7. Do the printer(s) have ink in them?

    Do they appear to be installed correctly?
     
    Cari \(MS-MVP\), Jul 27, 2009
    #7
  8. Snuffy2

    Snuffy2 Guest

    Printers work fine and all other PCs in the house can print to the
    fine. They are both network printers. I also cannot print to the buil
    in PDF and XPS printers either with the same error

    I can print simple txt docs from Notepad & Wordpad and test pages fro
    within control panel from this PC but cant print real docs from any app
     
    Snuffy2, Jul 27, 2009
    #8
  9. Aha.... then it's what we refer to as an application error, since you CAN
    print from Notepad and Wordpad. I'd suggest reinstalling the application in
    question... BTW what app is it?
     
    Cari \(MS-MVP\), Jul 29, 2009
    #9
  10. Snuffy2

    Snuffy2 Guest

    It's Every other app! Acrobat, OpenOffice, Microsoft Office, Firefox
    Thunderbird, IE, everything else. I have tried reinstalling a few o
    these apps but no success

    I can only print test pages from the control panel for the printer an
    simple txt files from within wordpad & notepad. No other app will print
     
    Snuffy2, Jul 29, 2009
    #10
  11. Make sure you are not just hitting the 'print' icon on the toolbar, but
    selecting File, Print... and then making sure you select the printer from
    the drop down box. It's possible you're printing to a virtual printer like
    Acrobat PDF Creator, Microsoft XPS printer etc.
     
    Cari \(MS-MVP\), Jul 30, 2009
    #11
  12. Snuffy2

    TryToHelp Guest

    I resolved a problem like this on my PC today... I had reset my wireless
    router due to a problem connecting to the Internt, and my
    network-connected HP printer stopped working. I went to Control Panel
    Printer window, right-clicked and brought up the Server Properties of
    the printer. Under the Ports tab, I could see the IP address that the
    spooler was configured to use. I then selected "Add a printer" to add a
    Network Printer. In this way, I discovered that my router had assigned
    a different address to my printer after the reset. So, I went back to
    the Ports property page and selected the correct address for it (using a
    checkbox on the left and clicking Apply). That fixed the problem.
     
    TryToHelp, Aug 10, 2009
    #12
  13. That's a common problem when you do not apply a static ip address to the
    printer. Look in the printer manual and see if you can configure it with a
    static ip so that the router does not try to change it each and every time
    the router has lost power, then comes back on and reassigns all the ip
    addresses.
     
    Cari \(MS-MVP\), Aug 11, 2009
    #13
  14. Snuffy2

    JayRFisher Guest

    I have the same problem. have tried the same steps as above. One other
    data point ... in task manager, you will see multiple instances of a
    process called splwow64.exe. If your powerpoint presentations are at
    all complex, this process will replicate thousands of times until it
    consumes all memory and you will need to reboot. I'm stumped. I can
    print from (at least some) 64 bit applications as above, but not any 32
    bit.
     
    JayRFisher, Aug 25, 2009
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.