The Active Directory Domain Service is currently unavailable

Discussion in 'Windows Vista Networking' started by Steve Clements, Dec 5, 2007.

  1. I am on a Vista laptop, connected by wireless to an XP-Home (SP4) desktop.
    Connected to the desktop is a Canon printer.
     
    Steve Clements, Dec 5, 2007
    #1
    1. Advertisements

  2. Sorry. Start again.

    I am on a Vista laptop, connected by wireless to an XP-Home (SP2) desktop,
    which is connected to a Canon printer. The entire network is Cable Modem,
    Wireless Router, Desktop and Printer (wired), Laptop (wireless).

    There are three accounts on the laptop. All three are connected to the
    internet via the wireless router. Two of them can print to the Canon printer,
    but the third cannot.

    I give that account Admin rights. I log on as that user. I select "Print"
    from a Word document and the only "Printer" available is "Microsoft XPS
    Document Write". I click "Find Printer", and I get the error message in the
    subject line.

    I compare this user's network connection settings to the other users. I
    don't see any difference, but there are a lot of settings.

    I go to Start/Network. I right-click on the Desktop and select Explore. I
    right-click on SharedDocs and select Explore. I select "Desktop/Printers"
    from the folder structure on the left, and the Canon printer and FAX appear
    and say "Ready".

    So it seems that the printer is visible to this user (as it is to the other
    users), but this user can't print to it.

    Ugh. Thanks. (And Thanks, Microsoft, for this support community thing.)
     
    Steve Clements, Dec 5, 2007
    #2
    1. Advertisements

  3. Robert L. \(MS-MVP\), Dec 5, 2007
    #3
  4. Steve Clements

    Lgbpop Guest

    Has anyone discovered a solution for this problem yet?
     
    Lgbpop, Feb 12, 2008
    #4
  5. Steve Clements

    umbrellasys Guest

    Did you try adding the printer using Administrator privs? Just go to the
    Control Panel > Printers > Run As Administrator > Add Printer. This
    process allowed me print on the network printer. Unfortunately, MS Word
    will not work at all if the network printer is setup as the default and
    was not added by the administrator.
     
    umbrellasys, Jul 2, 2008
    #5
  6. SWEET! Worked for me. thanks
     
    Boulderbronco, Jul 25, 2008
    #6
  7. Steve Clements

    cinnamon Guest

    I have been having the same problem and have spent hours on the phon
    with Microsoft Support. They finally closed it as 'unresolved'.
    found this but don't see a 'Run As Administrator' option, just Contro
    Panel >Printers>Add Printer.

    I completely uninstalled the printer - using both the remove program
    applet in the control panel, as well as manually deleting any files tha
    related to it and removing any references in the registry throug
    Regedit. Note that one of the solutions considered was to actuall
    install the printer drivers, etc. locally even though I was accessing i
    on the Network.

    I reinstalled on the Network only and still never found the 'Run A
    Administrator' option. Note that I AM the Administrator on this machine
    How do I get to this?

    Thanks
     
    cinnamon, Aug 9, 2008
    #7
  8. Steve Clements

    Lgbpop Guest

    Go to *Control Panel | Printers* and right-click on *Add Printer*
    select -Run as Administrator-

    Having administrative-level privileges on your user account isn't th
    same thing as using your administrator account - Administrator is
    separate user account. I haven't tried using that in Vista yet, but i
    XP you log in in Safe Mode to access the Administrator account
     
    Lgbpop, Aug 9, 2008
    #8
  9. Steve Clements

    cinnamon Guest

    Thanks for your reply. Unfortunately Vista doesn't give a right-contex
    menu for add a printer. Nor does it have the Admin available from Saf
    mode (insane).

    I've done a bit more research regarding the Administrator account.
    Apparently Vista has it hidden, and the home Premium version (which
    when I bought the computer, I was told was 'professional' level as in X
    professional), doesn't have a local users and groups snap-in, so yo
    can't even add it or activate it. I did find some forum threads an
    articles on how to create and activate the Admin account using the cm
    console and editing the registry. I then accessed it and installed th
    printer through it - still didn't work.

    If you haven't used Vista and you are a person who wants to contro
    your own computer, then don't get it!! Microsoft believes that the onl
    people using computers at home are just shopping and downloadin
    pictures and porn! They must be protected from themselve
    (hmmm...sounds like the government)

    I will continue my fight - or perhaps have to upgrade to Vist
    Business. Apparently I can't downgrade to XP, it's a tablet notebook an
    I have heard I would loose some functionality (touch screen, fingerprin
    scanner, etc.)


    Thanks agai
     
    cinnamon, Aug 9, 2008
    #9
  10. Steve Clements

    brujita Guest

    Hello everybody

    I have the same problem as yours.

    First, I connect my computer by wireless. In my house we have 4
    computers: 3 Mac and 1 Windows. The wireless network is from the Mac
    computers.
    When I go to *Start, Network, *I can see the Computer's name in which
    the wireless come from. Then I want to use their printer that is a HP
    PHOTOMASTER 2006 SERIES, but it ask me for password and user name, which
    I have both, but it doesn't work. The other 3 computer that are Mac work
    perfectly by the wireless and so they can print just while the main
    computer is sharing it. The main computer is allow to share the printer
    always.

    Second, I also when I try to find printers from the Microsoft Word the
    message in discussion of the forum comes out unallowing to find the
    wireless printer.

    I have to questions:

    1. Do you think I can use the printer of this wireless that comes from
    a Mac computer? How can I do it?

    2. How can I eliminate the XPS Microsoft Office printer? I have tried
    to unset it as a default but it doesn't work?

    In adition, I don't know if I have to install the software of the HP
    photosmart 2006 in my Windows computer first, then I could print by it
    using the wireless.

    Could someone help me, please? This is driving me crazy.
     
    brujita, Aug 12, 2008
    #10
  11. Steve Clements

    Gotbier Guest

    OMG!!! I have been on line and on the phone with Microsoft, HP an
    Toshiba for months, and NONE of them have been able to help me with thi
    issue! This worked perfect, and, to top it off my husband who know
    very little about computers, other surfing, is the one fixed it for m
    using your awesome instructions!! Thank you Thank you Thank yo
     
    Gotbier, Aug 25, 2008
    #11
  12. I have a Vista computer networked to an XP computer that is physically connected to a Samsung printer. I have been printing fine for 8 months now. Suddenly I am getting this error message when I try to print from the Vista computer. The Vista computer sees the Samsung just fine. The Vista computer is able to connect to the XP computer and save a word document to the XP and then print. It just can no longer send an item to print across the network anymore. Like I said, it had been printing fine. How can I make the "Active Directory Domain Service" available again?

    Thank you,
    Cindy
     
    Cindy Backstein, Aug 26, 2008
    #12
  13. Steve Clements

    Gotbier Guest

    My husband fixed mine. From the Control Panel, he opened the printers,
    right clicked on the printer I use, then selected Run As Adminsitrator
     
    Gotbier, Aug 26, 2008
    #13
  14. Robert L. \(MS-MVP\), Aug 26, 2008
    #14
  15. Steve Clements

    wendygan Guest

    For Vista users, this is what I did. And after several sleepless night,
    I can finally close my eyes. First of all you must know your base
    station (I'm using Airport Express) *IP address*. You could either get
    it from "Airport Utility" or for Window users right click on the
    "Wireless Network Connection", click "Details". The IP address is there.

    1. Go to "Network"
    2. Click "Add a Printer"
    3. Click "Add a network, wireless or Bluetooth printer"
    4. If your desired printer doesn't appear, click "The printer that I
    want isn't listed"
    5. Click "Add a printer using TCP/IP address or hostname"
    6. Key in the Hostname or IP address (I key in the IP add)
    7. Click next
    8. Select your printer driver or "have disk option"

    This should solve the problem. Good luck ;)
     
    wendygan, Aug 26, 2008
    #15
  16. Steve Clements

    Cindy Guest

    I have already tried that. Didn't change a thing. Thanks for replying
    though. Cindy
     
    Cindy, Aug 26, 2008
    #16
  17. Steve Clements

    Cindy Guest

    I'm not sure my reply made it through as after I typed it, it took me to a
    screen to enter my name again and then gave me a message about exceeding a
    limit and to contact microsoft if I don't get an email allowing me in. So I
    will try again just incase...

    Thank you for replying. I have already tried that but it didn't change
    anything. Cindy
     
    Cindy, Aug 26, 2008
    #17
  18. Steve Clements

    squishedworm Guest

    I found this on the microsoft forums ('\"Windows cannot connect to the
    printer. Access is denied\" -please help. - TechNet Forums'
    (http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=1192680&SiteID=17)),
    hope it helps

    *Melonhead *
    [image: http://forums.microsoft.com/TechNet/images/stars3.png]


    Posts 16
    *Answer **Re: \"Windows cannot connect to the printer. Access is
    denied\" -please help.*
    [image:
    http://forums.microsoft.com/TechNet/emoticons/PostAttributeIMG/AnswerIcon.gif]
    [image:
    http://forums.microsoft.com/TechNet/emoticons/PostAttributeIMG/Spacer.gif]
    Was this post helpful ? '[image:
    http://forums.microsoft.com/TechNet/Themes/default/images/newpost_en_US.gif]'
    (http://forums.microsoft.com/TechNet...iteID=17&ReturnUrl=&LCID=1033&ed=true)'[image:
    http://forums.microsoft.com/TechNet/Themes/default/images/quote_en_US.gif]'
    (http://forums.microsoft.com/TechNet...215821&SiteID=17&Quote=True&LCID=1033&ed=true)
    I had the same problem. I found a solution. Logically it makes no sense
    to me, but it worked so...

    Go to *-Control Panel-*. Choose *-printer-*. Then choose *-Add
    Printer-*.

    Choose*-Add a local printer.-* Click on *-Create a new port.-* The
    default in the drop down box is *-Local Port-*. Do not change that.
    Click *-Next-*.

    A dialogue box will appear asking for you to enter a port name. Type in
    the '_\\_*-_computer_-*' (file://computer/)*- name\printer name-* ie. My
    computer's name is basement and the printer name is EpsonSty so I typed
    in *-\\basement\epsonsty-*

    Yahoo! It worked. Go figure! I guess Microsoft thinks printers on a
    intranet are local.
    Hope this helps someone else so they don't spend the hours I did on it!
     
    squishedworm, Sep 2, 2008
    #18
  19. Steve Clements

    tomule Guest

    Thanks squishedworm this works! You would think Microsoft would make i
    easier to link to your printer via your wireless network.
    Thanks agai
     
    tomule, Sep 6, 2008
    #19
  20. Hi, I was having trouble with the error message as well (i'm a mac person, and i would like to state that my mac work properly the first time). The solution that work for me was to go to control panel, then search for printer where i then changed the default printer. Fixed it right up. Though i find it intersting that "Pinters" is not an imidiate option under the control panel.
     
    Heather Smith, Sep 14, 2008
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.