the system cannot log you on now because the domain <domain>is not available

Discussion in 'Server Networking' started by Madhusudhan, Sep 9, 2004.

  1. Madhusudhan

    Madhusudhan Guest


    Im using a Dell latitude laptop with win2003 professional
    running on it. It was a member of my company's domain till
    last eveninng.

    I used it as a stand alone elsewhere this morning and now
    it refuses to log on to the network, giving the message
    "the system cannot log you on now because the domain
    <domain>is not available".

    I am able to ping the domain controller from the computer
    by logging in as admin of the local computer. But i'm not
    able to enter the domain. Have tried many of the fixes
    like switching to workgroup and then rejoining the domain
    and such funny things.

    there are close to 20 other computers that are on the
    domain and working fine with any valid username.

    None of them work. Can anyone help?

    This is urgent
    Madhusudhan, Sep 9, 2004
    1. Advertisements

  2. Madhusudhan

    Miha Pihler Guest


    Can you check your client's DNS setting under TCP/IP. Make sure that it
    points to your Active Directory DNS (probably your active directory DNS). If
    you entered some other DNS (e.g. your ISP DNS), your computer will not be
    able to find domain controller and you will not be able to log on.

    If you still have problems after this check your Event Logs (System and
    Application) for any errors and post back with this information.

    Miha Pihler, Sep 9, 2004
    1. Advertisements

  3. First thing to check is that if you have any personal software firewall on it,
    disable it when you try to join the domain. The other thing to check is that the
    computer is pointing to the same domain controller as the other computers that work
    fine as it's preferred dns server in tcp/ip properties as shown in Ipconfig /all. --
    Steven L Umbach, Sep 9, 2004
  4. Madhusudhan

    Guest Guest

    Mike and Steve, thanks for your replies.

    1. there is no personal firewall in the system.
    2. the dns settings are exactly the same as that on other
    systems that are funtioning well on the domain.
    3. event logs : "NO windows NT or windows 200 domain
    controller is available for domain abc. the following
    error occurred: There are currently no logon servers
    available to service the logon request."
    Guest, Sep 10, 2004
  5. Try running netdiag on your computer to see if it reports any related errors. Netdiag
    is a free support tool on the install disk in the support/tools folder where you will
    have to install the support tools from. You can paste any errors/failed tests in a
    reply here. --- Steve
    Steven L Umbach, Sep 10, 2004
  6. Madhusudhan

    Madhusudhan Guest

    Thanks to advice from you guys I went through teh event
    log and stuff and did every little thing suggested. THe
    event log showed teh failed attempts at locating the DC.

    However, after all this I just gave one last shot at
    registering the computer to the domain and miraculosly, it
    worked. I really don't know how to explain how it happened.

    Something similar happened when I had teh same problem
    adding a new dell to the domain a month back. After
    several unsuccesful attempts, I added it to a workgroup ,
    rebooted and added it to the domain and it worked.
    Something strange is surely happening between Dell
    Latitudes, Win2003, WinXP.

    My hitch :
    The latest problem happened after someone tried to log
    onto teh system as a stand alone at some other place using
    the same id, as if they were actually logging on to teh
    domain. Since their details were cached, it worked.
    That , I feel has in someway corrupted some files causing
    this problem.
    any takers for my theory. in any case im gonna replicate
    this error later and see what happens. that, im sure would

    NETDIAG (thanks steve):
    i ran this now(after teh comp was able to join teh domain)
    and this seems the only problem area in the result.

    DNS test . . . . . . . . . . . . . : Passed
    [WARNING] Cannot find a primary authoritative
    DNS server for the name
    The name '' may not be
    registered in DNS.

    Thanks for all teh help guys, esp. steve.
    Madhusudhan, Sep 10, 2004
  7. Madhusudhan

    Madhusudhan Guest

    Thanks Steve,

    I have written a detailed reply to the parent thread of
    this discussion. Thanks for your help.

    support/tools folder where you will
    Madhusudhan, Sep 10, 2004
  8. Windows XP Pro in certain configurations seems to have problems with SMB signing.
    What I would suggest trying, at least temporarily, is to open Domain Controller
    Security Policy and go to security settings/local policies/security options and
    disable the security option for server digitally sign communications(always) if a
    Windows 2003 domain. If this is a Windows 2000 domain try disabling all four
    digitally sign communications options assuming that none of the domain member
    computers are configured to require it in their Local Security Policy which they
    would not be by default. -- description of XP and SMB issues.

    The other main concern is that dns is configured correctly for the whole domain. In
    short, domain controllers must point to the pdc fsmo [usually first domain
    controller] and/or themselves as their preferred dns server in tcp/ip properties as
    shown with Ipconfig /all. W2K/XP Pro domain computer must point only to domain
    controllers running dns with the AD domain zone and NEVER an ISP dns server anywhere
    in the list of dns servers. An ISP dns server could be third in the list, but if the
    other dns server are slow to respond the domain computer may instead use the ISP dns
    server and all kinds of problems will result including failed logons and failure to
    join a domain. Review the Active Directory FAQ for dns below for details.;en-us;291382

    Use first netdiag and then dcdiag on your domain controllers to see if any failed
    tests, errors, or fatal warnings are found that may indicate a problem. If you have
    more than a few domain controllers just do the pdc fsmo and the domain controller
    your computers are using for dns. If their is a problem it will probably pop up
    testing those two. If problems are found with netdiag you can use the /v verbose
    switch to find out further details as in " netdiag /test:dns /v ".

    It is possible if a user has installed "protection" software on their computer that
    it can interfere with network communications. Some of this software monitors for
    spyware and may modify computer configuration so keep that in mind. There also seems
    to be a lot of winsock corruption going around that causes dns problems. Lspfix is a
    free program to repair winsock corruption and there seems to be no harm running it on
    a computer that does not have the problem. The last link is how to use netsh to reset
    tcp/ip on a Windows XP computer. -- lspfix;en-us;299357 -- how to reinstall tcp/ip on Windows 2000

    Check out these items and see if you make any progress. --- Steve

    Steven L Umbach, Sep 10, 2004
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.