The system cannot log you on now because the domain not available

Discussion in 'Server Networking' started by MCP200, Nov 23, 2006.

  1. MCP200

    MCP200 Guest

    Hi Everyone,
    I get The system cannot log you on now because the domain <DOMAIN_NAME> is
    not available when i try to log onto the the domain

    When I get to the stage of entering the username and password it waits for
    10 seconds and then I get an error message saying that the domain is
    unavailable, however if I wait 20-25 seconds before logging on, it logs me on
    straight away

    It only occurs when you first boot up the machine ,and If I enter the
    username and password I get the domain is unavailable but it's working fine
    the 2nd attempt and logs me onto the domain very quick

    I don’t know if its dns issue ,but it sounds that the machine isn’t getting
    the ip address from the DHCP server quick enough. What’s your opinion please?

    Is this releated to Cached Logon Count problem?

    Thanks
     
    MCP200, Nov 23, 2006
    #1
    1. Advertisements

  2. MCP200

    MCP200 Guest

    Can someone assist please?
    What i tried doing on every machine,is set the nic to 100mb full duplex.
    Now it doesn't come up with The system cannot log you on now because the
    domain <DOMAIN_NAME> it sits there for 20 seconds and then it starts to apply
    personal settings.]

    can someone advise me please?
     
    MCP200, Nov 24, 2006
    #2
    1. Advertisements

  3. so, you set your NIC to 100MB and the symptom is gone

    except there is a 20 second delay after logon and "Apply Personal Settings"

    just not sure what your question is, so let me ask some :

    is your problem the 20 second delay ?
    does it occur after a boot ?
    does it occur after a logout (no boot) ?


     
    Edwin vMierlo, Nov 24, 2006
    #3
  4. MCP200

    steve Guest

    Do your DNS settings point to the internal DNS (AD) server *only*? You
    shouldn't have any external DNS entries on any of your internal clients.
     
    steve, Nov 24, 2006
    #4
  5. MCP200

    MCP200 Guest

    Edwin I was getting the error message every time I starup the machine,
    however the message no longer appears since enabling 100mb full duplex on the
    network card, but now it sits there for 20-25 seconds and then it starts
    applying personal settings instantely.Seems that when it starts up it doesn't
    get the ip address from the dhcp server fast enough?

    If I log off and log on again, it logs me on straight away. This is occurs
    only when you first starup your computer.

    I wanna know why there is such delay at startup?

    Many Thanks


     
    MCP200, Nov 25, 2006
    #5
  6. MCP200

    MCP200 Guest

    Steve,
    The internal machine have dns settings which point to the server box.
    Also the dns server forwards the query to the router which it provides the
    ISP's primay and secondary dns.

    Thank you

     
    MCP200, Nov 25, 2006
    #6
  7. "getting an IP" from the network, and time it takes to get it, might vary
    depending on your network configuration.
    Example: if you are using STP on Cisco switches, the cisco switch might (not
    always, just might) take up to 30 seconds to (try to) detect loops in the
    topology. These checks happen on all ports, unless you use the "portfast"
    command. (this detection of loops in the topology is when layer 1 and 2 are
    initializing and to establish link, more than likely at boot time !)

    if you use cisco, have a look here
    http://www.cisco.com/warp/public/473/12.html

    Obviously this is only one factor... there could be many more.


     
    Edwin vMierlo, Nov 25, 2006
    #7
  8. MCP200

    MCP200 Guest

    Thanks for the reply,
    I have two 2948 Cisco switches installed, but they are not configured.
    It's been installed as it is. So there is no way of management unless I
    configure them.


    The old server was connected to the same switches and would apply personal
    settings after entering username and password but would take long time
    because of dns issue.Now with new server once entering the userid and
    password it waits for 20-25 seconds and then it starts to apply personal
    settings very quick.At first i was getting the domain is unvailable but
    that's rectified since enabling 100 MB Full Duplex.

    Do you suggest to configure the switches?

    Sorry for being a pain

    Thanks

    However with this server once you bootup and enter the username and
    password ,it thinks for 20-25 seconds and then it starts to apply peronsal
    setting and your in windowes instantely.



     
    MCP200, Nov 25, 2006
    #8
  9. no, not at this point

    a quick test:
    - boot the machine
    - wait 5 minutes (at this point all network should be up and done)
    - then login

    does it still "sit there" for 20-25 seconds ?



     
    Edwin vMierlo, Nov 25, 2006
    #9
  10. MCP200

    Guest Guest

    I know the following is kind of specific but it may apply to you
    anyways if you are running Windows 2000 SP4.

    Did this behaviour start happening after you installed KB914388?

    Do you have "The DHCP Client service hung on starting" errors in your
    event log?

    If so, try the following:

    Use Regedit32 and go to
    HKLM\System\CurrentControlSet\Services\DHCP\DependOnService

    add ProtectedStorage to the bottom of the list of services and reboot.

    HTH





    Ha®®y

     
    Guest, Nov 25, 2006
    #10
  11. MCP200

    MCP200 Guest

    Edwin,
    Thanks for the reply.
    no need to wait 5 minutes, if i wait 30 seconds it logs me on straight away.

    Thanks

     
    MCP200, Nov 25, 2006
    #11
  12. In that case, I suspect the cisco switches not being configured might (not
    100% sure) be what is causing this.

    (you can configure 1 port as a test and prove it is indeed the cause)

    For you the question, is it worth configuring the switches ?
    Once you go down this route, you need to maintain a configuration on your
    network equipment, which in itself brings an overhead.
    So, either you simply "live with it" or you configure your switches ...

    As a different poster has commented, check the system/app event logs for
    clues if http://support.microsoft.com/kb/914388 is applicable.

    HTH,
    _Edwin.


     
    Edwin vMierlo, Nov 26, 2006
    #12
  13. MCP200

    MCP200 Guest

    Hi guys,
    I have checked the system event viewer.I have the following error messages
    for server


    The server could not bind to the transport
    \Device\NetBT_Tcpip_{92922F1B-B28D-4F4E-8C36-960107B1B1E7}.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.


    and for Netlogon


    The dynamic deletion of the DNS record 'ForestDnsZones.shaps.nsw.edu.au. 600
    IN A 192.168.168.254' failed on the following DNS server:

    DNS server IP address: <UNAVAILABLE>
    Returned Response Code (RCODE): 0
    Returned Status Code: 0

    USER ACTION
    To prevent remote computers from connecting unnecessarily to the domain
    controller, delete the record manually or troubleshoot the failure to
    dynamically delete the record. To learn more about debugging DNS, see Help
    and Support Center.

    ADDITIONAL DATA
    Error Value: A socket operation was attempted to an unreachable host.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.


    I have run the command DCDiag.exe and it showed that everything has passed.
    I also ran the command nltest.exe /dsregdns .

    I have installed the patch that has been mentioned for the DHCP.
     
    MCP200, Nov 27, 2006
    #13
  14. "I have installed the patch that has been mentioned for the DHCP"

    did it make a difference ? fixed ?
     
    Edwin vMierlo, Nov 27, 2006
    #14
  15. MCP200

    MCP200 Guest

    Edwin ,
    It hasn't fixed the problem :(
    I even confiured a port switch as full duplex and didn't fix the problem.
    don't know were to start from now.

    This issue does not occur when logging with administrator account after
    bootup.
     
    MCP200, Nov 27, 2006
    #15
  16. OK, so we have more info now, which actually changes the symptom description
    a bit.

    Just to summarise here:
    - boot computer
    - logon immediately after boot with "normal domain user" will cause 20-25
    seconds of delay
    - logon immediately after boot with "domain administrator" will NOT cause
    20-25 seconds of delay
    - logon after 30 seconds wait after boot with "normal domain user" will NOT
    cause 20-25 seconds of delay

    do you agree with the (new) symptom description ?

    (I don't think this is caused by your network switches, likely be in the
    host machine.)

    any different system event messages if you compare a failed "domain user"
    logon with a sucsesful "administrator" logon ?
    list them as :
    1) failed logon with normal user
    -- log error 1
    -- log error 2
    2) sucsesful logon with admin
    -- log error A
    -- log error B

    Rgds,
    Edwin.
     
    Edwin vMierlo, Nov 27, 2006
    #16
  17. MCP200

    MCP200 Guest

    Edwin,
    The symptoms mentioned below are correct.
    I will log on as domain user and domain admin and compare the event logs.
    I will post the event logs.I'm bit superised that this issue occured with
    new machine that was put on the network and similar issue on every host
    machine,

    Many Thanks.
     
    MCP200, Nov 27, 2006
    #17
  18. MCP200

    MCP200 Guest

    Hi Edwin,
    This is what i captured from the event viewer

    Your computer was not able to renew its address from the network (from the
    DHCP Server) for the Network Card with network address 00148510768D. The
    following error occurred:
    The semaphore timeout period has expired. . Your computer will continue to
    try and obtain an address on its own from the network address (DHCP) server.

    For more information, see Help and Support Center at
    http://go.microsoft.com/fwlink/events.asp.


    This error message is on 5 different machines that i tried.
    i cleared the system event and restarted the machine.It was 20-25 seconds
    and then it logged on.So i logged on as admin and check the system event and
    it was the same event.Seems that the problem is with DHCP.
     
    MCP200, Nov 28, 2006
    #18
  19. Edwin vMierlo, Nov 28, 2006
    #19
  20. MCP200

    MCP200 Guest

    I'll test tommorrow and i'll let you know.

    Many Thanks.
     
    MCP200, Nov 28, 2006
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.