The Windows Installer Service could not be accessed.

Discussion in 'Windows Update' started by Greg Kirkpatrick, Apr 16, 2007.

  1. The Windows Installer Service could not be accessed.
    This can occur if you are running Windows in safe
    mode, or if the Windows Installer is not correctly
    installed. Contact your support personnel for assistance.
    -------------------------------------

    I get this every time I try to install Windows Installer 3.1 (msxml3.msi),
    the latest version of it. I reasoned that Windows Installer was the issue
    when Windows Updates and Microsoft Updates kept giving me instant error
    messages (something about UserData persistence needing to be enabled, which
    it already is). Since an .MSI file is installed with Windows Installer, it
    doesn't seem possible that I will be able to fix the problem this way.

    I have also tried a repair install of Windows XP Professional SP2 from CD.

    I have also tried a secedit command to reset security parameters.

    I have also restarted the Cryptographic Services and the Automatic Update
    service.

    I have also tried to install Windows Installer 2.0 (InstMSIW.exe), but it
    tells me that my OS is the wrong version.

    Possible (likely?) contributing factors: after completing a clean install
    of Windows Professional SP2 from CD, and after downloading and installing all
    available Windows Updates, I attempted to lock down the computer as well as
    possible using the CIS NG Scoring Tool and the free Belarc Advisor 7.2.
    After following their advice, I was able to reach a score of 94.3% and 8.54
    out of 10, missing a perfect score due to my inability to adjust a few
    settings that they insisted were needed, including: increasing the size of
    event logs [I did it, but they only recognized one of my three changes],
    changing a few user permissions [about 6 just won't work], and changing the
    caching of logons by a workstation in a domain [no problem, since this will
    be a standalone computer, except no setting worked for it].

    As far as I can tell, Administrators have access to run Windows Installer,
    so I don't think it is a permissions problem.

    However, I have overlooked something.
     
    Greg Kirkpatrick, Apr 16, 2007
    #1
    1. Advertisements

  2. msxml3.msi is **NOT** Windows Installer 3.1 -

    http://www.microsoft.com/downloads/...fc-5f56-4a38-b838-de776fd4138c&DisplayLang=en

    WindowsInstaller-KB893803-v2-x86.exe IS the Windows Installer in
    executable form.
    Have you checked the KB893803v2.log located in %windir% for error codes?


    MowGreen [MVP 2003-2007]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============


     
    MowGreen [MVP], Apr 17, 2007
    #2
    1. Advertisements

  3. Thank you -- you're absolutely correct. Problem solved

    MSXML3.MSI is the Microsoft XML Parser (MSXML) 3.0 Service Pack 7, which was
    recommended in one of the "fixes" that I read.

    I am very embarassed, as I thought I had tried to install WI 3.1 -- but I
    got sidetracked. I hope this didn't waste too much of your time.

    Windows Installer 3.1 is now installed, and I am no longer getting the error
    message when I access Windows Updates.

    Thanks again.

     
    Greg Kirkpatrick, Apr 18, 2007
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.