This file is missing media usage rights

Discussion in 'Windows Media Player' started by Andrew, Aug 9, 2009.

  1. Andrew

    Andrew Guest

    When I try to rip any CD it just says error. When I right click on the file
    and look at the Media Usage Rights tab it just says 'This file is missing
    media usage rights'. Doesn't matter what CD I use, I've tried new CDs, old
    CDs, burned CDs, all the same result.
     
    Andrew, Aug 9, 2009
    #1
    1. Advertisements

  2. Andrew

    Panzy Guest

    There is a copy protection scheme known as DRM.
    The problem you are having is nothing to do with
    your CD's being encoded with DRM, but your version
    of WMP is unable to discern copy protected CD's etc.
    DRM is to prevent users making copies of protected audio.
    As your version of WMP lacks the component to discern
    what is and what isn't copy protected, it won't play anything!
    Hopefully all you require is a license upgrade.
    Click this link:
    http://drmlicense.one.microsoft.com/Indivsite/en/indivit.asp

    You'll be taken to the MS WMP security component upgrade site,
    assuming you use IE, at top will be a security alert that the
    website wants to run an add-on "DRM ActiveX network Object"
    Click to allow it to run.
    Once that is installed, you will see on the site that greyed out
    "Upgrade" button is now operational, click it and WMP will be
    upgraded and all your CD's will be playable.
     
    Panzy, Aug 9, 2009
    #2
    1. Advertisements

  3. Andrew

    Panzy Guest

    Of course what I should have said and clarified, is "recording/ripping"
    Some recordings have DRM, your WMP version maybe missing a
    security component, so it is unable to discern what is copy-protected
    with DRM, then it defaults to assuming all are DRM protected and won't
    rip. With the upgrade it will now rip from all non-protected discs.
     
    Panzy, Aug 9, 2009
    #3
  4. Andrew

    zachd [MSFT] Guest

    What file type are you trying to right click on?

    When you click Web Help on the error dialog, what *URL* does it take you to?
     
    zachd [MSFT], Aug 10, 2009
    #4
  5. Andrew

    Andrew Guest

    I tried upgrading DRM and that didn't help. Do you know any way to manually
    upgrade.

    Clarification of what I am doing:
    When I open Media Player and try to rip a CD, it goes to 20% then the Rip
    Status column says error, but there is no media player error. When I right
    click on a track and select properties that is where it says 'This file is
    missing media usage rights'.
     
    Andrew, Aug 19, 2009
    #5
  6. Andrew

    zachd [MSFT] Guest

    What format are you ripping to?

    It is doubtful that your rip error is caused by 'media usage rights'. That
    should just be the player telling you that the file doesn't have any media
    usage rights information found within the file.
     
    zachd [MSFT], Aug 20, 2009
    #6
  7. Andrew

    Andrew Guest

    Doesn't matter, I've tried multiple formats.

     
    Andrew, Aug 22, 2009
    #7
  8. Andrew

    zachd [MSFT] Guest

    Where are you right clicking on the Tracks and selecting Properties?

    Are you getting red Xs in the Rip columns?
     
    zachd [MSFT], Aug 24, 2009
    #8
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.