Trouble accessing my hosted web site

Discussion in 'DNS Server' started by rbrock, Dec 12, 2003.

  1. rbrock

    rbrock Guest

    my windows 2003 domain is called rickbrock.com. I host my own website
    (www.rickbrock.com) on my domain called rickbrock.com.

    The problem I am having is I can't accessing www.rickbrock.com. I get a
    "page not found" on my IE browser

    Please help me. Thank you



    Rick Brock
     
    rbrock, Dec 12, 2003
    #1
    1. Advertisements

  2. In
    I assume you are also hosting DNS and you have a private IP range?

    If so, you would need two DNS servers. One for public records that the
    outside folks get to, one for your internal users with private IPs.

    If not, then create a www record manually and give it the internal private
    IP of your server.


    --
    Regards,
    Ace

    Please direct all replies to the newsgroup so all can benefit.
    This posting is provided "AS IS" with no warranties.

    Ace Fekay, MCSE 2000, MCSE+I, MCSA, MCT, MVP
    Microsoft Windows MVP - Active Directory
     
    Ace Fekay [MVP], Dec 12, 2003
    #2
    1. Advertisements

  3. In
    Nslookup shows that www.rickbrock.com resolves to IP 66.218.85.169 but when
    I open your web site it is redirected to rickbrock.dnsalias.com. I take it
    that you have a dynamic IP and dnsalias is redirecting www.rickbrock.com to
    your external Dynamic IP?

    That is cool and it will work for everybody else out here on the internet.
    But for you to access your site by www.rickbrock.com in your internal DNS
    server, in the forward lookup zone for rickbrock.com create a host named www
    and give it the *internal* IP address of your web server.
    After you do this run ipconfig /flushdns then you should be able to access
    by www.rickbrock .com.
    I also noted that you can open your website by your IP address, this is a
    definite bad situation. There are worms out there looking for websites that
    can be opened from an IP address, Code Red was one of these. I recommend you
    give your default web site a host header for "www.rickbrock.com" and
    "rickbrock.dnsalias.com" both without the quotes and you *will* need both
    host headers, remove any website without a host header.


    --
    Best regards,
    Kevin D4 Dad Goodknecht Sr. [MVP]
    Hope This Helps
    ============================
    When responding to posts, please "Reply to Group" via your
    newsreader so that others may learn and benefit from your issue.
    To respond directly to me remove the nospam. from my email.
    ==========================================
    --
    http://www.lonestaramerica.com/
    ==========================================
    Use Outlook Express?... Get OE_Quotefix:
    It will strip signature out and more
    http://home.in.tum.de/~jain/software/oe-quotefix/
    ==========================================
    Keep a back up of your OE settings and folders with
    OEBackup:
    http://www.oehelp.com/OEBackup/Default.aspx
    ==========================================
     
    Kevin D. Goodknecht [MVP], Dec 12, 2003
    #3
  4. rbrock

    rbrock Guest

    Thank you very much for your help

    I created a host and named it "www" and gave it my internal IP and
    everything work perfect.

    However, I could not understand the second part of you answer. You
    suggested I give my default web site a host header for www.rickbrock.com and
    rickbrock.alias.com. Do I do that through the DNS console or do I do that
    through IIS?

    Thank you for your help. It is very much appreciated
     
    rbrock, Dec 13, 2003
    #4
  5. In
    That is done in IIS. Choose web site properties, on the Web Site Tab, click
    the Advanced button, all web sites listed in the top pane should have a host
    header. To Add a host header click Add, put in the IP address port 80 and
    the host header.
    The host header is what enables you to have more than one web site on the
    same IP address and port.


    --
    Best regards,
    Kevin D4 Dad Goodknecht Sr. [MVP]
    Hope This Helps
    ============================
    When responding to posts, please "Reply to Group" via your
    newsreader so that others may learn and benefit from your issue.
    To respond directly to me remove the nospam. from my email.
    ==========================================
    --
    http://www.lonestaramerica.com/
    ==========================================
    Use Outlook Express?... Get OE_Quotefix:
    It will strip signature out and more
    http://home.in.tum.de/~jain/software/oe-quotefix/
    ==========================================
    Keep a back up of your OE settings and folders with
    OEBackup:
    http://www.oehelp.com/OEBackup/Default.aspx
    ==========================================
     
    Kevin D. Goodknecht [MVP], Dec 13, 2003
    #5
  6. rbrock

    rbrock Guest

    OK, *almost* have everything working.

    I created a host named www in my forward lookup zone. Now i'm able to
    access my website

    I gave my default web site a host header. Now worms can't open my web site
    by my IP address

    But now I *can't* open my email on one of my client machines. My email
    settings were pop.rickbrock.com and smtp.rickbrock.com. I do not host my
    email. It is hosted on another server
     
    rbrock, Dec 15, 2003
    #6
  7. In

    Just as you created the www record, also create those two records (smtp and
    pop) under your internal rickbrock.com zone and give them both the IP
    address 66.218.85.170. They are the same addres since they point to the same
    server when I pinged both of them.


    --
    Regards,
    Ace

    Please direct all replies to the newsgroup so all can benefit.
    This posting is provided "AS IS" with no warranties.

    Ace Fekay, MCSE 2000, MCSE+I, MCSA, MCT, MVP
    Microsoft Windows MVP - Active Directory
     
    Ace Fekay [MVP], Dec 15, 2003
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.