Trouble installing WIN XP SP3

Discussion in 'Windows Update' started by Dick105, May 12, 2008.

  1. Dick105

    Dick105 Guest

    Hello

    I have two desktop computers and one laptop, all running Windows XP. I
    successfully downloaded and installed WIN XP SP3 on one desktop and the
    laptop. I’m having trouble with the other desktop.

    SP3 seems to download with no problems, but does not install properly.
    Before beginning the installation, I close all programs, including the
    screensaver. The installation begins normally, proceeding through the
    following steps: Inspecting – Creating Third Party Driver List – Performing
    inventory – Checking product key – Running processes before install. It
    stays on this last task for nearly three minutes, and then, without warning
    or notice, the computer reboots; thereby aborting the installation.

    I’ve tried it at least half a dozen times, with the same result.

    Any advice would be most appreciated.

    Cheers,
     
    Dick105, May 12, 2008
    #1
    1. Advertisements

  2. Does the desktop have an AMD processor ?
    Did you read this prior to the installation attempt ? -

    Steps to take before you install Windows XP Service Pack 3
    http://support.microsoft.com/kb/950717/

    Since the system is hanging on ' Running processes before install ' then
    'some' process is causing this issue. Could be a myriad of causes.

    If you check the spupdsvc.log located in WINDOWS it *should* provide a
    clue as to which process is causing this.


    MowGreen [MVP 2003-2008]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], May 12, 2008
    #2
    1. Advertisements

  3. Dick105

    Jahala Guest

    I have the same failure of installation and this what my log says:
    9.547: [ProcessPostBootInf] Deleted C:\WINDOWS\system32\spupdsvc.inf at the
    end of ProcessPostBootInf
    29.563: [SpUpdDeleteService] DeleteService Failed: Error:1072
    29.563: [SpUpdServiceStart] SpUpdDeleteService returned 1072
    29.563: [SpUpdServiceStart] Deleted Service, job done. Returning the Main
    Thread
    29.563: [SpUpdServiceStart] setting service to stopped
    Other than that, I have all the "right" requirements [and Intel, not AMD],
    so why is it doing this? FWIW, I do have a dual boot system, although that
    should not make a difference.
     
    Jahala, May 12, 2008
    #3

  4. The SpUpd service was deleted and that 'stopped' it. Check the
    svcpack.log, also located in WINDOWS, for further clues as to where the
    installation failure lies.

    Did you read this prior to the installation attempt ?

    Steps to take before you install Windows XP Service Pack 3
    http://support.microsoft.com/kb/950717/


    MowGreen [MVP 2003-2008]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], May 12, 2008
    #4
  5. Dick105

    Jahala Guest

    Yes, I read the page noted and it should have installed okay. However, it
    seems that Net framework v1 may be the culprit.'
    This is what I found in my svcpack.log:
    866.532: Starting process:
    C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\ToGac.exe
    C:\WINDOWS\Microsoft.NET\Framework\v1.0.3705\Microsoft.Vsa.Vb.CodeDOMProcessor.dll
    866.579: Return Code = 2
    866.579: ExConditionalRunInfProcesses: Error 0x2 while running processes in
    section 'ToGac.RunProcess.ProcessesToRun.'
    866.579: DoInstallation: ExConditionalRunInfProcess failed while during
    EXECUTE_AFTERINSTALL.
    866.579: Service Pack 3 Setup encountered an error: An error in updating
    your system has occurred.
    873.688: Unregistration of sprecovr successful
    873.750: An error in updating your system has occurred.

    Select 'OK' to undo the changes that have been made.
    882.329: Message displayed to the user: An error in updating your system has
    occurred.

    Select 'OK' to undo the changes that have been made.
    882.329: User Input: OK
    882.329: Starting process:
    C:\WINDOWS\$NtServicePackUninstall$\spuninst\spuninst.exe /~ -u -z
    1762.110: Software Update Rollback has completed with return code 0xbc2.
    This rollback requires a reboot.
    1762.188: Service Pack 3 installation did not complete.

    It looks like I will have to skip SP3. :::sigh:::
     
    Jahala, May 13, 2008
    #5
  6. Dick105

    Dick105 Guest

    --
    Hello MowGreen

    Thanks for the tips. The desktop in question does have an AMD processor,
    but so does the other one, and I had no problems at all with that one. I had
    not read the Microsoft pre-installation instructions, but will do so. As of
    now, I used GoBack to restore the machine to the pre-download state. As far
    as I can see, no damage was done to the machine, but I will proceed very
    carefully from here in deciding wheather or not to give SP3 another try.

    Thanks again!

    Cheers, Dickie
     
    Dick105, May 13, 2008
    #6
  7. AMD processors will only have the issue IF an OS image was applied that
    was done on an Intel processor. Installing images of an OS is a common
    practice with OEMs [Dell, Gateway, Acer, HP, etc]
    However, HP did not follow MS guidelines as it appears that they
    installed OS images created on Intel processors onto AMD systems.
    No issues appeared until SP3 was installed.

    cf: Unsupported Sysprep scenarios
    http://support.microsoft.com/kb/828287/

    MowGreen [MVP 2003-2008]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], May 13, 2008
    #7
  8. Hang in there, we're not going to throw in the towel just yet <w>

    Please run the .NET Framework setup verification tool
    http://blogs.msdn.com/astebner/archive/2008/03/03/8015158.aspx

    Use this link to obtain the previous Version of it since we're dealing
    with .NET 1.1: http://astebner.sts.winisp.net/Tools/netfx_setupverifier.zip

    Besides Microsoft .NET Framework 1.1, what updates for it and/or other
    ..NET Frameworks are listed in Add/Remove Programs in the Control Panel ?

    MowGreen [MVP 2003-2008]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============

     
    MowGreen [MVP], May 13, 2008
    #8
  9. Dick105

    Dick105 Guest

    --
    Hai MowGreen

    The machine that had no trouble loading SP3, I built myself, so no images.
    The other one (with the install problem) was built by a friend of mine who
    builts lots of them. He may well have used an image to load the OS. I'll
    ask him.

    Is there anything to be done, other than to start from scratch, and reload
    Windows XP?

    Thanks for you help.

    Cheers, Dickie
     
    Dick105, May 13, 2008
    #9
  10. Dick105

    Dick105 Guest

    --
    Checked with my friend. He says he did not load the OS from and image, but
    directly from the Microsoft CD. So much fo that. Will continue to tinker
    about with it, and see what can be done. Will let you know if I get it
    sorted.

    Thanks again for your efforts.

    Cheers, Dickie
     
    Dick105, May 14, 2008
    #10
  11. Check the spupdsvc.log and svcpack.log located in WINDOWS for a possible
    clue as to why SP3 failed to install.
    The first log will show the registration of files and the Process
    associated with it. It sounds like the problematic system is not
    reaching that point in the installation process, but it might still be
    worth going over.

    MowGreen [MVP 2003-2008]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], May 14, 2008
    #11
  12. Dick105

    Dick105 Guest

    --
    Hi MowGreen!

    Just to let know know: I fiddled around, and finally got the problem
    solved. It appears that, even though I had closed the program before
    attempting the istallation, some element or other of SpySweeper was still
    running in the background, and I could not figure out how to stop it. I
    removed the whole SpySweeper program, and rebooted. I next set the screen
    saver to None, and closed all programs. When I attempted to download and
    install SP3, everything worked just fine. As of now, SP3 is installed on all
    three of my machines, and all’s well.

    Thanks again for you interest and your help.

    Dickie
     
    Dick105, May 15, 2008
    #12
  13. Nice work ! You're mowst welcome, Dickie . Glad to hear that you finally
    got SP3 installed.
    I'd bet that Spywsweeper had an associated Service that was running that
    you were unaware of.


    MowGreen [MVP 2003-2008]
    ===============
    *-343-* FDNY
    Never Forgotten
    ===============
     
    MowGreen [MVP], May 17, 2008
    #13
  14. Dick105

    ANONYMOUS Guest

    If you want trouble free installation of SP3, then I suggest download the
    full-file version of SP3
    <http://www.microsoft.com/downloads/...a8-5e76-401f-be08-1e1555d4f3d4&displaylang=en>,
    then go off-line (i.e. unplug the cable from
    modem/lan), reboot the system in SAFE MODE, Install the SP3 (the file
    you just downloaded), reboot the system
    normally, problem solved!!

    To go into SAFE MODE, you need to press F8 key when booting so that black
    screen with DOS-Like characters appear where you can use arrow keys to go to
    the first item SAFE MODE.

    hth
     
    ANONYMOUS, May 18, 2008
    #14
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.