Trying to copy files to WD My Book 500gb: 0x8007045d I/O Error

Discussion in 'Windows Vista Hardware' started by Søren Andersen, Jul 28, 2007.

  1. After first converting my My Book from FAT32 to NTFS, I started copying files
    to it, which was fine for about 120gb.

    Then, suddenly, I get these I/O errors.

    I've tried EVERYTHING. I didn't have System Restore on, so I couldn't remove
    it, and put it on again. But, just to be safe, I turned it on, made a
    restorepoint, and turned it off again...

    I've tried deleting INFCACHE.1 in windows\inf.

    Nothing worked.

    Then I hooked it up to my Windows XP machine, and it works great.

    So, now I have an external harddrive - which, on the box, says "Works with
    Windows Vista" - that works on Windows XP, but not Vista...

    Seriously.

    Someone - please, help me!

    Regards,

    Søren
     
    Søren Andersen, Jul 28, 2007
    #1
    1. Advertisements

  2. Søren Andersen

    freddy Guest

    freddy, Jul 29, 2007
    #2
    1. Advertisements

  3. Freddy,

    Unfortunately, it seemed not to work. Thought I managed to copy 1 700mb file
    to the drive after using the update, further copying after that was
    unsuccessful. (Trying from 3 different harddrives, one of them external, to
    make sure it wasn't from my source-drives I had the problem)

    Is it possible each file corrupts something?
    It seems strange, at any rate...

    Anyway, thanks for the tip - unfortunately, no dice. :(

    Regards,

    Søren
     
    Søren Andersen, Jul 29, 2007
    #3
  4. Søren Andersen

    freddy Guest

    Soren,

    Try reformatting My Book to NTFS using Disk Management in Vista. Post back
    on results.
     
    freddy, Jul 29, 2007
    #4
  5. Hi,

    I'll try.

    I doubt it'll help, though - I've alredy done 2 full disk scans.
    One with WD's own software that took 9 hours, and one with Windows' own that
    took 3-4 hours.

    I'll post back in a few hours once I've moved the stuff off, and remformatted.

    Regards,

    Søren
     
    Søren Andersen, Jul 29, 2007
    #5
  6. I formatted my harddrive (not quick-format - a real one) and it didn't help.
    In fact, the error comes at almost exactly the same time as before...

    Regards,

    Søren G. Andersen
     
    Søren Andersen, Jul 29, 2007
    #6
  7. Søren Andersen

    Michael Guest

    Soren, (sorry, don't know how to get my machine to do your name correctly).

    Have you turned off ReadyBoast (should not have been turned on but never
    know)
    Have you turned off write caching (optimize for quick removal in policies of
    the drives properties).
    Have you done a full test/repair of the hard disk (properties tools
    errorchecking).
    Security settings check, owner should be SYSTEM. SYSTEM and administrators
    should have full control.

    There are reported problems resulting in this error due to SATA BIOS that
    need to be updated, suppose that your BIOS could have some similar problem
    in its USB operations (I don't recall you saying the drive is connected via
    USB, my assumption).
    USB drivers (not BIOS stuff) may also need to be updated from your
    manufacturer.

    I believe that formating leaves the partion table stuff alone, you might
    consider deleting the partion, repartioning and then formating.

    All long shots - but you don't seem to be getting anywhere anyway so I drop
    in my 2 cents.

    Michael
     
    Michael, Jul 30, 2007
    #7
  8. Søren Andersen

    freddy Guest

    Soren,

    OK, bummer. Did the My Book work properly when it was formatted FAT 32? If
    it did, go back to FAT 32.
     
    freddy, Jul 30, 2007
    #8
  9. Hello Michael,

    Tank you for your ideas!
    Don't worry about the name - blame my parent for choosing a crazy Danish
    name. :)

    I've finally - I think - managed to get everything working. Why, I have no
    idea.
    Because there had been so much talk about the System Restore partitions, I
    decided to give that approach another go. But this time, after I created
    restore-points on all my harddrives, I didn't remove them again.

    And now it seems to work.

    Again - I have no idea why. I'll be testing the drive again tomorrow, and if
    I hit any problems, I'll be coming back here for help again. Now you're
    warned. :)

    Regards,

    Søren
     
    Søren Andersen, Jul 30, 2007
    #9
  10. Søren Andersen

    Michael Guest

    Soren

    For what its worth,
    For my 150GB external usb drive,
    the check box for 'automatic restore points' is not set
    (system properties / system protection)

    Michael
     
    Michael, Jul 30, 2007
    #10
  11. Michael,

    As I wrote on my first post, neither did I.

    Regards,

    Søren
     
    Søren Andersen, Jul 30, 2007
    #11
  12. Freddy,

    I don't know if it worked better as FAT32 - I converted it as soon as I got
    it.
    Also, who uses FAT32 now a days?!? Nah, if it doesn't work with NTFS, then I
    want my money back.

    Also, the problem is back now, and I can't seem to get past it, even with
    the trick I used last time. I'm seriously considering just getting my money
    back, becuase this is insane. It's a bleeding USB harddrive - it should just
    bloody work.

    Regards,

    Søren
     
    Søren Andersen, Jul 30, 2007
    #12
  13. Søren Andersen

    freddy Guest

    Soren,

    Yes, I agree with you. It should work. It's hard to know whether it's a
    Vista or a hard drive problem. If it works in WinXP, then that fact make one
    believer the problem is with Vista. I'm at a loss to know what the problem
    is.
     
    freddy, Jul 30, 2007
    #13
  14. Freddy,

    I'm at a loss as well. I'd contact microsoft directly, except I don't want
    to spend the 80$ support-fee. (It's an estimate on the dollar-amount - I'm
    Danish, so the fee is in DKK)
    Also, my version was free as I'm a computer science student, so I doubt I
    can threaten that I want my money back. :)

    Regards,

    Søren
     
    Søren Andersen, Jul 30, 2007
    #14
  15. Søren Andersen

    Michael Guest

    Soren,

    Another long shot, maybe it is the drive after all. Have you tried leaving
    it off for a long time (to let it cool) and then seeing if it works for a
    while?
    Some cases for external drives don't have very good cooling so the drive
    gets pretty warm. I don't have your model of drive so cannot comment
    directly.
    (I went round and round with an XP system that had a marginal drive, every
    once in a while it would write to the wrong place on the disk, was very
    frustrating because I would make system changes and think I had it then boom
    some other weird manifestation would crop up.)
    A marginal drive might work in one OS and not in another because of timing,
    supposedly Vista is better at queuing up disk commands to reduce the delays
    in accessing the drive.

    Best of luck,
    Michael
     
    Michael, Jul 30, 2007
    #15
  16. Michael,

    Yeah, I've tried that. Mainly just leaving it off for the night, and then
    trying again in the morning. Unfortunately, that didn't help either. :(

    I'm currently trying to update everything to see if that helps - everything
    from the BIOS to the USB stack.

    Regards,

    Søren
     
    Søren Andersen, Jul 30, 2007
    #16
  17. Michael,

    Only indirectly.
    I mean - I leave it for 8 hours while I sleep, and it still doesn't work in
    the morning. :-(

    Regards,

    Søren
     
    Søren Andersen, Jul 30, 2007
    #17
  18. You guys will get a kick out of this...

    I decided to try something strange. First I tried copying files to the drive
    - no dice.
    I then let it sit in my Desktop. Didn't move.

    I shared a folder on the drive (write access) and one on one of my other
    Desktop harddrives (read).
    Using my Win XP laptop I then copied from the other harddrive, THROUGH my
    laptop (via a wireless connection...) to the external harddrive.
    And this insane approach works.
    But I cannot transfer directly.

    Whether this will bring us closer to a solution I do not know, but I at
    least had to share my utter disbelief...

    Regards,

    Søren Andersen
     
    Søren Andersen, Jul 31, 2007
    #18
  19. I have a group of virtual 2007 PC's built, and I snagged three of these drives for myself and two of my co-workers.

    We are all on Vista Enterprise, and all three of these drives are getting:

    Error 0x8007045D: The request could not be performed because of an I/O device error.

    I have put as much as 120 GB on a drive before hitting the error. Once I hit the error though, I find that I cannot get the file to copy over, even after restarting the system.

    I have tested all three drives on four Vista boxes and two XP installs. They work fine on XP, and all have failures on Vista.

    The failures are such that they are completely UNUSABLE with Vista. And yes, I have reformated two of the three drives... and I have to have NTFS since the VHD files exceed the 4GB max of FAT.

    EggHeadCafe - .NET Developer Portal of Choice
    http://www.eggheadcafe.com
     
    Michael Moynihan, Sep 28, 2007
    #19
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.