trying to solve update error 80070490

Discussion in 'Windows Update' started by John, Jan 7, 2009.

  1. John

    John Guest

    Still trying to solve my update problemon with Vista ultimate. IE7
    I ran the sytem update readiness tool.
    It came up in the CBS log file with this mum? missing.
    Am I on to something and can someone help me?
    I downloaded the windowsupdateagent30 and tried to installl it.
    It came up that it could not install Error: 80070490 (you guessed it)
    Checking packages.
    (f) CBS MUM
    Missing 0x00000002 servicing\packages\WUClient-SelfUpdate-Core-AdmComp~31bf3856ad364e35~x86~nl-NL~7.0.6000.381.mum
     
    John, Jan 7, 2009
    #1
    1. Advertisements

  2. Please state your full Windows version (e.g., Vista SP1; Vista SP2 Beta)
    when posting to this newsgroup.
     
    PA Bear [MS MVP], Jan 8, 2009
    #2
    1. Advertisements

  3. John

    John Guest

    OS Vista ultimate SP1
    Windows update stopped a few weeks ago and comes up with Code 80070490.
    There are no updates that failed, windows update states that it can no
    longer get any updates. In trying to solve the error I noticed that the list
    in "Enable or Disable Windows Components" is also empty now.
    John
     
    John, Jan 9, 2009
    #3
  4. To whom are you replying, yourself?

    Chances are that you're seeing the affects of a hijackware infection.

    1. See if you can download/run the MSRT manually:
    http://www.microsoft.com/security/malwareremove/default.mspx

    2. Run this online scan (in safe mode w/networking, if need be):
    http://onecare.live.com/site/en-us/center/howsafe.htm

    3. Run additional checks for hijackware, including posting your hijackthis
    log to an appropriate forum.

    Checking for/Help with Hijackware
    http://aumha.org/a/parasite.htm
    http://aumha.org/a/quickfix.htm
    http://aumha.net/viewtopic.php?t=5878
    http://mvps.org/winhelp2002/unwanted.htm
    http://inetexplorer.mvps.org/data/prevention.htm
    http://inetexplorer.mvps.org/tshoot.html
    http://www.mvps.org/sramesh2k/Malware_Defence.htm
    http://defendingyourmachine2.blogspot.com/
    http://www.elephantboycomputers.com/page2.html#Removing_Malware

    When all else fails, HijackThis v2.0.2
    (http://aumha.org/downloads/hijackthis.exe) is the preferred tool to use (in
    conjuction with some other utilities). HijackThis will NOT fix anything on
    its own, but it will help you to both identify and remove any
    hijackware/spyware with assistance from an expert. **Post your log to
    http://spywarehammer.com/simplemachinesforum/index.php?board=10.0,
    http://forums.spybot.info/forumdisplay.php?f=22,
    http://aumha.net/viewforum.php?f=30, or another appropriate forum for review
    by an expert in such matters, not here.**

    If the procedures look too complex - and there is no shame in admitting this
    isn't your cup of tea - take the machine to a local, reputable and
    independent (i.e., not BigBoxStoreUSA) computer repair shop.
    =====================
    Start a free Windows Update support incident request:
    https://support.microsoft.com/oas/default.aspx?gprid=6527

    Support for Windows Update:
    http://support.microsoft.com/gp/wusupport

    For home users, no-charge support is available by calling 1-866-PCSAFETY in
    the United States and in Canada or by contacting your local Microsoft
    subsidiary. There is no-charge for support calls that are associated with
    security updates.
     
    PA Bear [MS MVP], Jan 10, 2009
    #4
  5. John

    John Guest

    Dear PA Bear,
    I followed your links and performed 3 different scans.
    They all came up good and could not find any hijacking or viruses.
    I did make an incident request at MIcrosoft, but after trying several things
    that are already posted in other threads, the only solution would be to
    reinstall. An inplace upgrade is not possible due to my original DVD which is
    before SP1. I cannot uninstall SP1 as it is not in the installed update list.
    A new installation would take me a day.
    John
     
    John, Jan 11, 2009
    #5
  6. John

    Lynn Guest

    I am also encountering the error. Have Vista as well. Been following all
    the directions on these Dec & Jan threads to no avail.

    HELP
     
    Lynn, Jan 11, 2009
    #6

  7. It may help if you explain in detail what you did.
    (E.g. machine characteristics and URL used.)

    <title>How to obtain the latest version of the Windows Update Agent to help manage updates on a computer</title>
    http://support.microsoft.com/kb/949104

    (Live Search of Microsoft Support for
    windowsupdateagent30 vista
    )



    So, you need a non-English version?
    Perhaps you should do the equivalent Live Search
    from a browser with Language Preferences set to
    Dutch (Netherlands) [nl-NL].


    Good luck

    Robert Aldwinckle
    ---
     
    Robert Aldwinckle, Jan 11, 2009
    #7
  8. Repost:
     
    PA Bear [MS MVP], Jan 11, 2009
    #8
  9. John

    John Guest

    Robert thank you for responding,
    I downloaded the update agent from Microsoft here
    http://download.windowsupdate.com/w...one/7.2.6001.788/windowsupdateagent30-x86.exe
    Which should be the latest version.
    I ran the program, it starts copying files and installation. Installation
    stops and it comes up with "installation has failed error 0x80070490"


     
    John, Jan 12, 2009
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.