Turn off forms-based authentication - get "page not found"

Discussion in 'Windows Small Business Server' started by Doug Adkins, Feb 27, 2005.

  1. Doug Adkins

    Doug Adkins Guest

    Hey All,

    When I turn off forms-based authentication for OWA and then run IISRESET, I
    get "page not found" after authenticating.

    When I turn forms-based authentication back on and then run IISRESET, it
    works perfectly after authenticating via the owslogon.asp (including
    redirects to my originaly requested URL...like direct to my
    calendar....https://server.domain.ext/exchange/username/calendar).

    Any ideas? I really nee to be able to resolve the mailbox url, without
    using owalogon.asp, in order for my PDA's to work with ActiveSync via HTTP
    proxy.

    Thanks,
    -Doug
     
    Doug Adkins, Feb 27, 2005
    #1
    1. Advertisements

  2. Doug Adkins

    Jerry zhao Guest

    Hi Doug,

    Thanks for your posting!

    First of all, please check if your issue is the same scenario in the
    following KB:

    Troubleshooting Outlook Web Access logon failures in Exchange 2000 and in
    Exchange 2003
    http://support.microsoft.com/?id=327843

    If this is not your case, please perform the following steps:
    1. Re-run CEICW, set correct certificate for the IIS.

    2. Check the certificate that you used for the OWA virtual site.

    3. Check if you still can work with outlook well when OWA stops work.

    4. Install hoxfix 831464. For more information:
    FIX: IIS 6.0 compression corruption causes access violations
    http://support.microsoft.com/kb/831464

    5. Clear IIS cache. To do so:
    ==== At the server side ====

    a. Go to your "%SystemRoot%\IIS Temporary Compressed Files" (C:\WINDOWS\IIS
    Temporary Compressed Files or C:\WINNT\IIS Temporary Compressed Files)
    directory.

    b. Select all of the content in this directory and delete it.

    c. Click Start->Run, type "iisreset" (without the quotes) and click OK to
    restart the IIS services.

    ==== At the client side ====

    a. Open IE, and go to Tools -> Internet Options.

    b. Select Delete Files, check "Delete all offline files" and click OK to
    confirm that you want to delete the content. Then check if the issue
    disappears.


    If the issue still occurs, please help me collect the following information:

    1. What the exact error code and error message?

    2. Can you successfully access the OWA on the server as the administrator
    account?

    3. What the exact web page URL for which you get "page not found" after
    authenticating.

    4. Are there any event logs related to this issue?

    5. Can you open companyweb externally?

    6. Disable SSL, and then visit the OWA again to test. What is the result?

    If you have any concern on this thread, I am glad to be of further
    assistance. We look forward to hearing from you.

    Best regards,

    Jerry Zhao (MSFT)

    Microsoft Online Partner Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Jerry zhao, Feb 28, 2005
    #2
    1. Advertisements

  3. Doug Adkins

    Doug Adkins Guest

    Jerry,

    Thanks for the reply. At this point, I can live with OWA needing that
    owalogin.asp to properly authenticate and route OWA requests...because it
    works. Even so, I went through all your suggested steps, thinking that it
    would help with getting my PDA's and ActiveSync to work again (via Internet
    HTTP proxy)...they used to work up until about 5 days ago, when I made "some
    sort of change" to IIS...I think. So...jumping to your end questions...here
    we go...

    1. HTPP_500 (see PDA verbose log below)
    2. Used Administrator via the PDA...still HTTP_500
    3. Certificate maps host.domain.ext to internalhost.domain correctly...not
    sure if IP Host headers are correct in IIS for Default Website.
    4. See log below
    5. Yes...companyweb by apending port 444 to the end of the url (e.g.
    https://externalhost.domain.ext:444), and RWW by using this URL
    https://externalhost.domain.ext/remote. Just using
    https://externalhost.domain.ext or appending anyother site to the end of the
    URL (e.g. https://externalhost.domain.ext/Exchange) results in owalogon.asp
    being displayed. RWW logon page is different.
    6. When I disable SSL, all works (albeith without the https...rather just
    http in the requested URL) except RWW and still the ActiveSync does not work.

    Here's the PDA log...thanks for the help Jerry :)
    -Doug

    *************************



    =-= Build 14132 =-=
    =-= No XIP Information Available =-=
    host.domain.net

    =-=- [28/2/2005 18:3:12.0] -=-=
    =-=-=-= Client Request =-=-=-=
    OPTIONS
    Microsoft-Server-ActiveSync?User=joeuser&DeviceId=E48206360000000108000050BF3F5173&DeviceType=PocketPC
    Accept-Language: en-us

    -=-=-=- Start of Body -=-=-=-


    =-=- [28/2/2005 18:3:28.0] -=-=
    =-=-=-= Server Response =-=-=-
    HTTP/1.1 200 OK
    Connection: close
    Date: Mon, 28 Feb 2005 18:10:58 GMT
    Server: Microsoft-IIS/6.0
    MicrosoftOfficeWebServer: 5.0_Pub
    X-Powered-By: ASP.NET
    Pragma: no-cache
    Content-Length: 0
    Public: OPTIONS, POST
    Allow: OPTIONS, POST
    MS-Server-ActiveSync: 3.0.4215.0
    MS-ASProtocolVersions: 1.0,2.0,2.1
    MS-ASProtocolCommands:
    Sync,SendMail,SmartForward,SmartReply,GetAttachment,GetHierarchy,CreateCollection,DeleteCollection,MoveCollection,FolderSync,FolderCreate,FolderDelete,FolderUpdate,MoveItems,GetItemEstimate,MeetingResponse



    =-=- [28/2/2005 18:3:30.0] -=-=
    =-=-=-= Client Request =-=-=-=
    POST
    Microsoft-Server-ActiveSync?User=joeuser&DeviceId=E48206360000000108000050BF3F5173&DeviceType=PocketPC&Cmd=FolderSync
    Accept-Language: en-us
    MS-ASProtocolVersion: 2.0
    Content-Type: application/vnd.ms-sync.wbxml

    -=-=-=- Start of Body -=-=-=-
    <?xml version="1.0" encoding="utf-8"?><FolderSync
    xmlns="FolderHierarchy:"><SyncKey>0</SyncKey></FolderSync>

    =-=- [28/2/2005 18:3:33.0] -=-=
    =-=-=-= Server Response =-=-=-
    HTTP/1.1 500 Internal Server Error
    Connection: close
    Date: Mon, 28 Feb 2005 18:11:03 GMT
    Server: Microsoft-IIS/6.0
    MicrosoftOfficeWebServer: 5.0_Pub
    X-Powered-By: ASP.NET
    Pragma: no-cache
    Content-Type: text/html
    Content-Length: 56
    MS-Server-ActiveSync: 3.0.4215.0
     
    Doug Adkins, Feb 28, 2005
    #3
  4. Doug Adkins

    Jerry zhao Guest

    Hi Doug,

    Thanks for your update.

    Based on my research, I found that you issue is most like the scenario in
    the following KB:

    "HTTP 500 - Internal Server Error" Error Message When You Use Outlook Web
    Access to Connect to Your Microsoft Exchange Server 2003 Mailbox
    http://support.microsoft.com/default.aspx?scid=kb;en-us;829167

    Hope the above information helps.

    If there is anything else that I can do for you, please feel free to
    contact me, and I will be happy to help!

    Best regards,

    Jerry Zhao (MSFT)

    Microsoft Online Partner Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Jerry zhao, Mar 1, 2005
    #4
  5. Doug Adkins

    Doug Adkins Guest

    Jerry,

    Turns out that the metabase.xml file was corupted. Had to open a MS
    Trouble-ticket and pay the $245...but it was worth it. Tech was great, and
    never let up until repaired. Took about 24 hours.

    Thanks for the help,
    -Doug
     
    Doug Adkins, Mar 7, 2005
    #5
  6. Doug Adkins

    Jerry zhao Guest

    Hi Doug,

    Thanks for your kind response and I'm glad to hear that the problem was
    resolved.

    As always, please do post back here again if anything we can still be help.

    Best regards,

    Jerry Zhao (MSFT)

    Microsoft CSS Online Newsgroup Support

    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Jerry zhao, Mar 8, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.