Turn off screen blackening with User Account Control?

Discussion in 'Windows Vista Security' started by Gabrie, Jan 31, 2007.

  1. Gabrie

    Gabrie Guest

    Hi

    Running Vista Ultimate and have two displays attached (EIZO CRT). Each time
    User Account Control asks me if I realy want this or that (which I think is
    good), the screen gets that black overlay or transparancy. This switch makes
    my second display switch mode, which means a hard click sound, screen goes
    off and then on again. This is realy anoying, so I turned UAC off.

    Is there a way to change this behavior?

    Gabrie
     
    Gabrie, Jan 31, 2007
    #1
    1. Advertisements

  2. I doubt it. This isn't just an overlay. It's a whole different desktop,
    running as a different user, with a picture of your desktop in the
    background to make it a bit more seamless. The prompt doesn't happen under
    your credentials.
     
    Nathanial Woolls, Jan 31, 2007
    #2
    1. Advertisements

  3. Gabrie

    Robert Firth Guest

    No, it can be done. That is secure desktop you are seeing. All you have to
    do is disable secure desktop. However, be warned that this does present a
    security risk. UAC prompts must be answered by a human, no other process or
    script can hook in and answer for you because the prompt is opened in a
    whole new process.

    Ok, on to the answer:

    Type "secpol.msc" in the Start search box.
    Press "enter"
    Accept the elevation UAC dialog.

    Under "Security settings", open tree "Local policies"
    Click "Security Options"
    Scroll down to:
    "User Account Control: Switch to the secure desktop when prompting for
    elevation"

    Right click on it.
    Click "Properties" On the "Local Security Setting" tab:
    Select "enable"
    Click OK
    Close the "Local Security Policy" Application. You're done!

    --
    /* * * * * * * * * * * * * * * * * *
    * Robert Firth *
    * Windows Vista x86 RTM *
    * http://www.WinVistaInfo.org *
    * * * * * * * * * * * * * * * * * */
     
    Robert Firth, Jan 31, 2007
    #3
  4. Gabrie

    gabrie Guest

    Hi

    Thanks for the answer. Can you explain what the difference is between
    disabling UAC? Because what I did was just disabling UAC, but in a different
    way then you described below. So what is disabling Secure Desktop exactly?

    Gabrie
     
    gabrie, Feb 1, 2007
    #4
  5. Gabrie

    Jimmy Brush Guest

    Hello,

    Disabling UAC turns off all the benefits of UAC.

    Disabling the secure desktop transition keeps UAC enabled; however, the
    screen doesn't blacken.

    This does reduce security somewhat. The reason UAC blackens the screen and
    switches to the "Secure" desktop is to prevent evil programs from pretending
    to be you and clicking the Continue button automatically.

    By turning off the secure desktop, you run the risk of this happening.


    --
    - JB
    Microsoft MVP - Windows Shell/User

    Windows Vista Support Faq
    http://www.jimmah.com/vista/
     
    Jimmy Brush, Feb 1, 2007
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.