Turning off Auto Updates

Discussion in 'Windows Update' started by tsgm, May 1, 2007.

  1. tsgm

    tsgm Guest

    When I access the Automatic Updates window in System Properties, all the
    options are 'greyed' out and can't be chosen. I am logged on as the
    Administrator. Can anyone advise how I can turn off Auto Updates?
     
    tsgm, May 1, 2007
    #1
    1. Advertisements

  2. tsgm

    PA Bear Guest

    Is this your personal machine at home or one belonging to your employer &
    used at work?
     
    PA Bear, May 1, 2007
    #2
    1. Advertisements

  3. tsgm

    tsgm Guest

    This is my personal desktop computer at home running WinXP Home SP2 with
    latest updates.
     
    tsgm, May 1, 2007
    #3
  4. tsgm

    JulesKremer Guest

    If it's a left over from a policy, use gpedit.msc to locate it in computer configuration, windows components, windows update and set all options to not configured.

    If it was entered directly into the registry, create a backup of your registry (or of your complete computer (not a bad thing every now and then.... ;-) ), then locate these settings
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WindowsUpdate
    and / or
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate

    and delete all the keys and settings in there. This will reset it to out of the box settings, and regenerate the keys needing to be there. If no GPO is active, you'll have the option to set it by hand again.

    Jules


    tsgm wrote:

    This is my personal desktop computer at home running WinXP Home SP2 with latest updates.
     
    JulesKremer, May 1, 2007
    #4
  5. tsgm

    tsgm Guest

    Many thanks for your prompt reply, Jules.
    I don't have gpedit.msc; so I proceeded with modifying the registry as you
    suggested.
    I deleted all keys and values in Windows Update hives in the
    HKEY_CURRENT_USER\ . . . and HKEY_LOCAL_MACHINE\ . . . except for the first
    entry in each, which is: (Defaualt) Reg_SZ (value not set). I then rebooted.
    However, I still cannot access any options in the System/Automatic Updates
    -- they are still greyed out.
    Also, going into Regedit again, I find that the Windows Update entries in
    the HKEY_LOCAL_MACHINE are back again. Some other program must be
    controlling it.
     
    tsgm, May 1, 2007
    #5
  6. tsgm

    C_B_S Guest

    Hi,
    I was waiting today for someone else to post the 'greyed out' Automatic
    Updates issues. This is something that I also just noticed today and I had
    spent soem time on this to no avail before I went to this site to see if
    anyone else is reporting same concern. I did try all of the steps provided
    by JulesKrember (a couple times) but this did not change anything and
    restarting my PC didn't help. I should have left my PC to Notify me before
    download and install but around the DST (Daylight Savings Time) updates, we
    had so many office PCs to do that we decided to install the Microsoft Update
    and change everyone to Automatic Updates. Unfortunately, this in and of
    itself caused more issues in the guise of the "svchost.exe" which caused
    certain PCs in the office to perform badly and freeze. Turning off Automatic
    Updates in My Computer | Properties | Automatic Updates tab and changing to
    something other thatn Auto Updates turned out to be an easy and good fix for
    that issue. But, now that Automatic Updates is greyed out (on certain office
    systems), I can't turn it off.

    C_B_S 5/1/2007 3:52 pm
     
    C_B_S, May 1, 2007
    #6
  7. tsgm

    Cadwan Guest

    I know it sounds like something you would do to begin with, but did you try
    turning off the Automatic Update Service, using Manage (right click My
    Computer; Manage) and then Services?
     
    Cadwan, May 2, 2007
    #7
  8. tsgm

    PA Bear Guest

    Start > Settings > Control Panel > Security Center: What does Security
    Center report for the status of your anti-virus application and firewall?
    Can you enable Automatic Updates here?
     
    PA Bear, May 2, 2007
    #8
  9. tsgm

    C_B_S Guest

    Hi Cadwan,

    Yes I tried all of that earlier when I was reading various other suggestions
    on the site. I also did a restart after to verify what I saw next was not
    going to go away. With the Automatic Update Service anything other than
    Automatic, e.g., Disabled or Manual--within My Comptuer | Manage |
    Services...Auto Update box selections are all stilled greyed out under My
    Comptuer | Properies | Automatic Updates, and this is what I see when I
    subsequently go to the Windows Update site:

    Error Number: 0x8DDD0018
    this is the header message in bold text: site cannot continue because one
    or more of the windows services is not running...

    So, while Automatic Updates is Disabled within Services, I can't even open
    Windows Updates and hope to see the box on the right that allows the user to
    change their Auto Update selections.

    C_B_S 5/1/07 5:05 pm
     
    C_B_S, May 2, 2007
    #9
  10. tsgm

    C_B_S Guest

    Hi Pa Bear,
    No, unfortuantely it also greyed out as it is the same box just a different
    way to get there. I am sure it is the same for tsgm. I re-checked this just
    now but I also checked it earlier today. I agree with tsgm that something is
    controlling this and it is probably some easy fix that we just don't know
    about yet :)

    C_B_S 5/1/07 5:15 pm
     
    C_B_S, May 2, 2007
    #10
  11. tsgm

    PA Bear Guest

    ...What does Security
     
    PA Bear, May 2, 2007
    #11
  12. tsgm

    C_B_S Guest

    Security Center reports...
    Firewall is On. I tried turned it off earleir today and restarted and made
    several of the aforementioned changes but nothing changed the 'grayed-out
    selections' so I turned it back on. Anti-Virus does not show up in the
    Security Center. We are using CA eTrust licensed ver. 7.1.192. It
    successfuly updates - I just did it to be sure.

    C_B_S 5:40 pm
     
    C_B_S, May 2, 2007
    #12
  13. Start -> Run -> services.msc [Enter]
    Is the "Automatic Update" service running and set to start
    automatically in its properties there?

    Bye,
    Freudi
     
    Ottmar Freudenberger, May 2, 2007
    #13
  14. tsgm

    PA Bear Guest

    See Freudi's reply, too.

    If you open Security Center and click on "Change the way security center
    alerts me", check the Virus Protection box & OK, what does Security Center
    tell you about eTrust AV now?

    I have more but I need you to test the above (and respond to Freudi) before
    I post any of it.
     
    PA Bear, May 2, 2007
    #14
  15. tsgm

    JulesKremer Guest

    I'm a bit baffled. I read all the other posts for this subject. The only
    thing I can imagine is that there must be a active policy that maintains
    these settings. BTW; Both the registry settings I suggested should be
    done all at the same time.

    I'm not sure of the 'not so destructive' removal steps to remove a
    forced policy. I'll have to test it in a VMWare setting or google or
    technet it. But I don't have the time for it right now...

    Jules
     
    JulesKremer, May 2, 2007
    #15
  16. tsgm

    tsgm Guest

    Yes, Freudi, the Automatic Updates in the Services is set to: Started -
    Automatic - Local System.

    Also, as PA Bear requested, when I access the Security Center, the option to
    "Change the way Security Center alerts me" is greyed out and hence
    unselectable.

    --
    tsgm


     
    tsgm, May 2, 2007
    #16
  17. Hm, can you find the following key in the registry (the heart and brain
    of Windows, so handle with care)?
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate

    If so, please export the content (via "File") and insert it into your
    reply.

    Bye,
    Freudi
     
    Ottmar Freudenberger, May 2, 2007
    #17
  18. tsgm

    tsgm Guest

    Here is the requested info, Freudi.

    Key Name:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate
    Class Name: <NO CLASS>
    Last Write Time: 3/25/2007 - 2:56 PM

    Key Name:
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
    Class Name: <NO CLASS>
    Last Write Time: 3/25/2007 - 2:56 PM
    Value 0
    Name: NoAutoUpdate
    Type: REG_DWORD
    Data: 0x0

    Value 1
    Name: AUOptions
    Type: REG_DWORD
    Data: 0x4

    Value 2
    Name: ScheduledInstallDay
    Type: REG_DWORD
    Data: 0x0

    Value 3
    Name: ScheduledInstallTime
    Type: REG_DWORD
    Data: 0x11
     
    tsgm, May 2, 2007
    #18
  19. tsgm

    C_B_S Guest

    TO tsgm:
    RE: HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU

    I spoke to our outside IT consultant today regaridng your policy string
    below and he said that if your home PC is truly not controlled by any group
    policy put in place by anyone, e.g., you got the PC from your office or
    another source as a purchase or a gift, than you should be able to remove
    (delete) the AU in your Policies that pertains to Automatic Updates. Under
    Policies, only delete the WindowsUpdate folder and the AU folder under it.
    Only those 2 folders. Since there is a policy in place, than you must have
    XP Pro OS on that PC.

    Last night I was very suspicious about this dimmed out Automatic Updates on
    my PC and I started to believe that a GP was put in place unbeknown to me so
    I sent out an inquiry last night and got a reply back today that one was in
    place. The IT consultants had tried PatchLink and didn't like that so he
    next tried the Automatic Updates GP. He went ahead and removed the GP this
    AM and from my PC at Start | Run I did gpupdate /force after the server
    administrator removed the policy. Nothing is grayed out now and I wish you
    good luck with yours!

    C_B_S 5/2/07 9:50 am
     
    C_B_S, May 2, 2007
    #19
  20. tsgm

    tsgm Guest

    Many thanks, C_B_S!
    I deleted the Windows Update policy in HKEY_Loc_Machine as you suggested. I
    can now choose any option in the System Automatic Updates section.

    I had a computer crash in March and had to replace my motherboard and hard
    drive. The system upgrade was purchased from a large computer supply store
    and they initially set up the hard drive with WinXP Home. They probably
    connected my computer to their server to do the setup. The 'official'
    MicroSoft Windows XP CD I received was unopened.

    When I got the computer running at home, I proceeded to reinstall all my
    programs, and of course, WIndows automatically downloaded and installed all
    the latest security patches. That was when my 'fun' started -- especially
    with the Windows updates around April 3rd.

    Earlier (around April 9th), I posted another problem I have with accessing a
    second user account (sometimes it requires several attempts before it will
    connect - aborting each time back to the user selection screen). I received
    no response to this query. This problem did not show up until after the
    Windows updates were installed early April, so I felt it was due to an Update
    software glitch, and posted my question on this site. I thought I had solved
    it by returning to a privious audio driver configuration -- but the problem
    remains.

    Anyway, one problem has been solved. I wish to thank everyone for their
    valued input.
     
    tsgm, May 2, 2007
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.