UAC/Run as Administrator Issue

Discussion in 'Windows Vista Security' started by StMaas, Mar 31, 2007.

  1. StMaas

    StMaas Guest

    I have followed the help guidelines for two programs (my netgear wireless
    application & Logitech's updater application) by choosing to 'run as
    administrator' for each application, both for the shortcut in the start-up
    menu and for the actual .exe file indicated in the path statement provided
    when it is blocked on startup. Yet I'm still prompted, at every login, to
    allow each. It's getting pretty annoying - how do I really allow these
    applications to run automatically?
     
    StMaas, Mar 31, 2007
    #1
    1. Advertisements

  2. StMaas

    Guest Guest

    What do you mean blocked. That is Windows Defender terminolgy. So Run As is
    irrelevent to this issue. Look in Defender - Sofrware Explorer
     
    Guest, Mar 31, 2007
    #2
    1. Advertisements

  3. StMaas

    StMaas Guest

    What I mean is - I am prompted to allow the application to run every time I
    log in. My account has administrator rights. based on the support
    documentation I should be able to set it to run as administrator so I don't
    have to *allow* it every6 time I log on to the box.
     
    StMaas, Mar 31, 2007
    #3
  4. StMaas

    Guest Guest

    You have to make a shortcut to, and in the shortcut's properties look on the
    Compatability tab. I'm not sure what happens if you do it on the exe - it
    seems a different mechanism to previous versions of windows where this
    command is not a compat command. I run as an Admin so it is greyed out for
    me.
     
    Guest, Mar 31, 2007
    #4
  5. StMaas

    Rock Guest

    Any program that runs at startup that requires Admin privileges, which is
    the case if you have checked Run as Administrator, will give the prompt at
    start up. The computer has no way of knowing your intent, that you wanted
    this program to run with admin privileges this time, so it asks. One option
    is to remove the Run as Administrator requirement if the program doesn't
    need admin privileges. Another is not run those apps at startup. Why do
    you need the Logitech updater to run automatically on startup? See this
    link for more info:

    Error message when you reach the Windows Vista Desktop: "Windows has blocked
    some startup programs"
    http://support.microsoft.com/kb/930367/en-us

    One way around this is to run these programs as a scheduled task.
    http://blog.gerke-preussner.de/inde...cking-Elevated-Startup-Programs-in-Vista.html
     
    Rock, Apr 2, 2007
    #5
  6. StMaas

    Tulsaboyw Guest

    Uac IS useless if you cant automate some obviously correct stuff that
    will always get UAC run...


    The reality is that UAC seems to get in the way more than it really
    helps.

    I will be turning it off real soon, as it seems every body says get
    used to it and 'hit' continue.

    Which means everybootup I have dozens of apps to 'continue' ..so it
    either gets turned off, or bypassed..

    Im already running other stuff for security including NORTON & behind a
    double router setup (per my inhouse setup). so I figure IM ok.
     
    Tulsaboyw, Apr 27, 2009
    #6
  7. StMaas

    Tulsaboyw Guest

    Even when I run it as described above.. it still gets in the way.
     
    Tulsaboyw, Apr 27, 2009
    #7
  8. StMaas

    Gordon Guest

    Eh? Why are you getting UAC at boot up? Are you trying to run programs
    that are not Vista compatible?
    I get UAC maybe ONCE A WEEK......
     
    Gordon, Apr 27, 2009
    #8
  9. StMaas

    Tulsaboyw Guest

    I meant that Im getting the usual... 'need permission' to run...
    Though initially I only had a handful of apps (3), now its more than
    twice as many.

    Almost all of them are VISTA compatiable, though some were previously
    xp and got updated before I went vista.

    --

    VIsta Home Premimum - (Sp1, 64bit).
    Boinc (latest version) - Along with many apps that are part of VISTA
    that constantly ask permission, and will always be 'yes' no matter
    what..

    It seems stupid that many of the apps are asking permission when they
    themselves are part of the system and easily part of what would be
    automatically always yes and will never be 'not run'.

    The msg, is not really a error, its part of UAC's normal process.
    'A progra needs permission to continue'.

    Its ok that it does it... in that I often leave the pc running 24x7 but
    that may change soon... Ive not been a 'work from home' person till
    recently, and till now its not been a problem..

    Now that Im around more often, and actually end up doing a lot more its
    a bummer.

    Plus in the case of boinc, I have to litterally totally kill all boinc
    presense to run WMC in full tilt....not just minimize its running.

    I my just stop running boinc as a whole.

    Some of the other apps I can bypass UAC with some of the tricks noted
    in the past, but I dont want to do that on some.
     
    Tulsaboyw, Apr 27, 2009
    #9
  10. StMaas

    Gordon Guest

    I still don't understand. I NEVER get UAC to run any of the apps that I
    have installed. AT ALL.
    There must be something very odd going on on your machine, especially if
    (as you say) these apps are Vista compatible...
     
    Gordon, Apr 27, 2009
    #10
  11. StMaas

    Tulsaboyw Guest

    Note I also have 6gig of Ram... and 800gig of HD and a home network that
    has another 800gig .. (used to need that much, but nowadays.
     
    Tulsaboyw, Apr 27, 2009
    #11
  12. Welcome to userland. The Vista UAC mechanism was designed give you easy
    access to the admin token when needed. Even the protected admin account
    is affected. If you just can't stand working in userland, maybe this is
    for you.

    http://www.petri.co.il/add_administrators_account_to_vista_welcome_screen.htm

    Some people just can't be restriced to userland and have to be
    administrators, but most people are better off as users.
     
    FromTheRafters, Apr 27, 2009
    #12
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.