Ubuntu Display resolution > 800

Discussion in 'Virtual PC' started by gue22, Aug 24, 2009.

  1. gue22

    gue22 Guest

    Run latest Ubuntu 9.04 (fully patched) in latest VirtualPC. System /
    Preferences / Display control panel does not let me enter resolutions > 800 x
    600, though my monitor is 1920 x 1200.
    Tried several VPC setting variants including full screen of VM - to no avail.

    OpenSUSE is absolutely fine with all resolutions and the point is: It lets
    me choose monitor AND resolution in YaST2 / HArdware / Graphics Card and
    Monitor / Card and Monitor Properties.

    Shouldn´t be that hard in Ubuntu. ;-)

    Thanks for any help
    G.
     
    gue22, Aug 24, 2009
    #1
    1. Advertisements

  2. gue22

    Bo Berglund Guest

    Try Ubuntu 9.0.4 in VMWare Workstation 6.5.3 instead...
     
    Bo Berglund, Aug 24, 2009
    #2
    1. Advertisements

  3. gue22

    Bo Berglund Guest

    Bo Berglund, Aug 24, 2009
    #3
  4. gue22

    Bo Berglund Guest

    I actually installed 9.0.4 a week ago in my WS 6.5.2 and all seemed OK
    except for the tools installation. I could not get the mouse
    integration to work at all. Do you have mouse integration working?

    I asked my daughter (who works at VMWare) and she told me they were
    aware of it and would release a new maintenance update in just a few
    days to fix the Ubuntu issue. Took 2 days and then it was done....
     
    Bo Berglund, Aug 24, 2009
    #4
  5. gue22

    Bo Berglund Guest

    How did you do that?
    Did you upgrade a Ubuntu 8.x with mouse integration working to 9.0.4
    possibly?
     
    Bo Berglund, Aug 25, 2009
    #5
  6. gue22

    Bo Berglund Guest

    Bo Berglund, Aug 25, 2009
    #6
  7. gue22

    gue22 Guest

    Ok, guys, thanks for the feedback!
    Sorry to get back to you so late, but I had checked a box somewhere to get
    email notification of answers and I did not get anything.

    I would really have appreciated if there was a solution in MS Virtual PC,
    but it´s not that hot anymore anyway.

    I tried to install VMware twice (second Avast AV off) and my fully patched
    Vista Ultimate 64 would not get to the logon screen any more. Had to back out
    with a Restore Point.

    As I would have liked USB support anyway (which Virtual PC doesn´t have and
    why I tried VMware firstplace) I gave VirtualBox a shot. It installed ok, but
    it crashed on me already when I tried to set the default directory for the
    VMs.

    When it crashed again when I tried to set a CD/DVD drive for the VM I gave
    up. (I got a physical DVD and the latest Daemon Tools Lite DVD on this Vista
    64)

    Not that hot anymore, but it´d be nice to know how to tweak Ubuntu resolution.
    Thanks
    G.
     
    gue22, Aug 27, 2009
    #7
  8. I have this working just fine. What you need to do is to edit
    /etc/X11/xorg.conf file to look like this:

    Section "Device"
    Identifier "Configured Video Device"
    Driver "vesa"
    BusID "PCI:0:8:0"
    VideoRam 8192
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    Option "DPMS"
    HorizSync 30-70
    VertRefresh 50-160
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    DefaultDepth 16
    SubSection "Display"
    Depth 16
    Virtual 1280 1024
    Modes "1280x1024"
    EndSubSection
    EndSection

    If you want to use a different resolution - change the values in the
    "Virtual" and "Modes" lines. Doing this I have successfully gone up to
    1600x1200.

    Please note - I really encourage you to enable undo disks before messing
    with xorg.conf - as it can be really painful to recover from mistakes if
    you make them here. Annoyingly, once you make this change - you cannot
    use the Display widget under Ubuntu to change resolution (it will mess
    the system up completely).

    Cheers,
    Benjamin Armstrong
    ===========================
    Senior Program Manager Lead
    Windows Virtualization

    Blog: http://blogs.msdn.com/Virtual_PC_Guy
    Book: http://tinyurl.com/ysxcbm

    This posting is provided "AS IS" with no warranties, and confers no
    rights. You assume all risk for your use.
     
    Benjamin Armstrong [MSFT], Aug 27, 2009
    #8
  9. gue22

    gue22 Guest

    Thanx, Ben, you almost did it!

    But only almost, namely the login screen works with this res, but after that
    it switches back to the prior res totally distorted.

    I tried VideoRam 16384 for 1280 and left 8192 for 1024. Same.
    What´s the missing link? Horizontal or vertical freq values?
    Thx
    G.
     
    gue22, Aug 28, 2009
    #9
  10. gue22

    Bo Berglund Guest

    Did you check the color depth?
    DefaultDepth 16
    SubSection "Display"
    Depth 16

    Default on most Linux distros now is 24 bit, but that will guarantee a
    garbled screen in VPC. You can use 16 or 32 but NOT 24....
     
    Bo Berglund, Aug 28, 2009
    #10
  11. gue22

    gue22 Guest

    Hey Bo,
    as you may expect from a *reasonable* guy, I took *exaaactly* Ben´s settings
    and although I´m quite literate I made some mistake in copying, so I opened
    this forum in Ubuntu and copied and pasted the settings wich *are* depth 16.
    <g> Didn´t work.

    After some variations (1024x768 or depth 32,..) didn´t work either I tested
    Ben´s conf with 800x600 and it DID work.

    I looked at the SUSE xorg.conf and they are so sufficiently *different* that
    I retreated. They use a different driver too, not vesa.

    Then I thought VertRefresh actually is always 60 on my laptop LCD. Who needs
    160. It doesn´t flicker like a CRT, so I restricted VertRefresh to 50-60.
    Nope.

    I pumped up HorizSync to 30-170, because it´s something like vert refresh x
    res. Nope.

    Out of clues. Ben!
    ???
    Thx
    G.
     
    gue22, Aug 28, 2009
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.