Unable to access companyweb

Discussion in 'Server Networking' started by Mervin Williams, Apr 28, 2005.

  1. I have Microsoft Small Business Server 2003 installed with the SBS intranet
    web site (companyweb) setup, as well. Users who are logged onto the domain
    can access the companyweb site fine, but those who try to access it
    externally receive the error message "The page cannot be displayed."

    Please help!

    Mervin Williams
     
    Mervin Williams, Apr 28, 2005
    #1
    1. Advertisements

  2. Mervin Williams

    Ken Le Gall Guest

    Hi Mervin

    Something to look for - I had the same problem before:

    Have you enabled remote access in CEICW for SharePoint Services ?

    Also, has it always worked or have you recently re-installed companyweb ???

    Ken.
     
    Ken Le Gall, Apr 28, 2005
    #2
    1. Advertisements

  3. Hi Ken,

    I have (sort of) the same problem as Mervin. I run 2003 SE though
    What is CEICW and where do I find it?
    (If this is not it I'll start a new thread)

    TIA

    Peter Paul
    Versatec Energy
    The Netherlands
     
    Peter Paul Jansen, Apr 28, 2005
    #3
  4. We've had two IT companies who were to assist us with our network: the
    first installed the server, and the second disabled ISA. So, we are not
    running ISA. Is this the problem?

    Mervin Williams
     
    Mervin Williams, Apr 28, 2005
    #4
  5. Mervin Williams

    Ken Schaefer Guest

    Please look a little further down the page. Do you see "Cannot find server
    or DNS error" (in which case the browser, IE, can't connect to the server at
    all), or do you see a HTTP status code like 500 Internal Server Error or 404
    Not Found?

    I suspect the issue is name resolution. If you're outside the company LAN,
    how is a client supposed to know what IP address "companyweb" is supposed to
    have?

    Cheers
    Ken

    --
    Blog: www.adopenstatic.com/cs/blogs/ken/
    Web: www.adopenstatic.com


    :I have Microsoft Small Business Server 2003 installed with the SBS intranet
    : web site (companyweb) setup, as well. Users who are logged onto the
    domain
    : can access the companyweb site fine, but those who try to access it
    : externally receive the error message "The page cannot be displayed."
    :
    : Please help!
    :
    : Mervin Williams
    :
    :
     
    Ken Schaefer, Apr 28, 2005
    #5
  6. Mervin Williams

    Ken Le Gall Guest

    OK - to answer both questions:

    (1) CEICW is the Connect Email & Internet Connection Wizard - is in your
    Systems Manager under Internet & eMail Connection - just run it again, and
    don't change anything until you get to a list of services you can click on
    and off - make sure you have RWW and Sharepoint (and one called something
    like wwwroot - I think) clicked ON - also look at the others you may want to
    offer other things too...

    Also, for companyweb I believe you need ports 444, 4125 open on your router
    for SharePoint and RWW.

    (2) I am not running ISA either (I think), so I dont think thats a problem.
    I asked about the re-install as I have just done that myself and found you
    needed to re-apply the server security certificate manually.

    Come back if this does not help.

    Ken.
     
    Ken Le Gall, Apr 28, 2005
    #6
  7. Mervin Williams

    Majero Guest

    Majero, Apr 28, 2005
    #7
  8. After following the information contained in the Microsoft knowledge base
    article, I am now prompted for logon credentials when attempting to access
    the companyweb web site internally, but users outside are still unable to
    connect.

    I mentioned previously that we are not running ISA - I believe we're running
    NAT. How do I configure NAT for SSL and Sharepoint Services?

    Mervin Williams
     
    Mervin Williams, Apr 28, 2005
    #8
  9. Mervin Williams

    Ken Schaefer Guest

    Hi,

    Please undo the changes you made from the KB article.

    With a default SBS install, you already have a website listening on port 443
    (SSL). This is the one called "Default Web Site", and includes the virtual
    directories for Outlook Web Access, OMA and Server Active Sync.

    You can't have multiple SSL secured websites on port 443 if you only have a
    single IP address (unless you get a wildcard SSL certificate, but they are
    fairly expensive).

    The suggestion in the KB article is to make CompanyWeb available on a
    separate port (e.g. 444) when accessing it via SSL.

    - So, on your NAT router you will need to port-forward port 444 to your SBS
    box
    - If you have a DNS name for your public IP address, you would use the
    address https://yourcompany.com:444/ however if you only have an IP address,
    then https://your_IP_address:444/ will also work.

    Cheers
    Ken

    --
    Blog: www.adopenstatic.com/cs/blogs/ken/
    Web: www.adopenstatic.com



    : After following the information contained in the Microsoft knowledge base
    : article, I am now prompted for logon credentials when attempting to access
    : the companyweb web site internally, but users outside are still unable to
    : connect.
    :
    : I mentioned previously that we are not running ISA - I believe we're
    running
    : NAT. How do I configure NAT for SSL and Sharepoint Services?
    :
    : Mervin Williams
    :
    : : > http://support.microsoft.com/default.aspx?scid=kb;en-us;838429
    : >
    : > I don't think you can access the companyweb over the internet by
    default.
    : > The above link provides a workaround that's supposed to make it work.
    : >
    : >
    : >
    : > "Mervin Williams" wrote:
    : >
    : >> I have Microsoft Small Business Server 2003 installed with the SBS
    : >> intranet
    : >> web site (companyweb) setup, as well. Users who are logged onto the
    : >> domain
    : >> can access the companyweb site fine, but those who try to access it
    : >> externally receive the error message "The page cannot be displayed."
    : >>
    : >> Please help!
    : >>
    : >> Mervin Williams
    : >>
    : >>
    : >>
    :
    :
     
    Ken Schaefer, Apr 29, 2005
    #9
  10. Mervin Williams

    mrmmd Guest

    Does the error message say anything like "the server has a list of addresses
    allowed to access this site and yours is not one of them"? If so, you will
    need to change a security setting as well. Go to your server management
    console and choose IIS, navigate to the web site labled companyweb. Right
    click on it and choose properties. In Directory Security choose the second
    EDIT button under IP addresses and Domains. Make sure the IP address in one
    allowed or Grant ALL is chosen.

    I would suggest creating a client connection disk to let the external users
    connect via VPN and have them connect to Remote Web Workspace. From here they
    can connect to the companyweb page, OWA, and even connect to their office
    desktop computer.

    mrmmd
     
    mrmmd, Apr 29, 2005
    #10
  11. Hi Ken,

    I am getting the error described below. How do I fix this? I have to LAn
    Cards in the server. One for the ADSL and the other for the internal LAN.

    ADSL - DNS Prim and Sec configured to look at ISP.
    LAN - DNS configured to look at the server itself ie. 192.168.10.1

    Is this correct? if not what is the correct way to do this? I need this
    fixed cos right now I cannot access OWA from outside or inside.

    Thanks in advance for help.
     
    thatcomputerguy3, May 19, 2005
    #11
  12. Mervin Williams

    ipinet Guest

    I am running ISA server and i'm getting the dns error at the bottom of Page
    cannot be displayed.

    Ipinet
     
    ipinet, Jul 8, 2005
    #12
  13. Marina Roos [SBS-MVP], Jul 9, 2005
    #13
  14. Mervin Williams

    ipinet Guest

    I figured it out. I rebuilt the ISA server and republished Sharepoint on port
    444. That didn't work. In IIS I deleted the web certificate for sharepoint
    and reassigned it. That worked. Thanks for everyones help.
     
    ipinet, Jul 12, 2005
    #14
  15. Mervin Williams

    Carl Gross Guest

    I just saw your response. I am having the same trouble as Mervin. Opening
    port 444 was recommended to me, but I don't know how to open those ports.

    I have a Pix 501 Firewall. I have looked for information on how to open a
    port on the Firewall but no such luck.
     
    Carl Gross, Sep 6, 2005
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.