Unable to delete user profile folders

Discussion in 'Windows Vista General Discussion' started by Tom Ziegmann, Jun 29, 2006.

  1. Tom Ziegmann

    Tom Ziegmann Guest

    Hello,

    Does anyone know how to remove empty user profile folders? I have removed
    the user accounts, the profile from the System Control Panel, yet the
    folders are still there and they won't delete because a security error
    displays telling me I do not have sufficent permission to remove the folder.

    Anyone have any ideas?

    Thanks,

    -tom
     
    Tom Ziegmann, Jun 29, 2006
    #1
    1. Advertisements

  2. Hi,

    Are you doing this from "the" administrator account (as opposed to an admin
    level account)? Is UAP enabled or disabled?

    --
    Best of Luck,

    Rick Rogers, aka "Nutcase" - Microsoft MVP
    http://mvp.support.microsoft.com/
    Windows help - www.rickrogers.org
     
    Rick \Nutcase\ Rogers, Jun 29, 2006
    #2
    1. Advertisements

  3. Tom Ziegmann

    Tom Ziegmann Guest

    I am doing this from my user account with UAP disabled.
     
    Tom Ziegmann, Jun 29, 2006
    #3
  4. Rick \Nutcase\ Rogers, Jun 29, 2006
    #4
  5. Tom Ziegmann

    Tom Ziegmann Guest

    I have taken ownership of the folders, removed the users SID from the
    security tab and the folders still won't delete.

    Any other ideas?
     
    Tom Ziegmann, Jun 29, 2006
    #5
  6. Rick \Nutcase\ Rogers, Jun 29, 2006
    #6
  7. Tom Ziegmann

    Jimmy Brush Guest

    Hello,

    Try deleting them from an "administrator/root" explorer.

    - Click start
    - Type explorer
    - Right-click windows explorer when it shows up
    - Click Run-as administrator

    - JB
     
    Jimmy Brush, Jun 29, 2006
    #7
  8. Tom Ziegmann

    Tom Ziegmann Guest

    Hello,

    I have tried that and that does not work either.
     
    Tom Ziegmann, Jul 1, 2006
    #8
  9. Tom Ziegmann

    Jimmy Brush Guest

    This sounds like an NTFS permissions problem.

    Which is odd ...

    On my system, the user profile directories (in c:\users\) gives
    administrators full control.

    - Out of curiosity ... Did you upgrade?
    - And we are talking about the c:\users\ directory, correct?
    - Do you have View Hidden Files enabled and Hide protected operating system
    files disabled from the View tab of Folder options (under Organize button in
    explorer)?
    - Are you sure the directory is empty?

    Anyway ... you mentioned in an earlier post that you have already taken
    ownership of the folder. That's good. If the directory is not empty, take
    ownership again, and there should be a checkbox there to take ownership of
    all child objects... check that.

    Now, you just need to give Everyone full control, and then it shouldn't mind
    you deleting the folder. If the folder's not empty, check the checkbox that
    will replace all child object permissions with the new one.

    - JB
     
    Jimmy Brush, Jul 1, 2006
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.