Unable to Print or Print Preview from IE7 on Vista Home Premium

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by Poppy, Dec 7, 2007.

  1. Poppy

    Poppy Guest

    I've been struggling with this for some time now.

    The computer is a Toshiba laptop with Vista Home Premium. It prints to the
    USB connected Brother printer with no problem from Word, Excel, Firefox, etc.
    However, it is unable to print HTML documents from either IE7 or Outlook
    (plain text emails in Outlook do print fine)

    There is no response when I select "Print" in IE7. No error, no document
    spooled to the printer. This is consistent no matter which printer I select
    as the default printer. When I select "Print Preview", the print preview
    window opens, but no document is displayed.

    I have:
    - installed an updated, Vista compatible driver for the primary printer
    - installed all available updates for IE
    - changed Outlook to display messages as plain text - which is a work-around
    only
    - disabled UAC
    - disabled "Protected Mode" in IE
    - Run IE as administrator

    So far, nothing has fixed the problem. Has anyone else encountered this? I'm
    seeing a lot of printing problems with Vista, but very few that don't spool a
    document or display an error.
     
    Poppy, Dec 7, 2007
    #1
    1. Advertisements

  2. Poppy

    VegasDood Guest

    Hi Poppy,

    I am having the same problem and it is very frustrating, I have an HP
    printer and HP blames Microsoft, I contacted Microsoft but they said I have
    to either pay the fee for them to tell me what's wrong or I can go to my
    computer manufacturer and ask them for help, either way there is NO help
    anywhere, no one seems to know how to fix this..I have spent almost 2 hours
    looking for an answer in the Windows Vista Community postings but no one has
    posted how to fix this problem..sorry I'm just extremely frustrated.
     
    VegasDood, Jan 25, 2008
    #2
    1. Advertisements

  3. Poppy

    garydean01 Guest

    Yes, I have a new HP dv6404 laptop running Vista and IE7 and when I
    print from IE7 I get the following error message:

    Line: 14

    Char: 1

    Error: Library not registered

    Code: 0

    URL: res://ieframe.dll/preview.dlg

    (when I click on "yes" or "no" at the prompt, the error messages
    changer slightly from Line: 14 to Line: 439)

    I have switched to Firefox because I have tried all the fixes on the
    net without resolving the problem. There is no way to reinstall IE7 on
    Vista, no standalone IE7 software to install over the broken IE7 and
    no way to uninstall IE7 from Vista that I have found.

    What a way to run a multi-billion dollar company by using customers as
    the beta tester guinea pigs until enough people complain and they
    develop a patch! Now their are alternatives and so they had better
    start making more robust and bug-free software or they won't be around
    in a decade.
     
    garydean01, Jan 30, 2008
    #3
  4. Poppy

    BruceH Guest

    I had this problem for a long time (almost a year I guess - gave u
    eventaully). After a recent rebuild I did some more searching and foun
    a solution: did you by chance move the location of your FAVORITE
    folder?

    I moved the Favorites folder to my data drive. Apparently IE7 i
    protected mode runs in a limited security mode and windows does no
    automatically set the sharing security properly when this folder i
    moved.
    (Which is why the protected mode diable fix works

    I had to go to my Favorites folder. Right click on Properties then g
    to the Security tab. Make sure that your user ID has full contro
    marked. (Mine did not when I checked).

    As soon as I set myself for Full Control, IE7 started printing agai
    (on second attempt

    Hope this is helpfull to other. :
     
    BruceH, Apr 14, 2008
    #4
  5. Poppy

    MKM Guest

    Assuming you're running Vista... this is what worked for me when I
    experienced the same problem. Right click on the Internet Explorer icon
    on the desktop, then click on properties, then click the shortcuts tab,
    then choose the advanced tab (in the lower right corner) and then check
    "Run as Admisinstrator" box and click OK. This solved my problem - hope
    it works for you!
     
    MKM, May 12, 2008
    #5
  6. Poppy

    Tony Zamboni Guest

    I can not make changes in that box to check "Run as Admisinstrator" as the
    box is greyed out. I tried signed in as Administrator and user and can not
    make changes in either. I will attempt to make a new shortcut from the .exe
    file and see if I can make the changes.
    My problems started when I did MS update KB929547 and Update to AVG free 8.0
    The KB929547 was required by AVG to install the update.
     
    Tony Zamboni, May 12, 2008
    #6
  7. Poppy

    Mate Guest

    See following post

    Re: Internet Explorer 7 Does Not Allow Printing


    ________________


    Mate
     
    Mate, May 12, 2008
    #7
  8. Poppy

    MKM Guest

    I don't know why that area (Run as Administrator) would be greyed ou
    for you. Sorry that my fix didn't work for you. I don't know if thi
    next tip will help you but it's worth a try... Try making your use
    account in IE7 have full control. See the following link fo
    information about User Account Control permissions: 'Understanding an
    Configuring User Account Control in Windows Vista
    (http://technet.microsoft.com/en-us/windowsvista/aa906025.aspx#ECG)
     
    MKM, May 13, 2008
    #8
  9. Poppy

    Christopher Guest

    Running as administrator turns off the protected mode which might work for
    printing but which does nothing good for security.

    It is a great shame that Microsoft does give a **** for consumers that have
    this problem, of which there are many.
     
    Christopher, May 13, 2008
    #9
  10. Poppy

    gadgetlover Guest

    Well, you might just have hit the nail on the head there Bruce! I
    always "move" my favourites folder to a different partition and that
    caused a problem with adding websites to my favourites once because it
    was marked as Read Only.

    But it had never caused any problems with blank or very slow print
    previews until I did a clean install of Windows 7 64-bit! *But after
    installing Windows 7, I got all sorts of problems trying to print from
    IE8*, the worst of which was when I sent pages to my Epson Printer, the
    display would go black for a few seconds every time the print preview
    opened! I tried all the fixes I could find, including uninstalling and
    reinstalling my Nvidia drivers (two or three times!) but nothing cured
    the problem. So as a workaround I unchecked Print Preview in my Epson
    preferences and now I just use Windows print preview -before- I select
    the printer instead.

    But although Windows print preview opened OK, it would sometimes take
    ages to display the document. But I just followed your advice - and the
    print preview seems to come up MUCH quicker now! So thank you very much
    indeed for the tip!
     
    gadgetlover, Nov 9, 2009
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.