Unable to reach SBS Server through RWW

Discussion in 'Windows Small Business Server' started by Chester, Dec 10, 2004.

  1. Chester

    Chester Guest

    Hello, when I am on the road, and need access to my SBS server, I thought
    I'd just use RWW. HOwever, when I select Connect to Servers, and then select
    my server, (The only one available) I receive the following error.

    "The client could not connect to the remote computer. Remote connections
    might not be enabled or the computer might be too busy to accept new
    connections. It is also possible that network problems are preventing your
    connection. Please try connecting again later. If the problem continues to
    occur, contact your administrator."

    I've unchecked the "I'm using a shared computer" box on the login for RWW.

    I've also made sure that there are no users logged into the server.

    I've logged into RWW with my credentials (Administrative rights on the
    domain), and I've even tried logging into RWW with the top-level server
    username/password. No luck!

    If I'm on companyweb, and I use the Remote Server Access link, everything
    works fine.

    What am I missing? *Should* I be able to access the server through RWW?

    Thanks a lot!

    Chester
     
    Chester, Dec 10, 2004
    #1
    1. Advertisements

  2. Does RDP work inside the network (i.e. from a lan client to the server) ?

    Have you got any workstations you can connect to via RWW? If you get the
    same behaviour, perhaps port 4125 isn't open ? Or, if you've opened 3389,
    try to connect direcly to the server desktop with RDP.
     
    Les Connor [SBS Community Member], Dec 10, 2004
    #2
    1. Advertisements

  3. Chester

    Chester Guest

    Hello Les,
    Yes, I am able to use RDP inside the network. I can also connect to
    workstations on the network using RWW from the outside. It's just the
    server.

    I guess I should say at this point how our network is setup.

    DSL Modem>Hub>SBS Nic1 >< SBS Nic2>Switch>Workstations

    On the SBS Standard server firewall, Remote Desktop and RWW (4125) are both
    enabled.

    Any ideas? Thanks!

    Chester

     
    Chester, Dec 10, 2004
    #3
  4. Hi Chester,

    Can you log into the server from inside the network via RWW ? And with RDP ?

    --
    Les Connor [SBS Community Member]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member], Dec 10, 2004
    #4
  5. Chester

    Chester Guest

    Hello Les,
    Sorry, I guess I wasn't very clear earlier.

    When I use a client on the internal network, I can connect to the server
    using RDP. I can also connect to the server by going to companyweb, and
    using the Remote Server Management link in the upper right hand corner.
    However, if I am using a client on the local lan, and I try to use
    <external IP address>/remote, I am unable to connect to the server.

    Thanks!

    Chester
     
    Chester, Dec 10, 2004
    #5
  6. However, if I am using a client on the local lan, and I try to use
    The above isn't likely going to work, and doesn't indicate a problem. You
    have to try it remotely, have you done that?

    If you're connecting from outside, use https://<external IP address>/remote.
    Ensure that when you run CEICW, you use <external IP address> as the name
    for your certificate.

    --
    Les Connor [SBS Community Member]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member], Dec 10, 2004
    #6
  7. Chester

    Chester Guest

    Hello Les,
    Yes, I sure have tried it from outside the network. That is what made me
    realize I had a problem.
    Yes, I tried "https", but that gives me the same error.

    Any other ideas?

    Chester
     
    Chester, Dec 10, 2004
    #7
  8. If RWW and connect to client computers works from outside, then RWW 4125 and
    443 must be open, so the issue wouldn't be there.

    Do you still have *the* Administrator account on the SBS, or have you
    changed it in some way (renamed, changed group memberships, etc.). If that
    account is intact, does it work ?

    On the SBS | My Computer > remote tab, ensure that the domain account you
    are using to connect in RWW is allowed.

    Alternately (as a test, or permanently), run CEICW and ensure that port 3389
    (TS) is allowed. Then try a RDP connection to <PUBLIC_IP> and see if you can
    log onto the server directly, bypassing RWW. If that doesn't work, try
    telnet <public_ip> 3389 and see if you get a blank screen and blinking
    cursor, which indicates a connection.

    We need to discover whether this is a connectivity configuration issue
    (doesn't appear to be), or a user account permissions issue (most likely).

    --
    Les Connor [SBS Community Member]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member], Dec 10, 2004
    #8
  9. Chester

    Chester Guest

    Thank you Les. I've checked some of this out, and just thought I'd update
    here.

    Yes, RWW is enabled on the SBS box. (My Computer >Remote tab, enable remote
    connections) I even added myself as an authorized user just because.

    I also checked port 3389, and it gives me the requisite blank screen and
    blinking cursor, signifying that the port is open.

    Now, when I try to do a RDP to the public IP, I get an error about
    encryption!

    I will hopefully be able to try this connection from the outside network
    soon, and let you know.

    Thank you!

    Chester
     
    Chester, Dec 13, 2004
    #9
  10. Don't try RDP to your public IP, from a workstation on the lan. That's
    unlikely to work, so don't be surprised.

    If/when you get an error, please post the exact text of the error. Remember,
    we can't see what you see ;-).

    --
    Les Connor [SBS Community Member]
    -----------------------------------------------------------
    SBS Rocks !


     
    Les Connor [SBS Community Member], Dec 13, 2004
    #10
  11. Chester

    Chester Guest

    (posting this with a bowed head, and my tail between my legs.) Ahem. After
    working through several suggestions, and getting stumped, I was asked by a
    helpful party if I had Port 4125 forwarded from my router to my external
    NIC. Upon checking, I realized I did not for some reason! And therein lies
    the answer to my problems!

    Thanks for your help Les!

    Chester
     
    Chester, Dec 15, 2004
    #11
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.