Unable to Remove Printers in Control Panel

Discussion in 'Windows Vista Printing / Faxing / Scanning' started by mishutka, May 7, 2008.

  1. mishutka

    mishutka Guest

    I'm at my wits' end and don't know what to do next -- HELP!

    I have Vista Home Premium on a 36-bit computer. I unstalled a local USB
    Dell printer and it was working fine. Then it started printing tiny
    letters, then stopped printing at all and printer icons disappeared
    from the Control Panel.

    I used Windows Update and installed Service Pack 1. The printer icons
    are back, but there are now multiple copies of the printer which I'm
    unable to delete. At restart, the printer prints the same page each
    time.

    I went into Services, stopped and restarted the spooler to no effect.
    Would appreciate any thoughts on how to fix this.
     
    mishutka, May 7, 2008
    #1
    1. Advertisements

  2. right click on the printer
    Run as administrator
    Delete

    Only the Owner can delete the printer when not running as administrator and
    Plug and Play does not create the printer in the users context.

    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Alan Morris [MSFT], May 7, 2008
    #2
    1. Advertisements

  3. mishutka

    mishutka Guest

    Thanks, Alan, I tried that before and it didn't work either. I'm the
    only user on this machine and my account is set as administrator.
     
    mishutka, May 7, 2008
    #3
  4. Make sure you delete any pending print jobs. The printer cannot be deleted
    until the print jobs are deleted.

    --
    Alan Morris
    Windows Printing Team
    Search the Microsoft Knowledge Base here:
    http://support.microsoft.com/search/?adv=1

    This posting is provided "AS IS" with no warranties, and confers no rights.
     
    Alan Morris [MSFT], May 8, 2008
    #4
  5. mishutka

    mishutka Guest

    I deleted all printing jobs from the queue, and stopped and restarted
    the spooler. But when I restart the computer, the printer prints one of
    my e-mail messages (same each time). Where else could a pending job be
    "hiding"? Thanks for your help!
     
    mishutka, May 8, 2008
    #5
  6. mishutka

    Tom Ferguson Guest

    You might have to navigate to ...\spool\printers in Windows explorer and
    delete all the file there if you have not already).
     
    Tom Ferguson, May 9, 2008
    #6
  7. mishutka

    mishutka Guest

    I manually deleted the files from the .../spool/printers folder -- BU
    there are 2 persistent .shd files that won't delete ("file is in use"
    even after reboot. Any ideas on how I can purge them? Many thanks
     
    mishutka, May 16, 2008
    #7
  8. mishutka

    .Joe Guest

    Try booting into safe mode and then try deleting them. I had a simila
    issue with my printer and safe mode allowed me to delete the files

    --
    .Jo

    _[image
    http://uswave.net/vistax64/joetmvx64.png] (\"http://uswave.net/vistax64/joetmvx64.png\")_
    _*::Vista_Forums::* (\"http://www.vistax64.com/\")_
    _Geekbench_Score:_4031 (\"http://browse.geekbench.ca/geekbench2/view/51273\")_
    _CPU-Z (\"http://valid.x86-secret.com/show_oc.php?id=345866\")_
     
    .Joe, May 16, 2008
    #8
  9. mishutka

    mishutka Guest

    Booting in safe mode and deleting .shd files from .../spool solved th
    problem! Thank you so much for your help
     
    mishutka, May 21, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.