unable to run a scheduled task

Discussion in 'Windows Server' started by Rosana Almada, Nov 6, 2006.

  1. Hallo, my problem is that any user that want to run scheduled task can do it
    except when the session is closed. Only a user that belongs to a
    administrator's group can do it. The users need to run some task overnight
    while they are not in the office. They scheduled the task with the username
    and password, they execute them and they run, but while the session is closed
    they never run by them self...

    I will be very thankful for some help....
    Rosana Almada
     
    Rosana Almada, Nov 6, 2006
    #1
    1. Advertisements

  2. Run the task with a dedicated account instead of the user's
    logon account.
     
    Pegasus \(MVP\), Nov 6, 2006
    #2
    1. Advertisements

  3. Thank you Pegasus for your help.
    My question now is how i set a dedicated user? This user can not belongs to
    administrator's groups because i can not give the password to the users. The
    operative system is Windows Server 2003. The service Scheduled Task ir
    running with a system account.

    Regards,
    Rosana.
     
    Rosana Almada, Nov 7, 2006
    #3
  4. 1. Create an acount such as "Schedule" with the appropriate
    privileges.
    2. Use the Task Scheduler via the Control Panel to create
    your task. Specify "Schedule" when prompted for an
    account name.
     
    Pegasus \(MVP\), Nov 7, 2006
    #4
  5. Hallo, i did what you inform me. I create a user that belongs to a Operator
    Backup (this is the right that have the other users). I create a task with
    this account name and i close the session. The task never runs... what i'm
    doing wrong? what privileges i'm missing?

    Thank you very much again.

    Rosana.
     
    Rosana Almada, Nov 7, 2006
    #5
  6. If I had received a dollar for every time someone claimed that
    a scheduled event never ran, I would have a tidy fortune by
    now . . .

    Before you can make this sort of claim, you must verify it.
    Schedule the following batch file, then examine c:\test.log
    and report the result.

    @echo off
    echo %date% %time% Start of task > c:\test.log
    echo User=%UserName%, Path=%path% >> c:\test.log
    dir c:\ >> c:\test.log
    echo %date% %time% End of task >> c:\test.log
     
    Pegasus \(MVP\), Nov 7, 2006
    #6
  7. I really don't know what to do.... the task "never" start, then never create
    logs... before i wrote here i probe everything, including to make a copy of
    files with a .bat executable that copy files from one folder to another. If i
    run the task by my self, execute without problem (right click on the task and
    later run). If i schedule the task and i close the session, never run and in
    the scheduled task log tell me the sentences i write below. With your batch i
    have the same result. thanks again for your help
    Error:
    ""algo.job" (algo.bat) 06/11/2006 10:43:00 ** ERROR **
    No se puede iniciar la tarea.
    El error específico es:
    0x80070005: Acceso denegado.
    Pruebe usando el botón Examinar de la página Tarea para encontrar la
    aplicación."

    -----------------------------------------
     
    Rosana Almada, Nov 8, 2006
    #7
  8. I speak several languages but Spanish is not one of them.
    I suggest you post your question in a Spanish newsgroup.

    My guess is that the error message tells you that the account
    you used to launch the scheduled task is not authorised to
    run such tasks. If so then you must run gpedit.msc and follow
    this path:
    Local Computer Policy / Computer Configuration / Windows Settings /
    Security Settings / Local Policy / User Rights / Logon as a batch job.
     
    Pegasus \(MVP\), Nov 8, 2006
    #8
  9. You should learn spanish, is the second language in the world... and growing
    up...

    the user have this rights too, i verify it... i give up with this thema....
    i am searching for another solution without scheduled tasks....

    thanks for everything.
     
    Rosana Almada, Nov 9, 2006
    #9
  10. While Spanish is a very important language, I think your
    numbers are not quite correct. I suspect that Chinese is
    spoken by the greatest number of people, followed by
    English, then Arabic (which I am learning), followed by
    Spanish. But perhaps I'm wrong.
     
    Pegasus \(MVP\), Nov 9, 2006
    #10
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.